v0.10.16 - Onyx v2

darklord1981

New Member
Jun 26, 2014
35
4
8
I just got home from work. Out of 4 masternodes I manage, three were offline. The one that was online still had the cold wallet on my home PC open.

I've just ran the command grep HotCold .darkcoin/debug.log

Maybe it will help with the cold/hot wallet setup. I guess i'll know in an hour.
 

Lebubar

Active Member
Mar 15, 2014
249
213
103
Know what, I got a feeling of keeping the local online.
So the 2 MN updated on 16.8,I leave one local wallet online and see..
For the moment not exactly one hour. but both of them are still listed...
 

jiggytom

Member
Nov 14, 2014
104
22
68
I just got home from work. Out of 4 masternodes I manage, three were offline. The one that was online still had the cold wallet on my home PC open.

I've just ran the command grep HotCold .darkcoin/debug.log

Maybe it will help with the cold/hot wallet setup. I guess i'll know in an hour.
That command does nothing...just searches the debug log. I'd say shut down both sides, restart and leave both open.
 

Lebubar

Active Member
Mar 15, 2014
249
213
103
That command does nothing...just searches the debug log. I'd say shut down both sides, restart and leave both open.
Don't want to leave my local wallet online... As it go dirctly cold after start, and I got 6 local wallet so can't leave online all. or intall 6 vm on my PC =)
 

GilAlexander

Member
Jun 26, 2014
84
23
48
Know what, I got a feeling of keeping the local online.
So the 2 MN updated on 16.8,I leave one local wallet online and see..
For the moment not exactly one hour. but both of them are still listed...
I was keeping it online all the day and it didn't change anything (16.6-16.7). Have listed mn too on 16.8, go to bed now. Will post tomorrow.
 

UdjinM6

Official Dash Dev
Dash Core Team
Moderator
May 20, 2014
3,638
3,538
1,183
Aaaaaalright! New patch suggestion ;)

To let remote nodes correctly send dseep this line https://github.com/darkcoin/darkcoin/blob/master/src/activemasternode.cpp#L127 should be
Code:
if(isCapableMasterNode != MASTERNODE_IS_CAPABLE && isCapableMasterNode != MASTERNODE_REMOTELY_ENABLED)  return;
Also there is a bug in ThreadCheckDarkSendPool
https://github.com/darkcoin/darkcoin/blob/master/src/darksend.cpp#L1987
It would work fine if this https://github.com/darkcoin/darkcoin/blob/master/src/masternode.h#L35 wasn't an expression.
Right now it will start spam the network every 20 seconds and not minutes as it seems.

So these 4 lines https://github.com/darkcoin/darkcoin/blob/master/src/masternode.h#L34-L37 should be
Code:
#define MASTERNODE_MIN_SECONDS                 (5*60)
#define MASTERNODE_PING_SECONDS                (20*60)
#define MASTERNODE_EXPIRATION_SECONDS          (65*60)
#define MASTERNODE_REMOVAL_SECONDS             (70*60)
It's only 2nd line that matters now but just to keep things consistent I would suggest to fix them all.
eduffield
 

DrkMiner

Member
Jun 7, 2014
204
63
88
v8 looks ok so far...

I'm running a shell script to check my nodes every 5 min.
been 1 hour so far.

Edit: oops all nodes return :0 now :sad: .... now the are not on the MN list.
 
Last edited by a moderator:

Lebubar

Active Member
Mar 15, 2014
249
213
103
MN5 dissapear again but only from MN6 list and his own list... hmmm still something:
[email protected]:~$ date ; ./grepMN.sh
Sat Nov 15 17:05:54 EST 2014
MN1
"108.x.x.x:9999" : 1,
MN2
"104.x.x.x:9999" : 1,
MN3
"108.x.x.x:9999" : 1,
MN4
"108.x.x.x:9999" : 1
MN5
MN6
"128.x.x.x:9999" : 1,

with all other MN5 is listed fine..
Have to wait more...
 

Lebubar

Active Member
Mar 15, 2014
249
213
103
v8 looks ok so far...

I'm running a shell script to check my nodes every 5 min.
been 1 hour so far.

Edit: oops all nodes return :0 now :sad: .... now the are not on the MN list.
Same here ...
[email protected]:~$ while [ 1 -eq 1 ]; do sleep 60; date; ./grepMN.sh ; done
Sat Nov 15 22:38:32 UTC 2014
MN1
MN2
MN3
"108.xx.x.x:9999" : 0,
MN4
"108.x.x.x:9999" : 0,
MN5
MN6
...
...
Sat Nov 15 22:46:32 UTC 2014
MN1
MN2
MN3
MN4
MN5
MN6


Ok will try again with leaving one local wallet online more time (I stop one after 1 hour and the MN was listed for little more than 2 hours)....
 

jiggytom

Member
Nov 14, 2014
104
22
68
I spoke to soon, mine just went to 0 status on v8.

edit.. ..it didn't seem to happen during the first hour when I had my local wallet closed, but in the 2nd hour after I closed my local wallet.

edit 2...and she's gone from the list.

edit 3: went to local wallet, masternode start...and it's back to 1.
 

Lebubar

Active Member
Mar 15, 2014
249
213
103
dont you people have the "inbound port not open" error when starting masternode from local machine? I would need to take v6 to start from local machine, v7 and v8 give the error
No I don't have, but other people (Tante2, gwghwgk2hg2h) report the same..
Are you all on the same vps provider? (aws?)
 

Lebubar

Active Member
Mar 15, 2014
249
213
103
So I just re-start the MN1 from local (and I will leave the local wallet online just by curiosity)
And MN4 appeared again online (I do all the start from local, from the same PC (just changing conf file) and the MN4 was the last I start during my last test)
Sat Nov 15 18:04:37 EST 2014
MN1
"108.x.x.x:9999" : 1,
MN2
MN3
MN4
"108.x.x.x:9999" : 1
MN5
MN6
 

Lebubar

Active Member
Mar 15, 2014
249
213
103
no I am using digital ocean. so i only got the error with v7 and v8, with v6 its working! it got nothing to do with the server i would say
Well one of my MN is on DigitalOcean too, and no problem with v6, 7, and 8...
Did you remove peer.dat (from local and remote)?
 

olymp

New Member
Sep 3, 2014
21
4
3
My MN (v 16.6) is on vultr.com and went offline after ~1h after getting online. Just updated to v16.8 and will continue to watch.
 

jiggytom

Member
Nov 14, 2014
104
22
68
we supposed to try this ?
Zero payments since yesterday !
He's still working on it..don't think its done.

tungfa...update to 16.8..and keep your local wallet on. I dont think anything below 16.6 is supposed to get paid any more.
 

tungfa

Administrator
Dash Core Team
Moderator
Foundation Member
Masternode Owner/Operator
Apr 9, 2014
8,895
6,723
1,283
He's still working on it..don't think its done.

tungfa...update to 16.8..and keep your local wallet on. I dont think anything below 16.6 is supposed to get paid any more.
tx man
too many MN's to keep all wallets open !

can not find 16.8 ?!

a friend got paid across all his MN's on 16.6 !
 

jiggytom

Member
Nov 14, 2014
104
22
68
for 16.8 evan only posted the linux binaries..>I use 16.7 local wallet and that worked. search for his posts on BCT, I can't post the whole link:

BCTURL/index.php?action=profile;u=107946;sa=showPosts to see evan's posts on bct
 

MrMime

Well-known Member
Foundation Member
Mar 9, 2014
169
36
188
Ya I got two payments today on 16.6 but kept fluttering them on. THIS IS GENTLEMEN
 

eduffield

Core Developer
Mar 9, 2014
1,084
5,319
183
Aaaaaalright! New patch suggestion ;)

To let remote nodes correctly send dseep this line https://github.com/darkcoin/darkcoin/blob/master/src/activemasternode.cpp#L127 should be
Code:
if(isCapableMasterNode != MASTERNODE_IS_CAPABLE && isCapableMasterNode != MASTERNODE_REMOTELY_ENABLED)  return;
Also there is a bug in ThreadCheckDarkSendPool
https://github.com/darkcoin/darkcoin/blob/master/src/darksend.cpp#L1987
It would work fine if this https://github.com/darkcoin/darkcoin/blob/master/src/masternode.h#L35 wasn't an expression.
Right now it will start spam the network every 20 seconds and not minutes as it seems.

So these 4 lines https://github.com/darkcoin/darkcoin/blob/master/src/masternode.h#L34-L37 should be
Code:
#define MASTERNODE_MIN_SECONDS                 (5*60)
#define MASTERNODE_PING_SECONDS                (20*60)
#define MASTERNODE_EXPIRATION_SECONDS          (65*60)
#define MASTERNODE_REMOVAL_SECONDS             (70*60) this
It's only 2nd line that matters now but just to keep things consistent I would suggest to fix them all.
eduffield
Thankyou! You're a genius, this is definitely what's causing our issues. I'll get the patch out right away