v0.10.9.x Help test RC2 forking issues

Status
Not open for further replies.

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,287
2,406
1,183
Germany
I just updated my masternode, deleted blockchain and flushed peers. Now I am stuck at 2308 with 0 connections. Whats wrong?
Give these a try :)

Code:
addnode=23.23.186.131
addnode=188.226.248.36
addnode=184.73.179.187
addnode=54.183.73.24
addnode=87.230.94.57
addnode=54.198.19.83
addnode=54.76.52.216
addnode=54.215.181.251
addnode=91.218.156.233
addnode=50.191.199.127
addnode=54.80.186.130
addnode=54.198.109.108
addnode=112.175.123.94
addnode=50.17.76.216
addnode=23.23.55.5
addnode=54.86.103.191
 
  • Like
Reactions: vertoe

minersday

Member
Apr 9, 2014
77
19
48
--reindexed
, error from log
2014-06-03 09:20:24 trying connection 54.83.73.204:19999 lastseen=11.7hrs
2014-06-03 09:20:25 received: getheaders (37 bytes)
2014-06-03 09:20:25 getheaders 13266 to 00000000d109fee334c5b21cddbb65c5704a4eed4d9dbc3e7f018a987cea9015
2014-06-03 09:20:25 sending: headers (83 bytes)
2014-06-03 09:20:29 connection timeout
2014-06-03 09:20:29 ThreadRPCServer method=submitblock
2014-06-03 09:20:29 ThreadRPCServer method=submitblock
2014-06-03 09:20:29 trying connection 54.87.121.203:19999 lastseen=4.2hrs
2014-06-03 09:20:29 ThreadRPCServer method=submitblock
2014-06-03 09:20:29 ThreadRPCServer method=submitblock
2014-06-03 09:20:34 received: dssu (13 bytes)
2014-06-03 09:20:34 received: inv (37 bytes)
2014-06-03 09:20:34 got inventory: block 000000009e452c60c44430b4aec68a6ca4dcaf969445ebf556d54676c212edb8 new
2014-06-03 09:20:34 askfor block 000000009e452c60c44430b4aec68a6ca4dcaf969445ebf556d54676c212edb8 0 (00:00:00)
2014-06-03 09:20:34 sending getdata: block 000000009e452c60c44430b4aec68a6ca4dcaf969445ebf556d54676c212edb8
2014-06-03 09:20:34 sending: getdata (37 bytes)
2014-06-03 09:20:34 connection timeout
2014-06-03 09:20:34 received: block (723 bytes)
2014-06-03 09:20:34 received block 000000009e452c60c44430b4aec68a6ca4dcaf969445ebf556d54676c212edb8
2014-06-03 09:20:34 CheckBlock() : hashPrevBlock != pindexPrev->GetBlockHash() : 0000000041c1c223cb0d2db2baa33ef8f9aa82cdd06cfba0fd8500975c87644b != 00000000d109fee334c5b21cddbb65c5704a4eed4
d9dbc3e7f018a987cea9015
2014-06-03 09:20:34 ERROR: CheckBlock() : pblock->hashPrevBlock != blockLast->GetBlockHash()
2014-06-03 09:20:34 ERROR: ProcessBlock() : CheckBlock FAILED
2014-06-03 09:20:34 Misbehaving: 54.86.103.191:19999 (0 -> 100) DISCONNECTING
2014-06-03 09:20:34 disconnecting node 54.86.103.191:19999
2014-06-03 09:20:35 trying connection 54.76.47.232:19999 lastseen=0.7hrs
2014-06-03 09:20:37 received: ping (8 bytes)
2014-06-03 09:20:37 sending: pong (8 bytes)
2014-06-03 09:20:39 ThreadRPCServer method=submitblock
2014-06-03 09:20:39 ThreadRPCServer method=submitblock
2014-06-03 09:20:39 ThreadRPCServer method=submitblock
2014-06-03 09:20:39 ThreadRPCServer method=submitblock
2014-06-03 09:20:40 connection timeout

getinfo
{
"version" : 90501,
"protocolversion" : 70015,
"walletversion" : 60000,
"balance" : 896.13249801,
"blocks" : 13266,
"timeoffset" : 0,
"connections" : 7,
"proxy" : "",
"difficulty" : 0.59807259,
"testnet" : true,
"keypoololdest" : 1401551609,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"mininput" : 0.00001000,
"errors" : ""
}
Tue Jun 3 12:26:15 EEST 2014
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
Give these a try :)

Code:
addnode=23.23.186.131
addnode=188.226.248.36
addnode=184.73.179.187
addnode=54.183.73.24
addnode=87.230.94.57
addnode=54.198.19.83
addnode=54.76.52.216
addnode=54.215.181.251
addnode=91.218.156.233
addnode=50.191.199.127
addnode=54.80.186.130
addnode=54.198.109.108
addnode=112.175.123.94
addnode=50.17.76.216
addnode=23.23.55.5
addnode=54.86.103.191
Thanks
 

minersday

Member
Apr 9, 2014
77
19
48
xxxxx --testnet listaddressgroupings
[
[
[
"n1gvBwfPGaUt5KAFko2s5pmZfJqc1Spkga",
0.00000000,
"0"
]
],
[
[
"mtPDe3eMkhsDfFTJznm5kubrSpz1uKRqkz",
896.13249801,
"0"
]
]
]
xxxx --testnet getaccountaddress 0
mwmHyUyiZXFTxEitYcGDsKrUsu4m9eEkRp

is this correct?
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
I'm still getting no connections.
Code:
    "version" : 100901,
    "protocolversion" : 70015,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 0,
    "timeoffset" : 0,
    "connections" : 0,
    "proxy" : "",
    "difficulty" : 0.00024414,
    "testnet" : true,
    "keypoololdest" : 1401783301,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "mininput" : 0.00001000,
    "errors" : ""
Trying to add nodes gives me the following
Code:
 ~$ darkcoind addnode 23.23.186.131 add
error: {"code":-23,"message":"Error: Node already added"}
Any idea?
 

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,287
2,406
1,183
Germany
I'm still getting no connections.
Code:
    "version" : 100901,
    "protocolversion" : 70015,
    "walletversion" : 60000,
    "balance" : 0.00000000,
    "blocks" : 0,
    "timeoffset" : 0,
    "connections" : 0,
    "proxy" : "",
    "difficulty" : 0.00024414,
    "testnet" : true,
    "keypoololdest" : 1401783301,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "mininput" : 0.00001000,
    "errors" : ""
Trying to add nodes gives me the following
Code:
 ~$ darkcoind addnode 23.23.186.131 add
error: {"code":-23,"message":"Error: Node already added"}
Any idea?
Try the next in the list, or put all of them into a darkcoin.conf file? I am not adding the nodes manually here ;)

darkcoinf.conf
Code:
rpcuser=darkcoinrpc
rpcpassword=supersecretpassword
testnet=1
daemon=1
logtimestamps=1
maxconnections=32
timeout=15000
masternode=1
masternodeprivkey=<masternode genkey output>
addnode=23.23.186.131
addnode=188.226.248.36
addnode=184.73.179.187
addnode=54.183.73.24
addnode=87.230.94.57
addnode=54.198.19.83
addnode=54.76.52.216
addnode=54.215.181.251
addnode=91.218.156.233
addnode=50.191.199.127
addnode=54.80.186.130
addnode=54.198.109.108
addnode=112.175.123.94
addnode=50.17.76.216
addnode=23.23.55.5
addnode=54.86.103.191
 

minersday

Member
Apr 9, 2014
77
19
48
EDIT: found out why it didn't start syncing blocks,
I did not shutdown p2pool which was using the darkoind,
stopped darkcoind removed everything but wallet.dat
and started darkcoind.. this procedure did not start syncing blocks.

when I stopped the p2pool did the same procedure to darkcoind
it started syncing the blocks.


------------------------------------------------
And now I am stuck with this problem also.
I deleted all the files except wallet.dat and darkcoind

{
"version" : 90501,
"protocolversion" : 70015,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 0,
"timeoffset" : 0,
"connections" : 8,
"proxy" : "",
"difficulty" : 0.00024414,
"testnet" : true,
"keypoololdest" : 1401551609,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"mininput" : 0.00001000,
"errors" : ""
}
using:
rpcuser=xxxxxxxxxxxxxxxxx
rpcpassword=xxxxxxxxxxxxxxxxxxx
rpcallowip=*
gen=0
server=1
daemon=1
addnode=54.200.165.131
testnet=1
debug=1
logtimestamps=1
maxconnections=32
timeout=15000
addnode=23.23.186.131
addnode=188.226.248.36
addnode=184.73.179.187
addnode=54.183.73.24
addnode=87.230.94.57
addnode=54.198.19.83
addnode=54.76.52.216
addnode=54.215.181.251
addnode=91.218.156.233
addnode=50.191.199.127
addnode=54.80.186.130
addnode=54.198.109.108
addnode=112.175.123.94
addnode=50.17.76.216
addnode=23.23.55.5
addnode=54.86.103.191



Try the next in the list, or put all of them into a darkcoin.conf file? I am not adding the nodes manually here ;)

darkcoinf.conf
Code:
rpcuser=darkcoinrpc
rpcpassword=supersecretpassword
testnet=1
daemon=1
logtimestamps=1
maxconnections=32
timeout=15000
masternode=1
masternodeprivkey=<masternode genkey output>
addnode=23.23.186.131
addnode=188.226.248.36
addnode=184.73.179.187
addnode=54.183.73.24
addnode=87.230.94.57
addnode=54.198.19.83
addnode=54.76.52.216
addnode=54.215.181.251
addnode=91.218.156.233
addnode=50.191.199.127
addnode=54.80.186.130
addnode=54.198.109.108
addnode=112.175.123.94
addnode=50.17.76.216
addnode=23.23.55.5
addnode=54.86.103.191
 
Last edited by a moderator:

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,287
2,406
1,183
Germany
And now I am stuck with this problem also.
I deleted all the files except wallet.dat and darkcoind
Tried the same here 5 minutes ago, and just used one of my own masternodes to bootstrap - downloaded the complete blockchain in 2 minutes

Code:
addnode=184.73.179.148
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
Try the next in the list, or put all of them into a darkcoin.conf file? I am not adding the nodes manually here ;)
Hey, I'm not that stupid. ;)

After one hour still no connections. This is my config:

Code:
testnet=1

rpcuser=***
rpcpassword=***
rpcallowip=127.0.0.1
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=512
masternode=1

# add seednodes
addnode=23.23.186.131
addnode=188.226.248.36
addnode=184.73.179.187
addnode=54.183.73.24
addnode=87.230.94.57
addnode=54.198.19.83
addnode=54.76.52.216
addnode=54.215.181.251
addnode=91.218.156.233
addnode=50.191.199.127
addnode=54.80.186.130
addnode=54.198.109.108
addnode=112.175.123.94
addnode=50.17.76.216
addnode=23.23.55.5
addnode=54.86.103.191

### change stuff below
externalip=***
masternodeprivkey=***
 

minersday

Member
Apr 9, 2014
77
19
48
Some more..
2014-06-03 10:52:04 CDarkSendPool::NewBlock
2014-06-03 10:52:04 ProcessBlock: ACCEPTED
2014-06-03 10:52:04 sending: inv (37 bytes)
2014-06-03 10:52:04 received: getblocks (837 bytes)
2014-06-03 10:52:04 getblocks 13046 to 0000000000000000000000000000000000000000000000000000000000000000 limit 500
2014-06-03 10:52:04 sending: inv (37 bytes)
2014-06-03 10:52:04 received: block (1580 bytes)
2014-06-03 10:52:04 received block 00000000b51267dbe5798d4589c054d8da82bb219230bc58ec03ea0c4cfd31fb
2014-06-03 10:52:04 Committing 20 changed transactions to coin database...
2014-06-03 10:52:04 SetBestChain: new best=00000000b51267dbe5798d4589c054d8da82bb219230bc58ec03ea0c4cfd31fb height
=13078 log2_work=43.87054 tx=19929 date=2014-06-03 01:08:34 progress=0.999307
2014-06-03 10:52:04 CDarkSendPool::NewBlock
2014-06-03 10:52:04 ProcessBlock: ACCEPTED
2014-06-03 10:52:04 sending: inv (37 bytes)
2014-06-03 10:52:04 received: getblocks (837 bytes)
2014-06-03 10:52:04 getblocks 13047 to 0000000000000000000000000000000000000000000000000000000000000000 limit 500
2014-06-03 10:52:04 sending: inv (37 bytes)
2014-06-03 10:52:04 received: block (5569 bytes)
2014-06-03 10:52:04 received block 00000000751a294a91332c6251c8465dd73a25170f6495aff1d3b3304e20d104
2014-06-03 10:52:04 ERROR: CheckBlock() : Vote not found in previous block
2014-06-03 10:52:04 ERROR: ProcessBlock() : CheckBlock FAILED
2014-06-03 10:52:04 Misbehaving: 5.9.136.141:19999 (0 -> 100) DISCONNECTING
2014-06-03 10:52:04 disconnecting node 5.9.136.141:19999
2014-06-03 10:52:04 received: getblocks (837 bytes)
2014-06-03 10:52:04 getblocks 13048 to 0000000000000000000000000000000000000000000000000000000000000000 limit 500
2014-06-03 10:52:04 sending: getblocks (837 bytes)
2014-06-03 10:52:04 received: getblocks (837 bytes)
2014-06-03 10:52:04 getblocks 13049 to 0000000000000000000000000000000000000000000000000000000000000000 limit 500
2014-06-03 10:52:04 received: getblocks (837 bytes)
2014-06-03 10:52:04 getblocks 13050 to 0000000000000000000000000000000000000000000000000000000000000000 limit 500
2014-06-03 10:52:04 received: getblocks (837 bytes)
 

minersday

Member
Apr 9, 2014
77
19
48
Is it just me, but I have a feeling that if there are nodes in that list that are forked, the sync wont happen?
I would try to add just one node and try syncing..

Hey, I'm not that stupid. ;)

After one hour still no connections. This is my config:

Code:
testnet=1

rpcuser=***
rpcpassword=***
rpcallowip=127.0.0.1
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=512
masternode=1

# add seednodes
addnode=23.23.186.131
addnode=188.226.248.36
addnode=184.73.179.187
addnode=54.183.73.24
addnode=87.230.94.57
addnode=54.198.19.83
addnode=54.76.52.216
addnode=54.215.181.251
addnode=91.218.156.233
addnode=50.191.199.127
addnode=54.80.186.130
addnode=54.198.109.108
addnode=112.175.123.94
addnode=50.17.76.216
addnode=23.23.55.5
addnode=54.86.103.191

### change stuff below
externalip=***
masternodeprivkey=***
 

chaeplin

Active Member
Core Developer
Mar 29, 2014
749
356
133
Code:
WhenDate/Timetimestamp diffeNumberDiffSubsidy
[reward of next block]WhoPayee[Maternode payee of next block]
just nowJun 03 2014 20:41:1420133210.443151nomp-
1 min agoJun 03 2014 20:40:5525133200.455151nomp-
2 mins agoJun 03 2014 20:39:359133190.483150nomp-
6 mins agoJun 03 2014 20:35:4612133180.488150nompmpKNkHEdgtxQAjTCkGB4ZwHAED74qwjDvj
6 mins agoJun 03 2014 20:35:351133170.510150nompmysBdRyDRFSYgBGUVjrEM1TyXsNxHMEUgQ
I have restart nomp darkcoind at 13319.
I think that cause no masternode payee.
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
Tried the same here 5 minutes ago, and just used one of my own masternodes to bootstrap - downloaded the complete blockchain in 2 minutes

Code:
addnode=184.73.179.148
I tried with only one node, still getting nothing:
Code:
2014-06-03 11:46:06 trying connection 184.73.179.148:19999 lastseen=361610.0hrs
2014-06-03 11:46:06 connected 184.73.179.148:19999
2014-06-03 11:46:06 send version message: version 70015, blocks=4500, us=54.76.47.232:19999, them=184.73.179.148:19999, peer=184.73.179.148:19999
2014-06-03 11:46:06 socket closed
2014-06-03 11:46:06 disconnecting node 184.73.179.148:19999
 

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,287
2,406
1,183
Germany
Is my IP banned because I didnt update soon enough?
I don't know how darkcoin is deciding if a node is allowed to connect - i have deleted peers.dat, increased the incoming connection and restarted that node - please retry

EDIT:

I think you got connected now :)

Code:
    {
        "addr" : "54.76.47.232:49822",
        "services" : "00000003",
        "lastsend" : 1401796887,
        "lastrecv" : 1401796922,
        "bytessent" : 5319386,
        "bytesrecv" : 652347,
        "blocksrequested" : 8829,
        "conntime" : 1401796810,
        "version" : 70015,
        "subver" : "/Satoshi:0.10.9.1/",
        "inbound" : true,
        "startingheight" : 4500,
        "banscore" : 0
    }
 

chaeplin

Active Member
Core Developer
Mar 29, 2014
749
356
133
I tried with only one node, still getting nothing:
Code:
2014-06-03 11:46:06 trying connection 184.73.179.148:19999 lastseen=361610.0hrs
2014-06-03 11:46:06 connected 184.73.179.148:19999
2014-06-03 11:46:06 send version message: version 70015, blocks=4500, us=54.76.47.232:19999, them=184.73.179.148:19999, peer=184.73.179.148:19999
2014-06-03 11:46:06 socket closed
2014-06-03 11:46:06 disconnecting node 184.73.179.148:19999
Yes banned. try nomp node 54.183.73.24.
 

kktr

New Member
Jun 1, 2014
4
0
1
I've set up a 10.9.1 masternode a few minutes after the this new version came out yesterday and haven't received a single payment until now - block 13343 (It took around 10+ hours). Which is a bit odd given that there are just a handful of them and that I've been listed in ./darkcoind masternode list => "54.76.52.216:19999" : 1
all the time.

Here's my testnet3 folder with debug.log: http://1drv.ms/1nKCdCN
It has a bunch of CheckBlock() errors.
 
Last edited by a moderator:

jimbit

Well-known Member
Foundation Member
May 23, 2014
228
103
203
just want to put this out there.. my MN has been connected and running continually for about 3 days. as far as I can tell I have continually received payments. I do NOT have any CheckBlocks in the log.

here is :
last transaction
getinfo
masternode list
masternode votes
Code:
 {
        "account" : "",
        "address" : "mw23256bSTqEkP6ThTRrY3KNicB9cfwzLR",
        "category" : "immature",
        "amount" : 14.90000000,
        "confirmations" : 30,
        "generated" : true,
        "blockhash" : "000000003e585d6b6c0f0e9977737d9e7255170f29146dbb630dabe149c5b60e",
        "blockindex" : 0,
        "blocktime" : 1401785611,
        "txid" : "b98ca6f8d0ea59366750deda7c35ed2aeb90caf457c4582906a0214ce370c1da",
        "time" : 1401785611,
        "timereceived" : 1401785620
    }
]
[email protected]:~$ darkcoind getinfo
{
    "version" : 100811,
    "protocolversion" : 70015,
    "walletversion" : 60000,
    "balance" : 4261.82260000,
    "blocks" : 13287,
    "timeoffset" : 0,
    "connections" : 6,
    "proxy" : "",
    "difficulty" : 0.73250472,
    "testnet" : true,
    "keypoololdest" : 1401626368,
    "keypoolsize" : 99,
    "paytxfee" : 0.00000000,
    "mininput" : 0.00001000,
    "unlocked_until" : 0,
    "errors" : ""
}


[email protected]:~$ darkcoind masternode list
{
    "54.76.47.232:19999" : 1,
    "54.203.217.224:19999" : 1,
    "54.193.124.32:19999" : 0,
    "54.215.181.251:19999" : 0,
    "54.245.240.204:19999" : 0,
    "54.83.103.205:19999" : 0,
    "54.83.144.77:19999" : 0,
    "54.87.113.180:19999" : 0,
    "54.83.119.70:19999" : 0,
    "54.226.35.164:19999" : 0,
    "54.196.183.250:19999" : 0,
    "23.20.251.111:19999" : 0,
    "54.204.103.109:19999" : 0,
    "50.16.161.222:19999" : 0,
    "54.87.64.168:19999" : 0,
    "54.87.78.40:19999" : 0,
    "54.234.196.97:19999" : 0,
    "54.83.73.204:19999" : 0,
    "54.198.29.31:19999" : 0,
    "54.80.172.181:19999" : 0,
    "54.81.163.182:19999" : 0,
    "54.83.186.105:19999" : 0,
    "54.205.239.39:19999" : 0,
    "23.20.86.159:19999" : 0,
    "54.80.46.68:19999" : 0,
    "54.205.95.233:19999" : 0,
    "54.224.97.195:19999" : 0,
    "54.198.182.25:19999" : 0,
    "54.198.73.92:19999" : 0,
    "50.19.68.175:19999" : 0,
    "54.83.190.57:19999" : 0,
    "54.204.142.242:19999" : 0,
    "54.83.162.41:19999" : 0,
    "54.237.228.241:19999" : 0,
    "54.198.231.203:19999" : 0,
    "54.205.136.180:19999" : 0,
    "54.198.51.150:19999" : 0,
    "23.20.183.122:19999" : 0,
    "54.205.54.4:19999" : 0,
    "184.73.41.210:19999" : 0,
    "54.82.216.66:19999" : 0,
    "54.234.157.177:19999" : 0,
    "54.80.122.128:19999" : 0,
    "54.211.41.63:19999" : 0,
    "50.17.41.33:19999" : 0,
    "54.198.82.100:19999" : 0,
    "54.242.101.135:19999" : 0,
    "23.20.40.89:19999" : 0,
    "54.242.231.254:19999" : 0,
    "54.82.218.205:19999" : 0,
    "54.81.90.244:19999" : 0,
    "54.224.233.36:19999" : 0,
    "54.237.85.246:19999" : 0,
    "54.242.75.82:19999" : 0,
    "54.227.105.253:19999" : 0,
    "50.16.136.92:19999" : 0,
    "54.196.129.200:19999" : 0,
    "54.226.45.165:19999" : 0,
    "54.237.16.209:19999" : 0,
    "184.73.179.187:19999" : 0,
    "184.73.179.148:19999" : 1,
    "184.73.179.196:19999" : 1,
    "87.230.94.57:19999" : 0,
    "188.226.133.22:19999" : 1,
    "188.226.248.36:19999" : 1,
    "54.76.52.216:19999" : 0,
    "54.237.141.247:19999" : 0,
    "54.86.103.191:19999" : 0
}
[email protected]:~$ darkcoind masternode list | wc
     70     206    2103
[email protected]:~$



[email protected]:~$ darkcoind masternode votes
{
    "13279" : "OP_DUP OP_HASH160 aa09e4b6969c00f9e3ba46dc5da62241c525d180 OP_EQUALVERIFY OP_CHECKSIG",
    "13280" : "OP_DUP OP_HASH160 19357ffa833aecc3f54f2f4b533ced906fa337ab OP_EQUALVERIFY OP_CHECKSIG",
    "13281" : "OP_DUP OP_HASH160 0fda8e49dec54b2f47055480eacaa8e973a79353 OP_EQUALVERIFY OP_CHECKSIG",
    "13282" : "OP_DUP OP_HASH160 aa09e4b6969c00f9e3ba46dc5da62241c525d180 OP_EQUALVERIFY OP_CHECKSIG",
    "13283" : "OP_DUP OP_HASH160 cc9d15a2c7682233f85a8cff39ca1f152221ef3c OP_EQUALVERIFY OP_CHECKSIG",
    "13284" : "OP_DUP OP_HASH160 a83cc7c0004906c57957d420e7dbc19cbc8c2fdb OP_EQUALVERIFY OP_CHECKSIG",
    "13285" : "OP_DUP OP_HASH160 c528e80499bf252ee5b5a3b51de6e52434d23ee9 OP_EQUALVERIFY OP_CHECKSIG",
    "13286" : "OP_DUP OP_HASH160 cc9d15a2c7682233f85a8cff39ca1f152221ef3c OP_EQUALVERIFY OP_CHECKSIG",
    "13287" : "OP_DUP OP_HASH160 aa09e4b6969c00f9e3ba46dc5da62241c525d180 OP_EQUALVERIFY OP_CHECKSIG",
    "13288" : "OP_DUP OP_HASH160 0fda8e49dec54b2f47055480eacaa8e973a79353 OP_EQUALVERIFY OP_CHECKSIG"
}
 

eduffield

Core Developer
Mar 9, 2014
1,084
5,319
183
Can we get some hashpower pointed at these two? Both of my instances were having issues, back up now:

Mpos + Stratum: http://ec2-54-198-19-83.compute-1.amazonaws.com
-- connection string: sgminer.exe -o stratum+tcp://54.198.19.83:3333 -u eduffield.1 -p x

P2Pool: http://54.200.184.132/
-- connection string: sgminer.exe -o stratum+tcp://54.200.184.132:18998 -u mt2ScQSwpsohN8KC9CuFGCuCuvyJkCY8iEn1K5Y5JGe5svtfmrJ6J9McsZPJdWXPvuRq -p 1
 
  • Like
Reactions: BrainShutdown

minersday

Member
Apr 9, 2014
77
19
48
Can we get some hashpower pointed at these two? Both of my instances were having issues, back up now:

Mpos + Stratum: http://ec2-54-198-19-83.compute-1.amazonaws.com
-- connection string: sgminer.exe -o stratum+tcp://54.198.19.83:3333 -u eduffield.1 -p x

P2Pool: http://54.200.184.132/
-- connection string: sgminer.exe -o stratum+tcp://54.200.184.132:18998 -u mt2ScQSwpsohN8KC9CuFGCuCuvyJkCY8iEn1K5Y5JGe5svtfmrJ6J9McsZPJdWXPvuRq -p 1
pointed ~36MH/s to Mpos + Stratum pool.. atleast for a while..
 

jimbit

Well-known Member
Foundation Member
May 23, 2014
228
103
203
Can everyone check to see what chain they're on? We should all match this: http://23.23.186.131:1234/chain/DarkCoin

If you're on a different chain please send me your debug.log
This is the first time in 3 days I have evidence of not being on the right chain:

I suppose everyone will HAVE to upgrade darkcoind when we launch?
Code:
[email protected]:~$ darkcoind getinfo
{
    "version" : 100811,
    "protocolversion" : 70015,
    "walletversion" : 60000,
    "balance" : 4261.82260000,
    "blocks" : 13287,
    "timeoffset" : 0,
    "connections" : 7,
    "proxy" : "",
    "difficulty" : 0.73250472,
    "testnet" : true,
    "keypoololdest" : 1401626368,
    "keypoolsize" : 99,
    "paytxfee" : 0.00000000,
    "mininput" : 0.00001000,
    "unlocked_until" : 0,
    "errors" : ""
}
[email protected]:~$ grep "CheckBlock()" .darkcoin/testnet3/debug.log
[email protected]:~$
 

jimbit

Well-known Member
Foundation Member
May 23, 2014
228
103
203
Can everyone check to see what chain they're on? We should all match this: http://23.23.186.131:1234/chain/DarkCoin

If you're on a different chain please send me your debug.log
Evan,
I was on the wrong chain, with the older version of MN
"version" : 100811,

I did the following steps:
upgraded to "version" : 100901,
delete peers.dat
edited conf to addnodes
start darkcoind -resync.


tailing the log resulted in a checkBlock entry during the resync

edit: now I continue to get checkBlock messages every couple minutes. all similar to the following
edit2: i shut the server down and left it alone for debugging. if you need access to the server pm me.


Code:
2014-06-03 15:54:42 CDarkSendPool::NewBlock - Is Masternode, resetting
2014-06-03 15:54:42 ProcessBlock: ACCEPTED
2014-06-03 15:54:42 received block 000000002e165403fdb76c0bf570232c6545a33412b0ba9381f27fcf06e2067c
2014-06-03 15:54:42 ----
2014-06-03 15:54:42 CDarkSendPool::NewBlock - Is Masternode, resetting
2014-06-03 15:54:42 ProcessBlock: ACCEPTED
2014-06-03 15:54:42 received block 000000002a4032156cab69cd1158a867e74fbe046c58a0bdcad7732b3609234f
2014-06-03 15:54:42 ----
2014-06-03 15:54:42 CDarkSendPool::NewBlock - Is Masternode, resetting
2014-06-03 15:54:42 ProcessBlock: ACCEPTED
2014-06-03 15:54:42 received block 0000000031f80cf2e393197400405a5c3532f368e1d12ba42df37c3579fd5ecb
2014-06-03 15:54:42 CheckBlock() : hashPrevBlock != pindexPrev->GetBlockHash() : 000000002a4032156cab69cd1158a867e74fbe046c58a0bdcad7732b3609234f != 00000000901d3db6cee133339e1a7d979554e0f324fef406930fd7634661c9bd
2014-06-03 15:54:42 ERROR: CheckBlock() : pblock->hashPrevBlock != blockLast->GetBlockHash()
2014-06-03 15:54:42 ERROR: ProcessBlock() : CheckBlock FAILED
2014-06-03 15:54:42 Misbehaving: 188.226.248.36:19999 (0 -> 100) DISCONNECTING
2014-06-03 15:54:42 disconnecting node 188.226.248.36:19999
2014-06-03 15:54:46 connection timeout
2014-06-03 15:54:46 trying connection 54.242.110.149:19999 lastseen=10.3hrs
 
Last edited by a moderator:

DRKLord

Member
Jun 2, 2014
92
94
68
Louisiana
Reposted from original topic:
https://darkcointalk.org/threads/my-dirty-fork.1073/

I read on Bitcointalk.org that the Darkcoin devs were looking for someone with a daemon still running on a bad fork from the failed masternode launch to examine and try to figure out what went wrong.

It just so happens that I retained a copy of a bad fork. I even mined a few blocks on the bad fork after the difficulty dropped so my daemon wouldn't switch to a new chain. I just wanted to preserve it in case it was ever needed, and it seems like perhaps it is.

So if it is still needed, I have a back-up save of my dirty fork... Let me know if this could be of any help to the devs.

Regards,

The DRK Lord
 
Status
Not open for further replies.