RC2 Hard Fork on May 14th!

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
Yes, our masternodes must be updated by May 14th to be functional and to participate in the payment system.
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
I went to check on my MN, and yeah weird. Dont masternode addresses start with "m" ?

Here is my 1k deposit



I ran getaaccountaddress 0 a few times, generates a NEW address, starting with "n" ... but always the same.
Were you able to run a masternode with a remote wallet holding your coin?

When I do "getaccountaddress" I get an X address. I have something wrong obviously, but no idea what. I tried, after starting my wallet with the ip address of my remote wallet, to turn my local account into a masternode with masternode start, it started up as a masternode, then I did getaccountaddress 0 and got another X address. What is my problem?
 
Last edited by a moderator:

miningpoolhub

New Member
Mar 9, 2014
12
1
3
Can you clarify what this mean?
-> (Without DarkSend. For pool operators and anyone else that wants to compile from opensource):

Why pool operators have to use without Darksend version?
What is the different between with DarkSend and without DarkSend.

With DarkSend version -> send all coins in DarkSend by default? so pool operators must not use it?
Without DarkSend version -> includes masternode payouts but DarkSend is not included? or disable?
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
The update changes how mining works. payments will be made to masternodes. This part of the code has been open sourced. However, DarkSEnd is still "under the hood". If you compile your own wallets, you will not get DarkSEnd, however, you will get what you need to continue to communicate with the network after we hit whatever block Evan chose to fork at for the new payment system. This will effect all transactions, so everyone, regardless if they use DarkSend beta or not, must update their wallets by May 14th.
 

mattmct

Member
Mar 13, 2014
259
92
88
Yes, our masternodes must be updated by May 14th to be functional and to participate in the payment system.
Thanks, I suspected as much, but then read about a whole bunch of people who updated but weren't able to launch the master node.

Also, I started a thread here, for a request of a guide for runing a remote masternode, without the 1000DRK on the server. As there hasn't been any official instructions or decent guides on this
https://darkcointalk.org/threads/ne...e-remotely-without-the-1000drk-on-server.386/
Hopefully someone can chime in!
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
I went to check on my MN, and yeah weird. Dont masternode addresses start with "m" ?

Here is my 1k deposit



I ran getaaccountaddress 0 a few times, generates a NEW address, starting with "n" ... but always the same.
yidakee, I think you might be using the testnet wallet? I just remembered that those addresses start with m's or something
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283

miningpoolhub

New Member
Mar 9, 2014
12
1
3
The update changes how mining works. payments will be made to masternodes. This part of the code has been open sourced. However, DarkSEnd is still "under the hood". If you compile your own wallets, you will not get DarkSEnd, however, you will get what you need to continue to communicate with the network after we hit whatever block Evan chose to fork at for the new payment system. This will effect all transactions, so everyone, regardless if they use DarkSend beta or not, must update their wallets by May 14th.
Now I can understand it.
Thanks a lot!
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
No, on May 1st when Evan said RC2 was live, his announcement was confusing because I think he made a typo :) I suspected it was a typo but didn't know either at the time :confused: :D

What he meant was that the source was available to compile a wallet that would allow for payments to masternodes, and thus be functional after May 14th. But DarkSend is separate from that, and still closed source. His mind is running ahead, and he doesn't realize we have no idea what's going on, LOL. But that's what we have InternetApe for, he's the interface between machine language (Evan) and human language (us) LOL
 

miningpoolhub

New Member
Mar 9, 2014
12
1
3
Is it okay to run RC2 version before the hardfork for pools?
It may sound silly since it must run smoothly between the hardfork, but just asking for sure.
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
Pools need to run the RC2 version, at least just before the fork to keep miners on the right fork and not waste their time mining a wrong fork. There is a testnet, and a version for this, so you can test it out. In fact, I believe they have a pool set up on testnet (see the other thread, testing RC2) I think it's ongoing but have been too busy to check???
 

miningpoolhub

New Member
Mar 9, 2014
12
1
3
Pools need to run the RC2 version, at least just before the fork to keep miners on the right fork and not waste their time mining a wrong fork. There is a testnet, and a version for this, so you can test it out. In fact, I believe they have a pool set up on testnet (see the other thread, testing RC2) I think it's ongoing but have been too busy to check???
I was concerned about RC2 not working with old pool software which doesn't know anything about masternode.
Thanks for answering.
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
Thanks Mike :)

I'm still unable to get my ip:0 off of the masternode list. I've turned off my computers, I've rebooted and made sure neither one had darkcoind running, and now, I've even sent off my 1000 coin deposit. None of these things have taken the ip address off the list.

And I think the fact that my ip address is on the list is keeping me from being able to take my wallet with coins off to cold storage, as my correct ip:9999 drops off the list when I do. Am I the only person with this problem?
 

yidakee

Well-known Member
Foundation Member
Apr 16, 2014
1,812
1,168
283
I have the opposite issue. MN working but not on list.
 

Lariondos

Well-known Member
Foundation Member
Apr 8, 2014
89
61
158
I have the opposite issue. MN working but not on list.
I have both issues, yours and Tante's, on different local/remote masternodes and different providers - hope someone could explain.
 

yidakee

Well-known Member
Foundation Member
Apr 16, 2014
1,812
1,168
283
I decided to try the remote/local setup.

- deleted masternode's wallet
- configured local wallet to point to masternode (as per Tante's tutorial) - yes, I sent myself 1000 DRK to address 0
- opened TCP port 9999 in local router
- not capable masternode
 

DcoinZ

Member
Apr 27, 2014
88
25
68

[Image credit: REUTERS; A giant fork sculpture, created in 1995 by artists Jean-Pierre Zaugg and Georges Favre, is pictured in Lake Leman, Switzerland.]
 

moloch

New Member
Apr 30, 2014
9
3
3
i managed to get my masternode working completely, with remote and local server.
I had a problem of it not showing on the list. It was showing on my local list but not on any other wallets list.
Also I had an old ip that i couldn't remove from the list too Tante. ( have you tried starting that wallet with masternode=0 in the config? )
Here is how I fixed it.
I withdrew my coins from the master node wallet back to my original wallet ( windows ).
I installed a new ubuntu Darkcoind ( daemon) wallet on my system.
I sent the 1000 coins to that address. Encrypt.

Start Remote server darkcoind.

Start local server with -

Darkcoind -masternodeaddr=YOURSERVERIP:9999

unlock wallet with -

walletpassphrase YOURPASSPHRASE 300

Then start masternode with
masternode start YOURPASSPHRASE

thats it, you do not have to start masternode on your remote server.
check now that your masternode shows on both darkcoind daemons. darkcoind masternode list
make sure it is on both.
I was having all these problems until I redid it all. Once i resent the 1000 to a new address everything was fine. Make sure you send the 1000 coins to a Darkcoind daemon.
I hope this works for you.

Also you can turn your local machines darkcoind off after. It should stay on the list.

Tante just to be sure. Assign a new elastic ip to your remote server before doing this. That way you can forget about the old ip. It will be moved eventually and you will have a new ip linked to a new transaction id ( i assume this is how it works)
 
Last edited by a moderator:
  • Like
Reactions: DcoinZ

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,861
1,854
1,283
I decided to try the remote/local setup.

- deleted masternode's wallet
- configured local wallet to point to masternode (as per Tante's tutorial) - yes, I sent myself 1000 DRK to address 0
- opened TCP port 9999 in local router
- not capable masternode
Are you trying to start your remote darkcoind as a masternode? It's really weird but you start your local darkcoind, the one with the 1000 coins, as the masternode. Then you stop it, and put it in cold storage :)
 

yidakee

Well-known Member
Foundation Member
Apr 16, 2014
1,812
1,168
283
Are you trying to start your remote darkcoind as a masternode? It's really weird but you start your local darkcoind, the one with the 1000 coins, as the masternode. Then you stop it, and put it in cold storage :)
Sorry, a bit tired back there... Just one note, my server has an un-encryted wallet

- Stopped remote darkcoind, deleted remote masternode wallet, start remote daemon with "darkcoind" only.
- configured local wallet to point to masternode (as per Tante's tutorial) - yes, I sent myself 1000 DRK to address 0 - encrypted -
- stopped local darkcoind, restart as darkcoind masternode=Ip etc -> darkcoind walletpassphrase MYPASS 60 -> darkcoind masternode start
- Get error, not capable masternode

Troubleshooting stuff I tried
- Opened TCP port 9999 on router
- delete peers.dat on both sides
- set masternode=0 and =1 on remote machine
- deleted masternode entry all together.
- on local daemon, darkcoind masternote start REMOTE_RCP_PASSWORD_IN_CONF_FILE
- on local daemon,
Nothing, still same issue - not capable masternode

Here is the 1k deposit on local wallet

{
"account" : "0",
"address" : "mkFSxjFhy5DLWoyjbYpoZcD7e7qaeqJnVs",
"category" : "receive",
"amount" : 1000.00000000,
"confirmations" : 132,
"blockhash" : "0000011dd51116c8b9bfb5644b25b31200b8ebfa0be870a07fda3cbe1effb8fd",
"blockindex" : 1,
"blocktime" : 1399545075,
"txid" : "4115b9e42f45e49172c55d2e3e6b30ad0128de98c897b3e88503fe691d6c9ed1",
"time" : 1399545067,
"timereceived" : 1399545067
},
Local Wallet getinfo

{
"version" : 100603,
"protocolversion" : 70014,
"walletversion" : 60000,
"balance" : 113060.64452813,
"blocks" : 3368,
"timeoffset" : 0,
"connections" : 2,
"proxy" : "",
"difficulty" : 0.00182892,
"testnet" : true,
"keypoololdest" : 1399546794,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"mininput" : 0.00001000,
"unlocked_until" : 0,
"errors" : ""
}
And server side

{
"version" : 100602,
"protocolversion" : 70014,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 3368,
"timeoffset" : -4,
"connections" : 5,
"proxy" : "",
"difficulty" : 0.00182892,
"testnet" : true,
"keypoololdest" : 1399545843,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"mininput" : 0.00001000,
"errors" : ""
}
The version number do not match... masternode payment WAS working on a single remote setup, so thats not it...
Getting nervous about my DRK's...
 
Last edited by a moderator:

InternetApe

I am root, bow before me!
Mar 10, 2014
13
6
3
Arizona
darkcoin.io
We have updated the RC2 wallet so everyone please upgrade.

And this is what I had to do to get another person working:

1) Windows: from console: getaccountaddres 0
Linux: ./darkcoind getaccountaddress 0
This will give you the main address for the wallet
2) Windows: from console: walletpassphrase {your wallet pass phrase} 60
Linux: from command line: ./darkcoind walletpassphrase {your wallet pass phrase} 60
3) Windows: from console: sendtoaddress {the wallet address from step 1}
Linux: from command line: ./darkcoind sendtoaddress {the wallet address from step 1}
4) When you see the transaction shutdown the wallet
Windows; Just close the wallet
Linux: ./darkcoind stop
5) Restart the wallet and wait for sync
6) Windows: from console: walletpassphrase {your wallet pass phrase} 60
Linux: from command line: ./darkcoind walletpassphrase {your wallet pass phrase} 60
7) Windows: from console: masternode start
Linux: from command line: ./darkcoind masternode start

That should start the masternode you can run masternode debug command to get the status.
 

elbereth

Active Member
Dash Support Group
Mar 25, 2014
440
466
133
Costa Rica
dashninja.pl
Dash Address
XkfkHqMnhvQovo7kXQjvnNiFnQhRNZYCsz
Just wondering, I installed the new RC2 version from today and getaccountaddress 0 returns an empty list...
Code:
$ darkcoind getaddressesbyaccount 0
[
]
That's exactly what I did with previous version 0.10.6.3 and it worked fine (address was returned successfully).
Can we use the address for account "" now? I see on my currently running masternode that the account 0 does not exist anymore and the 1000 DRK are on "".
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
Just wondering, I installed the new RC2 version from today and getaccountaddress 0 returns an empty list...
Code:
$ darkcoind getaddressesbyaccount 0
[
]
That's exactly what I did with previous version 0.10.6.3 and it worked fine (address was returned successfully).
Can we use the address for account "" now? I see on my currently running masternode that the account 0 does not exist anymore and the 1000 DRK are on "".
You have mixed the commands:
getaccountaddress <account> Returns the current bitcoin address for receiving payments to this account. If <account> does not exist, it will be created along with an associated new address that will be returned.
getaddressesbyaccount <account> Returns the list of addresses for the given account.
 

yidakee

Well-known Member
Foundation Member
Apr 16, 2014
1,812
1,168
283
edit: wrong thread
 
Last edited by a moderator: