COMPLETE MASTERNODE GUIDE (WINDOWS LOCAL + LINUX REMOTE @VULTR)

MrMime

Well-known Member
Foundation Member
Mar 9, 2014
169
36
188
1 - Download the release candicate 0.10.11.6 "linux rc3 (darksend) tgz" file from darkcoin.io website -> getting started page on your local pc.
2 - Extract the tgz file on your local pc which will give you darkcoin-0.10.11.6-linux folder containing bin folder containing 32 & 64 bit folders, i am using 64 bit so in 64 bit folder was 2 files "darkcoin-qt" & "darkcoind"

terminal commands are in bold, i am assuming your darkcoind file is in your home folder (remote server) for all of the below terminal commands


3.1 - on remote server stop the MN - ./darkcoind stop
3.2 - on remote server, backup old darkcoind file - mv darkcoind darkcoind.old
3.3 - on local pc from inside extracted 64 bit folder - scp darkcoind [email protected]:/home/YOURUSERNAME
3.4 - confirm copied darkcoind file is in your home folder on the remote server, should be 6824kb in size - ls -s
3.5 - give darkcoind file execute permission on the remote server - chmod +x darkcoind
3.6 - start darkcoind file on remote server - ./darkcoind
3.7 - wait about 30 seconds, confirm you are running .6 version, at top of the output will be the version 101106, on remote server - ./darkcoind getinfo
3.8 - confirm your MN is running, output should end in IPADDRESS:1 with a 1 showing - ./darkcoind masternode list | grep YOUR-REMOTEPC-IP-ADDRESS
3.9 - Re-confirm your MN running by checking elbzo.net webpage, allow 45-60 minutes for your version to update on that webpage.

Hope the above helps.
If using windows for local wallet, do you know if I can just change my config file to repoint?
 

Darkuopm

Member
Jun 18, 2014
50
17
48
If using windows for local wallet, do you know if I can just change my config file to repoint?
I dont know what you mean by repoiont. I had the understanding that updating did not require a change to the .conf file. I could be wrong anyone please correct me if so.

I have a windows local machine and was trying to update. This is what I did and it seams to have worked.
on my VPS logged in thru putty:
wget https://github.com/darkcoinproject/darkcoin-binaries/raw/master/rc/darkcoin-0.10.11.6-linux.tar.gz
that downloaded the file then
tar -zxvf darkcoind0.10.11.6-linux.tar.gz
that unzipped it
mv darkcoind0.10.11.6-linux/bin/64/darkcoind darkcoind
that moved darkcoind to my root dir
sudo chmod +x darkcoind
that set permissions
./darkcoind
that started the server.
It is now showing updated on elbzo.net to 10.11.6 but does not show listed yet on the Status drkmn 01 thru 08 or the p2 pool. I am hoping that it just needs time for those.
hopefully this helps someone trying to update. I am still kinda of new to linux but am learning.
 
  • Like
Reactions: MrMime

MrMime

Well-known Member
Foundation Member
Mar 9, 2014
169
36
188
that started the server.
It is now showing updated on elbzo.net to 10.11.6 but does not show listed yet on the Status drkmn 01 thru 08 or the p2 pool. I am hoping that it just needs time for those.
hopefully this helps someone trying to update. I am still kinda of new to linux but am learning.
Same thing happened to one of my MN's also. The Other two were fine however. Weird.. In regards to the pointing, I was looking off of what booyah posted up above. Babygiraffe had a great guide and that seemed to go off without a hitch. (Essentially what you had written) Other than that one not listing on any servers, it's all good.

*Edit: Is your ip showing up when you ./darkcoind masternode list | grep [ip]?
 
Last edited by a moderator:
  • Like
Reactions: Darkuopm

Darkuopm

Member
Jun 18, 2014
50
17
48
Same thing happened to one of my MN's also. The Other two were find however. Weird.. In regards to the pointing, I was looking off of what booyah posted up above. Babygiraffe had a great guide and that seemed to go off without a hitch. (Essentially what you had written) Other than that one not listing on any servers, it's all good.

*Edit: Is your ip showing up when you ./darkcoind masternode list | grep [ip]?
no that's weird the grep command doesn't seem to do anything now?? and I am still unlisted? Any ideas??

i dont want to try and update my second one if it is going to be a problem
 

MrMime

Well-known Member
Foundation Member
Mar 9, 2014
169
36
188
Yeah, same thing happened to me and looks like my node disappeared from elbzo. :/. Assuming will have to restart creation process over?

Edit* Trying to roll back to 05 version and seeing if that changes anything.
Edit** Didn't work. Not too sure now. Will probably need to transfer coins and re-setup?
 
Last edited by a moderator:

Ryan Taylor

Well-known Member
Dash Core Team
Foundation Member
Jul 3, 2014
550
1,649
263
Scottsdale, AZ, USA
Yeah, same thing happened to me and looks like my node disappeared from elbzo. :/. Assuming will have to restart creation process over?

Edit* Trying to roll back to 05 version and seeing if that changes anything.
Edit** Didn't work. Not too sure now. Will probably need to transfer coins and re-setup?
Did you try going back into the wallet console and entering "walletpassphrase <password> 60" and "masternode start <password>" to relaunch the masternode?
 

MrMime

Well-known Member
Foundation Member
Mar 9, 2014
169
36
188
babygiraffe I have not yet. Will try throwing that in and seeing. Thanks!

Ya went through and still no 1 after ip. :/
 
Last edited by a moderator:

Darkuopm

Member
Jun 18, 2014
50
17
48
babygiraffe I have not yet. Will try throwing that in and seeing. Thanks!

Ya went through and still no 1 after ip. :/
I see I am always 1 step behind babygiraffe. I just went to my windows wallet and re-did masternode genkey. And then restarted my masternode and all is working now. I guess it is worth mentioning that I first stoped darkcoind on my linux server and edited the darkcoin.conf file to masternode=0 and deleted my old masternode private key. Then I ran darkcoind again. then stoped it. then did the same on windows. I edited the .conf file ran the wallet. closed the wallet. opened it again then requested the new masternode genkey. Then edited the linus .conf with teh new key and changed masternod=1 then ran darkcoind on linux. then I edited my local .conf file. then opened the local wallet did the passphrase and start masternode commands and now its working.
 

TaoOfSatoshi

Grizzled Member
Jul 15, 2014
2,841
2,648
1,183
Dash Nation
www.dashnation.com
Hello, I just made an account to give my utmost gratitude to Weirdgod, Flare, and Chaeplin for their invaluable assistance in setting up my first Masternode, and then, with much more pain, the second one from the same computer (I need sleep). I'm too cheap to pay you guys, so I have to pay somehow, right?

I believe in DRK, and I will be hodling my 2k+ coins for the foreseeable future, as I am excited to see where this project, which is already leaps and bounds beyond BTC in innovation, will take us.

I will hold even though the falling price tests patience, I believe all of our patience will be rewarded.

Evan and the Dev team are in a class by themselves, and the community from what I've seen in my short time here is top notch.

Onward and upward, my friends! DARKCOIN FTW!!!!!!

Thanks again,

Tao
 
  • Like
Reactions: flare

MrMime

Well-known Member
Foundation Member
Mar 9, 2014
169
36
188
I see I am always 1 step behind babygiraffe. I just went to my windows wallet and re-did masternode genkey. And then restarted my masternode and all is working now. I guess it is worth mentioning that I first stoped darkcoind on my linux server and edited the darkcoin.conf file to masternode=0 and deleted my old masternode private key. Then I ran darkcoind again. then stoped it. then did the same on windows. I edited the .conf file ran the wallet. closed the wallet. opened it again then requested the new masternode genkey. Then edited the linus .conf with teh new key and changed masternod=1 then ran darkcoind on linux. then I edited my local .conf file. then opened the local wallet did the passphrase and start masternode commands and now its working.
Here goes nothing....
 

darklord1981

New Member
Jun 26, 2014
35
4
8
With this setup and the latest Windows Wallet there seems to be no more 'Masternode start" command available in the debug console.

Looking to set up another MN. My quesiton is, does the windows wallet NEED to be online at all times for teh masternode, or merely the instance running on the linux server?
 

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,286
2,404
1,183
Germany
With this setup and the latest Windows Wallet there seems to be no more 'Masternode start" command available in the debug console.
What version are you referring to? If its 0.9.12.6: Yes, there is no masternode start command in there, as it does not contain masternode functionality. A Windows binary for 0.10.12.6 (masternode capable) is not available at the moment.

My quesiton is, does the windows wallet NEED to be online at all times for teh masternode, or merely the instance running on the linux server?
No, the windows wallet does not need to be online, just the actual masternode (linux server).
 

darklord1981

New Member
Jun 26, 2014
35
4
8
I have issues setting up MN #2.

It doesn't seem to be downloading the blockchain. When I do ./darkcoind getinfo it shows

{
"version" : 101105,
"protocolversion" : 70018,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 0,
"timeoffset" : 0,
"connections" : 0,
"proxy" : "",
"difficulty" : 0.00024414,
"testnet" : false,
"keypoololdest" : 1406802420,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"mininput" : 0.00001000,
"errors" : ""
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
I have issues setting up MN #2.

It doesn't seem to be downloading the blockchain. When I do ./darkcoind getinfo it shows

{
"version" : 101105,
"protocolversion" : 70018,
"walletversion" : 60000,
"balance" : 0.00000000,
"blocks" : 0,
"timeoffset" : 0,
"connections" : 0,
"proxy" : "",
"difficulty" : 0.00024414,
"testnet" : false,
"keypoololdest" : 1406802420,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"mininput" : 0.00001000,
"errors" : ""
Update to 101106 and you will find connections automatically.
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One

darklord1981

New Member
Jun 26, 2014
35
4
8
Thanks bro! Its been doing my head in for hours!
damn thing still wont start. Grep command returns just a blank line. damn it,

Edit: Fixed.

Seems I fired up the wrong cold wallet against the wrong MN and somehow managed to merge the MN and new wallet address, creating only 1 MN instead of too. (prob the beer's fault) haha

Just rebuilt both of them individually with new wallets and instances of Linux and working like a dream.
 
Last edited by a moderator:

Miner237

Well-known Member
Foundation Member
May 28, 2014
516
226
213
You have now completed linux part. You can leave console/putty open, but in order to complete setup, you need to enter come commands on your Windows PC. With commands there, you will initiate connection from your funded wallet (1000 DRK balance), which will enable masternode on linux.



3. WRAPPING IT ALL TOGETHER!

On your windows pc:

Open NEW notepad, and paste in the following text:
---
rpcuser=LONG-RANDOM-STRING-fisjfijsfisjfsdwesdfsfdsfsfsdfhis_you_should_change_this
rpcpassword=LONGER-RANDOM-STRINGfisdfisfisjfijsfisjfsdwesdfsfdsfsfsdft_you_should_change_this
rpcallowip=127.0.0.1
listen=0
server=1
daemon=1
logtimestamps=1
addnode=23.23.186.131
masternode=1
masternodeprivkey=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
masternodeaddr=YYYYYYYYYYYYYY:9999

----

Replace rpcuser and rpcpassword fields with random text.
Replace the XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX string with the privkey value, obtained in previous steps above.
Replace YYYYYYYYYYY string, with IP address of your linux server (you should see it from vultr dashboard, or on linux, if you type "ifconfig" and look at eth0 line).

Save file as c:\darkcoin\darkcoin.conf

Now close darkcoin-qt.exe if still running.

Open DOS window (windows key+R, enter “CMD” and press enter), and go to c:\darkcoin and run darkcoin-qt.exe with parameter to force it to load the darkcoin.conf file (make sure conf file is indeed called darkcoin.conf, as notepad could append the .txt at the end):

cd c:\darkcoin
darkcoin-qt.exe -conf=C:\darkcoin\darkcoin.conf


Once darkcoin-qt opens, go to console, and enter the password that you used to ENCRYPT WALLET on windows:

walletpassphrase "PASSWORD" 60

you will get blank line, and in the main window the LOCK icon will change to unlocked.
Now continue with:

masternode start "PASSWORD"


If successful, you will see a message - masternode started...





On your linux server:

Now go to linux console/putty again, and issue the command:
grep HotCold .darkcoin/debug.log

if you see a line with Enabled in string, then linux masternode is enabled (activated from funded windows wallet!).
Now you can check whether your linux server is listed in list of active masternodes, with command:
./darkcoind masternode list | grep YOURIP

And if your IP is listed with :1 at the end, then you are up and running, and should expect first masternode payment soon! :D



You can also check whether your MN (IP) is listed at this great elbereth's MN status page: https://elbzo.net/masternodes.html


Congratulations!


EDIT (26.6.2014): ADDED APPENDIX ON UPDATING THIS SETUP TO NEW DARKCOIN VERSIONS (currently to 10.11.4 that softforks and enables masternode payments, but should work for newer versions too), here: https://darkcointalk.org/threads/dr...cal-linux-remote-vultr.1367/page-3#post-10183


EDIT2 (1.8.2014): UPDATED FIRST POST, TO INCLUDE NEW DOWNLOAD PATH TO DARKCOIN BINARIES ...
I'm having trouble on the local wallet running the Masternode start command. I verified my port is open but I keep getting the message inbound port is not open please open and try again. Any thoughts?
 

Lebubar

Active Member
Mar 15, 2014
249
213
103
I'm having trouble on the local wallet running the Masternode start command. I verified my port is open but I keep getting the message inbound port is not open please open and try again. Any thoughts?
Hi,

When I had this error last time it's because I forgot to start the deamon on the remote server =).
So I think that it can't connect your MN at port 9999 :
-check deamon start on remote server : ps- ef | grep drakcoin (should show I line darkcoind)
-Check your conf file in your local wallet should have the IP of the remote MasterNode : masternodeaddr=IP:9999
From local wallet can try : telnet IP_remote 9999 = If deamon is start and reachable from your local you should have some message on the screen
 

Lebubar

Active Member
Mar 15, 2014
249
213
103
Oh yes and also no need to write 2 times the passphrase at the end.
Only masternode start "Passphrase"
It s enough. No need to do the wallerpass " PASS" 60 before.