Steps to run dash on devnet

Milan

New Member
Dec 29, 2017
5
2
3
42
Hi!

I'm trying to run dash in devnet mode. I partially managed to run it but stuck in some parts.

This is how I run it in one my nodes
Code:
dashd -gen -genproclimit=1   -printtoconsole  -devnet -port=10332 -rpcport=10333
This node creates the wallet but there is few problems.
1. I don't see that any log related to node start Mingin
2. I see a lot of logs like this
Code:
2017-12-29 22:53:16 CMasternodeSync::ProcessTick -- nTick 37 nRequestedMasternodeAssets 0 nRequestedMasternodeAttempt 0 nSyncProgress -0.250000
2017-12-29 22:53:22 CMasternodeSync::ProcessTick -- nTick 43 nRequestedMasternodeAssets 0 nRequestedMasternodeAttempt 0 nSyncProgress -0.250000
2017-12-29 22:53:28 CMasternodeSync::ProcessTick -- nTick 49 nRequestedMasternodeAssets 0 nRequestedMasternodeAttempt 0 nSyncProgress -0.250000
2017-12-29 22:53:34 CMasternodeSync::ProcessTick -- nTick 55 nRequestedMasternodeAssets 0 nRequestedMasternodeAttempt 0 nSyncProgress -0.250000
Are these logs normal?

On the second node:
3. how can I run it in devnet as well and connect two nodes?
I tried to run second node like this
Code:
dash-qt -listen=0  -printtoconsole  -devnet -port=10332 -rpcport=10333
but when I run addnode command tried to connect to first node on 9999. Is there anyway to fix it?

4. When I run nodes in devnet, no one has 1000 DASH, what happen to masternode in this case? Who will be master node?
 
Last edited:

strophy

Administrator
Dash Core Group
Dash Support Group
Feb 13, 2016
786
496
133
My apologies! That will teach me to comment on things I don't fully understand ;)