Please Update Your Darkcoin Clients!!!

Status
Not open for further replies.

DRKLord

Member
Jun 2, 2014
92
94
68
Louisiana
I would like to remind everyone to be sure to update Darkcoin client software! It is important that everyone run the new client software in this transitory phase for Darkcoin. A "soft fork" was just implemented to enable Darksend payments, and masternodes are now being paid and working. You can see Evan's official announcement for more information. There are a lot of great things ahead for Darkcoin and a lot of new, powerful features and technologies in the works. Let's all cooperate and make this transition a smooth and easy one!

EDIT (6/28/2014)
New clients have been released and more changes have been made. Current versions are v9.11.5 and v10.11.5. It is important that all solo-miners and pool operators update to the correct clients! Miners make the network work, and as such you need to use the right client versions, stay up to date and keep our blockchain healthy and stable!

You can find the new client software on the official downloads page of www.Darkcoin.io.

*** PLEASE UPDATE TO 9.11.5 OR 10.11.5 ***

Windows Users:
v9.11.5
v10.11.5

Linux Users:
Ubuntu v10.11.5 GUI Wallet/Client
Ubuntu v10.11.5 Darkcoind Daemon

Mac Users:
v9.11.5 Wallet/Client

If you need any help or have any questions please let me know! You may reply in this thread. :)

Regards,

The DRK Lord
 
Last edited by a moderator:
  • Like
Reactions: jpr

tungfa

Administrator
Dash Core Team
Moderator
Foundation Member
Masternode Owner/Operator
Apr 9, 2014
8,902
6,733
1,283
This is regarding masternodes only ?
correct ?
Nothing to do with normal wallets
 

DRKLord

Member
Jun 2, 2014
92
94
68
Louisiana
This is regarding masternodes only ?
correct ?
Nothing to do with normal wallets
Your existing wallet is not going to be broken by the new release. But everyone should update. More changes will be coming in the future and it's important to have everyone keeping up-to-date.
 
  • Like
Reactions: tungfa

wmr1988

New Member
May 27, 2014
10
2
3
DRKlord I read somewhere that says the latest version is 10.11.5. Is that true?
 

gujo82

New Member
Masternode Owner/Operator
Jun 16, 2014
29
4
8
I've updated my MNs now to 10115, and i ask the same q as yesterday as i never got any answer :what: - Do i need to resync the coldwallet to the remote node (with masternode start etc)?

because the MNs show up in the list after update, so everything should be ok without doing it...?
 

Lariondos

Well-known Member
Foundation Member
Apr 8, 2014
89
61
158
I've updated my MNs now to 10115, and i ask the same q as yesterday as i never got any answer :what: - Do i need to resync the coldwallet to the remote node (with masternode start etc)?

because the MNs show up in the list after update, so everything should be ok without doing it...?
I never had to resync and still receiving payments for the updated nodes. As long as "darkcoind masternode debug" on the remote wallet says "successfully started masternode" after the update, it should work.
There may be a case, when the node is pinged just while being offline. So to be sure, check chaeplin's masternode list after an hour or so.
 

vertoe

Three of Nine
Mar 28, 2014
2,573
1,652
1,283
Unimatrix Zero One
As far as I understood the update to xx115 is only mandatory for pool operators.
I'm not going to update all my masternodes just for a minor (miner!) bugfix.

That being said, can we highlight updates which are mandatory for masternodes somehow in future?
 
  • Like
Reactions: DRKLord

DRKLord

Member
Jun 2, 2014
92
94
68
Louisiana
OP has been updated with correct client versions. I also added the correct download links for Windows, Linux and Mac users. In my first post I was a bit tired and forgot to do this, and I apologize for that! :p

Thanks, and if you have any problems or need any help then you need only ask! :)

The DRK Lord
 

darkwing

Active Member
Apr 8, 2014
149
110
103
OP has been updated with correct client versions. I also added the correct download links for Windows, Linux and Mac users. In my first post I was a bit tired and forgot to do this, and I apologize for that! :p

Thanks, and if you have any problems or need any help then you need only ask! :)

The DRK Lord
On darkcoin.io the links still say RC2!
 
  • Like
Reactions: vertoe

DeathRay1977

New Member
Jun 10, 2014
13
11
3
Where can I find the 10.11.5 source repo so I can build the client on OSX? Is it available as a branch on GitHub? Can't see it there?
 

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,286
2,404
1,183
Germany
Where can I find the 10.11.5 source repo so I can build the client on OSX? Is it available as a branch on GitHub? Can't see it there?
10.11.5 contains the Darksend component, which is still closed source (private repo) - Evan scheduled to make it available when the implementation is finished.

The problem with no OSX Darksend wallet available also applies to Linux 32bit - but i provided Evan with the necessary gitian-descriptors so he should be able to build OSX and Linux32 binaries for 10.11.x soon.
 
  • Like
Reactions: DeathRay1977
Status
Not open for further replies.