Needed: Guide for running Masternode remotely without the 1000DRK on server.

mattmct

Member
Mar 13, 2014
259
92
88
Update: Thanks to TanteStefana , we have a guide! -> https://darkcointalk.org/threads/remote-masternode-guide.410/

Hey guys,

I've read a few mentions on the forum about how we can run a master node without the 1000DRK not physically on the server. Right now I have a couple of master nodes running, with the drk on the server, now that there is the option to do it in a safer way, many are interested.

I haven't been able to find a decent guide or even instructions / documents on this. With the fork coming on the 14th I feel it is needed.

I also have some un answered questions.
1) Do we need to keep the computer / server on, the one with the 1000DRK? Or can it be off after the remote master node is up and running?

I personally have a number of unbutu VPS's running, but at home I have Windows computers.

Here is my thinking. Remove 1000DRK wallet from current masternodes. Restart demons. New empty wallet there. Take 1000DRK wallet, move to windows computer. Some how start remote masternode. Take second wallet, reload with 1000DRK from second wallet, start second remote server?

Or do I need to do all on unbutu / have that computer / sever running all the time. This is where things get foggy.

chaeplin has written an awesome guide for setting up master nodes, so I'm looking at you mate! lol. I know you have the knowledge.
Maybe eduffield can chime in on some clarifications?

Thanks for your time!
 
Last edited by a moderator:

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,871
1,863
1,283
Evan gave some instruction (I remember a quote in bitcointalk) that you put 1000 coins on a local machine, then start it like so: ./darkcoind -masternodeaddr="server's ip address" then you're supposed to be able to start your masternode up on your remote machine as usual, and it would see the dark on your local machine. (local machine must be unlocked to do it, you can do that with ./darkcoind

It's never worked for me, though I've tried and tried, yet others say it did work for them.

https://bitcointalk.org/index.php?topic=421615.msg6427569#msg6427569
Ok, I have verified it works.

Start darkcoind on remote machine.
On your local machine specify the IP at launch with -masternodeaddr=YOUR_SERVER_IP
Unlock your local machine wallet with your passphrase.
On your local machine, ./darkcoind masternode start

Slickness indeed.

darkcoin.conf (stolen from chaeplin's thread, thanks buddy)
Quote
addnode=23.23.186.131
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
masternode=1

Could someone kindly help me? I can't seem to get this to work.

I started my server darkcoind wallet

I started my local darkcoind with the command:
./darkcoind -masternodeaddr=YOUR_SERVER_IP
I unlocked my wallet

I then tried to start my server with ./darkcoind masternode start passphrase

I get "not capable masternode"

I tried starting my local darkcoind as a masternode, unlocking the wallet, then went back to my server and still could not start the masternode.

Can anyone see what I'm doing wrong? Thanks
 

ErrorId

Member
Mar 9, 2014
158
41
88
Canada
Wasn't there an additional step in there somewhere where you have to transfer 1000DRK to the wallet that will be choosing the master node or is that part no longer required?
 

donho

Member
Masternode Owner/Operator
Apr 16, 2014
96
20
58
I couldn't get it to work either TanteStefana. Would be great if someone (humanitee ;)) who did it could post it here before the hardfork.

edit: I pm'd humanitee on bitcointalk a link to this thread
 

donho

Member
Masternode Owner/Operator
Apr 16, 2014
96
20
58
strange I tried it again (testnet). And now it seems to work. At least my masternode is in the list but with port 0
"54.187.152.9:0" : 1
I will check if it will be chosen as a masternode and receive payments
 

donho

Member
Masternode Owner/Operator
Apr 16, 2014
96
20
58
I started my server darkcoind wallet

I started my local darkcoind with the command:
./darkcoind -masternodeaddr=YOUR_SERVER_IP
I unlocked my wallet

I then tried to start my server with ./darkcoind masternode start passphrase

I get "not capable masternode"

I tried starting my local darkcoind as a masternode, unlocking the wallet, then went back to my server and still could not start the masternode.

Can anyone see what I'm doing wrong? Thanks
I think your problem is that you tried to start the Masternode from the server! You have to start the masternode on your local machine after you started the daemon with the serverip as a parameter!

so steps are:
start your server darkcoind
start your local darkcoind with darkcoind -masternodeaddr=YOUR_SERVER_IP
unlock your local wallet
start the masternode on the local machine

then darkcoind masternode list -> your server ip should now be listed
 

mattmct

Member
Mar 13, 2014
259
92
88
Cheers for replying guys, seems like there is a clear need for a clear guide for sure, as people are getting mixed results.

I have have yet to give it a try, but I will do soon. My local computer runs windows? is it possible to do it on that?.. If not I can always set up a temporary server to get my other node servers up and running I guess.
Also what about if you want to set up multiple nodes? I can only assume you keep swapping the wallet.dat file on your local computer for each node to set up.
 

yidakee

Well-known Member
Foundation Member
Apr 16, 2014
1,812
1,168
283
One very important step is missing here. On a typical 1 server setup, the you must generate "darkcoind getaccountaddress 0" and send exactly 1000DRK. Only then does
the masternode become eligible.

donho

strange I tried it again (testnet). And now it seems to work. At least my masternode is in the list but with port 0
"54.187.152.9:0" : 1
I will check if it will be chosen as a masternode and receive payments
How do you do that?
 

humanitee

New Member
Mar 30, 2014
13
4
3
Greetings all,

The only part I left out was sending 1000 DRK to a separate, newly generated wallet. This is the local machine wallet that is used in the steps I laid out, the server wallet has 0 DRK in it. I figured this was common sense but I know that when following guides it's nice when the author is explicit with their procedure, my apologies. That is step #1! Everything else is verbatim what I did, and it worked for me. Let me know if you all still have problems!

Start darkcoind on the remote machine.
On your local machine, send 1000 DRK to a newly generated wallet. Send it to the 0th address. If you use darkcoin-qt version to make your wallets, send it to the first (and only if it was newly generated) address.
On your local machine specify the server IP at launch with: ./darkcoind -masternodeaddr=YOUR_SERVER_IP
Unlock your local machine's newly generated 1000 DRK wallet with your passphrase, ## is the time in seconds before the wallet will be once again locked: ./darkcoind walletpassphrase 'your wallet passphrase here' ##
On your local machine, ./darkcoind masternode start

my darkcoin.conf on local machine (stolen from chaeplin's thread, thanks buddy)
addnode=23.23.186.131
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
masternode=1

my darkcoin.conf on remote machine
addnode=23.23.186.131
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
masternode=1
externalip=YOUR_SERVER_IP
 
Last edited by a moderator:
  • Like
Reactions: mattmct

Minotaur

Well-known Member
Foundation Member
Apr 7, 2014
452
1,079
263
Could it be the version of darkcoind? I think this happened to me running version 90202 and I think the latest version is 100603. If you are already on the latest version then I dont know what else could be. Could some of the people experiencing this check on the version with getinfo.
 

thelonecrouton

Well-known Member
Foundation Member
Apr 15, 2014
1,135
813
283
OK got it working, both port 0 and 9999 show under masternode list on the local machine, only IP:9999 under masternode list on the remote box. Version 100603 for both.

Many thanks to you all! :)
 
Last edited by a moderator:

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,871
1,863
1,283
I think your problem is that you tried to start the Masternode from the server! You have to start the masternode on your local machine after you started the daemon with the serverip as a parameter!

so steps are:
start your server darkcoind
start your local darkcoind with darkcoind -masternodeaddr=YOUR_SERVER_IP
unlock your local wallet
start the masternode on the local machine

then darkcoind masternode list -> your server ip should now be listed
Wow, that makes no sense to me but it worked. I do have port 0 on the list though... Now I wonder if my server instance will actually act as a masternode? I guess I have to wait until I actually receive a payment to know if it worked or not?!

I did turn off my local darkcoin instance (darkcoin stop) so that I could put the wallet in cold storage. So far it's still on the list.
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,871
1,863
1,283
So the answer to the 0 problem is that you may need to define it in your startup command on your local machine. IE:
./darkcoind -masternodeaddr=54.xxx.xxx.xxx:9999

On one of my servers, I simply stopped it, restarted it, and restarted the local machine with the above command and everything went well. When I turned off the local machine, the MasterNode remained on the masternode list, and continues to work fine.

However, on my other MasterNode, the 54.xxx.xxx.xxx:0 on the list did not go away, even after rebooting both the remote and the local machines. And when I started up the masternode with the above command, all seemed well, with the ip address showing up on the masternode list along with the proper port number. However, when I turned off the local machine, the ip address was dropped from the masternode list and only the one with port 0 continued... I suspect I need to get this incorrect ip address off the list somehow but I can't figure it out. I dont' think my other ip with the proper port will take until I do. Can anyone think of anything? Thanks :)
 
Last edited by a moderator:
  • Like
Reactions: mattmct