MEGA-"HELP! WALLET NOT SYNCING"-THREAD

tnbdash

New Member
Feb 22, 2016
5
3
3
I need help! My dash-qt seems to be crashed. The following is the message:

Runtime Error!

Program: C:\Program Files\Dash\dash-qt.exe

This application has requested the Runtime to terminate it in an unusual way.
Please contact application's supprot team for more information.
 
  • Like
Reactions: demo2

demo2

New Member
May 15, 2016
14
2
3
121
I need help! My dash-qt seems to be crashed. The following is the message:

Runtime Error!

Program: C:\Program Files\Dash\dash-qt.exe

This application has requested the Runtime to terminate it in an unusual way.
Please contact application's supprot team for more information.
I have already told them.
Nobody seems to care until now.

I hope they will fix the bug soon, because I have the same problem.
 
Last edited:

tnbdash

New Member
Feb 22, 2016
5
3
3
Here is a more detailed description of how I get into the Runtime Error on Windows 8:

My wallet was up and running fine and my laptop got into a screen saving mode(after a few minutes of no keyboard activity) . This caused dash-qt to lose synch with the network due to database corruption. By loading the wallet again, it started synching. While it was synching, it again got into a second screen saving mode(again after a few minutes of no keyboard activity). This time the wallet crushed and was no longer able to synch with the network. The initial error message (I did not write down) was something like "level13 error". Keep on loading the wallet then got into the Runtime Error I reported above. I also tried to copy the earlier version of backup wallet.dat into the \dash folder and loaded the wallet again. The same Runrime Error above appears.
 
  • Like
Reactions: UdjinM6

UdjinM6

Official Dash Dev
Core Developer
Dash Core Team
May 20, 2014
3,639
3,537
1,183
Here is a more detailed description of how I get into the Runtime Error on Windows 8:

My wallet was up and running fine and my laptop got into a screen saving mode(after a few minutes of no keyboard activity) . This caused dash-qt to lose synch with the network due to database corruption. By loading the wallet again, it started synching. While it was synching, it again got into a second screen saving mode(again after a few minutes of no keyboard activity). This time the wallet crushed and was no longer able to synch with the network. The initial error message (I did not write down) was something like "level13 error". Keep on loading the wallet then got into the Runtime Error I reported above. I also tried to copy the earlier version of backup wallet.dat into the \dash folder and loaded the wallet again. The same Runrime Error above appears.
pls find debug.log (should be in the same folder next to your wallet.dat) and send it to me [email protected]


EDIT: debug.log received but nothing really helpful there - it looks like wallet starts normally and sync as usual..
 
Last edited:

UdjinM6

Official Dash Dev
Core Developer
Dash Core Team
May 20, 2014
3,639
3,537
1,183
@tnbdash if you are still having issues starting your wallet pls try one of the following:
1) create a shortcut to dash-qt.exe and add " -reindex" (no quotes) to "Target" field, run your wallet using this shortcut and it should reindex the whole blockchain from block 0 - this will take some time.
2) remove blocks and chainstate folders and run your wallet. You'd have to redownload the whole blockchain after doing so however and this will take even more time than option (1). You can use bootstrap.dat file to speed things up a bit https://github.com/UdjinM6/dash-bootstrap
 

tnbdash

New Member
Feb 22, 2016
5
3
3
@tnbdash if you are still having issues starting your wallet pls try one of the following:
1) create a shortcut to dash-qt.exe and add " -reindex" (no quotes) to "Target" field, run your wallet using this shortcut and it should reindex the whole blockchain from block 0 - this will take some time.
2) remove blocks and chainstate folders and run your wallet. You'd have to redownload the whole blockchain after doing so however and this will take even more time than option (1). You can use bootstrap.dat file to speed things up a bit https://github.com/UdjinM6/dash-bootstrap
Thank you very much! The debug.log I sent to you was after I recovered my wallet. I need to correct in my previous messages that the wallet crashed due to my PC get into "hybernation mode" not "screen saving mode". I recovered my wallet by 1) rename one of the recent wallet.dat in the backup folder to the \dash folder; 2)launch wallet; 3)in Tool>Repair Wallet, I clicked reindex. I suppose this is the same as you suggested to have "-reindex" in the Target field.

I think the real issue is dash wallet could crash after Windows 8 get into hibernation, which may need to be investigated.
 
  • Like
Reactions: UdjinM6

tnbdash

New Member
Feb 22, 2016
5
3
3
My wallet is up and running and I can receive fund without any problems, however, I could not send dash. Here is the error message after I typed in my passcode before sending:

Assertion Failed
Program: C:\Program Files\Dash\dash-qt.exe
File: crypter.cpp Line 257
Expression false
 

UdjinM6

Official Dash Dev
Core Developer
Dash Core Team
May 20, 2014
3,639
3,537
1,183
My wallet is up and running and I can receive fund without any problems, however, I could not send dash. Here is the error message after I typed in my passcode before sending:

Assertion Failed
Program: C:\Program Files\Dash\dash-qt.exe
File: crypter.cpp Line 257
Expression false
That's a very bad one :/ This means that some of your private keys cannot be decrypted i.e. wallet could be corrupted. Copy backup folder somewhere and try to use another wallet.<datetime>.dat file as your wallet.dat. Hopefully you have also another backup somewhere else so try that one too.
 

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,286
2,404
1,183
Germany
try "reconsiderblock 0000000000122ce86bf9b563507a22e828746e2d70f19e3703518526a42c258f"
It seems like we were struck by the usual "superblock hiccup" again

In case someones node/client is stuck at block 498479, try


Code:
reconsiderblock 000000000001d804336c90739e5d6c5514409328fc5ed76e3dab989de41dcf74
 
  • Like
Reactions: MangledBlue

rorman

New Member
Apr 19, 2016
5
1
3
My wallet does not seem to be syncing for the last 4 days. Is this something that I should just wait or reload the wallet?
 

tungfa

Grizzled Member
Foundation Member
Masternode Owner/Operator
Apr 9, 2014
8,902
6,740
1,283
My wallet does not seem to be syncing for the last 4 days. Is this something that I should just wait or reload the wallet?
definately restart wallet
 

tungfa

Grizzled Member
Foundation Member
Masternode Owner/Operator
Apr 9, 2014
8,902
6,740
1,283
I tried to restart the wallet a couple times today and that did not work. Is there a way to restore it and then start it back up and recover the transaction sent to it?
reindex wallet !
 

tungfa

Grizzled Member
Foundation Member
Masternode Owner/Operator
Apr 9, 2014
8,902
6,740
1,283
Is there instructions to reindexing a wallet posted somewhere?
on Mac in Terminal (Wallet closed)
copy / paste:
/Applications/Dash-Qt.app/Contents/MacOS/Dash-Qt -reindex
return

PC we have to wait for the pro's
@UdjinM6 sorry brother - can you please help out
tx
 
Jul 23, 2016
3
1
3
45
Halps!
I've done a bunch of reading here and tried to figure things out but alas have had to bother you all and ask another potentially stupid question. My wallet isn't syncing. I've updated to latest version, done the delete peers.dat thing, tried the Wallet Repair - Rebuild Index thing, but still no luck. After doing the Rebuild Index, I get the following errors on startup:
Capture.JPG

If I hit Retry:
Capture1.JPG

If I hit Ignore, wallet loads but doesn't sync. What to do?
 

MangledBlue

Well-known Member
Jun 28, 2014
1,246
678
183
USA
I would make sure I have a back-up of the wallet.dat file - or even many of them
Delete everything and start over from scratch
 

UdjinM6

Official Dash Dev
Core Developer
Dash Core Team
May 20, 2014
3,639
3,537
1,183
Deleted everything (saved wallet backup elsewhere) and reinstalled but still having the same problem
You wallet can't rebuild the chain for some reason - hashes doesn't match. Make sure your disk isn't corrupted, scan for bad blocks etc.

Also can you send me your debug.log pls? [email protected]
(zip it before sending if it's huge or delete it and start wallet once so that debug.log was recreated from scratch)
 

UdjinM6

Official Dash Dev
Core Developer
Dash Core Team
May 20, 2014
3,639
3,537
1,183
Deleted everything (saved wallet backup elsewhere) and reinstalled but still having the same problem
There is clearly smth left in data folder which is interferring with the process - go there and delete "blocks" and "chainstate" folders completely.
 
Jul 23, 2016
3
1
3
45
Uninstalled everything, deleted whole Dash folder, and reinstalled. Looks like it's actually trying to sync now - started at 2 years 27 weeks behind and is now at 2 years 24 weeks behind. I'll keep you posted. Thanks!
 
  • Like
Reactions: UdjinM6

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,871
1,863
1,283
I'm starting up new servers and so I started them with the PPA

I just checked on them, and they were all stopped. I started them back up and now all three of them are rescanning. I'm getting the feeling something's not working...
 

Hickok

New Member
Feb 24, 2017
1
0
1
32
Why doesn't the checksum ever match the download? I keep downloading it but the checksum never changes?