Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

Invalid Masternode Status, cannot continue.

Discussion in 'Masternode Questions and Help.' started by Amazing, Mar 10, 2017.

  1. Amazing

    Amazing New Member

    Joined:
    Oct 19, 2015
    Messages:
    39
    Likes Received:
    6
    Trophy Points:
    8
    I've been trying to update MN.

    When I run ./dash-cli mnsync status I get:
    Code:
    {
      "AssetID": 999,
      "AssetName": "MASTERNODE_SYNC_FINISHED",
      "Attempt": 0,
      "IsBlockchainSynced": true,
      "IsMasternodeListSynced": true,
      "IsWinnersListSynced": true,
      "IsSynced": true,
      "IsFailed": false
    }
    
    I can start the Masternode on my local wallet succesfully (QT wallet lists 'Watchdog Expired')

    However when I try to run sentinel: venv/bin/python bin/sentinel.py I get:
    Code:
    Invalid Masternode Status, cannot continue.
    
    I'm not sure how to trouble shoot this. Also when running ./dash-cli masternode debug I get:
    Code:
    Not capable masternode: Masternode not in masternode list
    
    I've checked obvious things like making sure my dash.conf file has the correct privkey and external IP address. I've also double checked my masternode.conf file.

    But other than that I am a little stumped dash-cli says the masternode is synced.

    Does anyone please have any ideas how to trouble shoot this?
     
  2. Amazing

    Amazing New Member

    Joined:
    Oct 19, 2015
    Messages:
    39
    Likes Received:
    6
    Trophy Points:
    8
    Just to try to answer my own question and anyone who comes up with this problem when updating. I think I finally have the problem resolved and the only thing that fixed it was going in my masternode.conf file and renaming the masternode alias. It seems the problem somehow related to this. I still don't know how it is connected to sentinel and watchdog, but for now at least the masternode is enabled.
     
  3. blockmaster

    blockmaster New Member

    Joined:
    Dec 22, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thank you so much!!

    I had exactly this problem and your (strange, who would've thought this could help?!?) fix worked!

    EDIT: wait, not quite. The sentinel message "Invalid Masternode Status, cannot continue" is gone, but the masternode is still not started... maybe a different issue. ;-|

    EDIT2: just took a while, seems to be up now (although dashman says "masternode started: No", but I think that's incorrect. I can see queue/count: 4626/4634.
     
    #3 blockmaster, Dec 22, 2017
    Last edited: Dec 22, 2017
  4. moocowmoo

    moocowmoo Bovine Bit-flipper
    Foundation Member

    Joined:
    Jun 15, 2014
    Messages:
    483
    Likes Received:
    603
    Trophy Points:
    263
    Dash Address:
    XmoocowYfrPKUR6p6M5aJZdVntQe71irCX
    update dashman to fix that: `dashman sync status` combines getting the latest github changes and running the status command.
     
  5. blockmaster

    blockmaster New Member

    Joined:
    Dec 22, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    thanks!!!

    all green now, except some shell incompatibility when checking sentinel that has always been there but doesn't hurt me:

    (and 3 more of the same kind)
     
  6. ec1warc1

    ec1warc1 Active Member

    Joined:
    Jul 26, 2016
    Messages:
    319
    Likes Received:
    170
    Trophy Points:
    113
    @blockmaster and @moocowmoo To fix the unary operator expected error, edit the file lib/dashman_functions.sh
    look for the line:
    if [ -e $INSTALL_DIR/sentinel ]; then

    and just before it, add (use the correct directory of course):
    INSTALL_DIR=/home/dash/.dashcore

    This will manually force the script to find the correct directory. The error is gone! dashman version 0.1.27 (0.1.27-dirty)