Help me setting up the masternode, bitcoind won't start.

pyc

New Member
May 15, 2014
24
2
3
Hello!

I'm using Debian 7 and I did downloaded pre-comiled http://www.darkcoin.io/downloads/rc/darkcoind because as far as I understand, that RC versions are needed to run masternode, and it's not opensourced yet. Correct me if I'm wrong.

When I try to run it, it outputs this:
Code:
./darkcoind: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by ./darkcoind)
./darkcoind: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./darkcoind)
Already saw somwhere that it's a bit problematic to run on Debian 7... So what's the best system for it then?

Thanks in advance...
 
Last edited by a moderator:

pyc

New Member
May 15, 2014
24
2
3
Ubuntu 12.04.4 LTC, fresh and completely updated, downloaded darkcoind from http://darkcoin.io/downloads/rc/darkcoind
Code:
[email protected]:~/darkcoin$ ./darkcoind
terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid
Aborted (core dumped)
Since everything is so clean and there is not help around Googling about this problem, I must ask again...
 

Lzeppelin

Member
Feb 27, 2014
283
57
88
w00t I finally know something to help someone! Run:
Code:
sudo locale-gen en_US en_US.UTF-8
assuming you want english.
 

Lzeppelin

Member
Feb 27, 2014
283
57
88
thats the answer for which question?
this one:

Ubuntu 12.04.4 LTC, fresh and completely updated, downloaded darkcoind from http://darkcoin.io/downloads/rc/darkcoind
Code:
[email protected]:~/darkcoin$ ./darkcoind
terminate called after throwing an instance of 'std::runtime_error'
  what():  locale::facet::_S_create_c_locale name not valid
Aborted (core dumped)
Since everything is so clean and there is not help around Googling about this problem, I must ask again...
The server just does not have a locale set up, exact same thing happened to me.
 

pyc

New Member
May 15, 2014
24
2
3
Tried setting locale, and I still have the same error :( Anyways, thanks...
 

yidakee

Well-known Member
Foundation Member
Apr 16, 2014
1,812
1,168
283
export LC_ALL=C helped!
I had all these problems when using OSx terminal to SSH into a VPS to setup a MN. After going bonkers trying to solve all the errors, I simply installed VM Ubuntu on my Mac, killed my server and redid everything without a hick-up.

OSx terminal screws up into linux via SHH somehow. Tried for days to compile on early RC masternode testnet and almost drove me nuts. Even with these fixes I never managed to get it going properly.