Electrum Dark

akhavr

Active Member
Oct 11, 2014
829
412
133

Cofresí

Member
Dash Core Team
Aug 22, 2014
86
82
58
121
Carribean

akhavr

Active Member
Oct 11, 2014
829
412
133

AjM

Well-known Member
Foundation Member
Jun 23, 2014
1,341
575
283
Finland
And were I can find testnet blockexplorer? Would like to make sure that #371a978075436de8cb36f0a1d77633554998944c93f80a7014c3a8730e9f0b8e made through to the faucet

Upd: http://test.explorer.darkcoin.fr/tx/371a978075436de8cb36f0a1d77633554998944c93f80a7014c3a8730e9f0b8e
Looks fine for me.

So, right now I'll push the changes to the repo and will declare electrum server and client ready for testnet.
Testnet tools: https://darkcointalk.org/threads/sticky-testnet-tools-resources.1768/
 
  • Like
Reactions: akhavr

thelonecrouton

Well-known Member
Foundation Member
Apr 15, 2014
1,135
813
283
Where do we get it? I have a spare VPS doing nothing and want to perpetrate psychadelic mayhem upon the client.
 

thelonecrouton

Well-known Member
Foundation Member
Apr 15, 2014
1,135
813
283
Do you want a "prebuilt" archive? (to the extend possible with python)

In case you've missed, server is https://github.com/akhavr/electrum-drk-server and client is https://github.com/akhavr/electrum-drk
Thanks. A prebuilt archive might help idiots like me. :)

Installed whatever the client complained was missing ( sudo pip install pyasn1, sudo pip install pyasn1-modules, sudo pip install tlslite, then ran pyrcc4 icons.qrc -o gui/qt/icons_rc.py when told to) but it now gives me: 'ImportError: No module named qrcode'
 

akhavr

Active Member
Oct 11, 2014
829
412
133
Thanks. A prebuilt archive might help idiots like me. :)
For such multitaskers like me - please, create an issue for this?

Installed whatever the client complained was missing ( sudo pip install pyasn1, sudo pip install pyasn1-modules, sudo pip install tlslite, then ran pyrcc4 icons.qrc -o gui/qt/icons_rc.py when told to) but it now gives me: 'ImportError: No module named qrcode'
Hmm...

Code:
(.electrum-drk)[email protected] ~/src/electrum-drk $ pip list | grep qrco
qrcode (5.0.1)
Should be installed automatically via
Code:
pip install -r requirements.txt
... Ouch.. Got it. Please, create an issue too, so my ADD wont have a chance
 
  • Like
Reactions: thelonecrouton

akhavr

Active Member
Oct 11, 2014
829
412
133
Pushed `requirements.txt` to the repo. It contains complete list of necessary modules
 

tungfa

Grizzled Member
Foundation Member
Masternode Owner/Operator
Apr 9, 2014
8,900
6,740
1,283
hey guys,
how is the progress going ?!
 

Gorila1977

New Member
Dec 21, 2014
2
1
3
=== SERIOUS CONCERNS, ADDRESSED TO MAINTAINERS OF ELECTRUM-DRK REPO ===

[3*w] electrum-drk org
[3*w] github com/electrum-drk/electrum-drk


I've installed the necessary libraries and launched Electrum-DRK client.
However, it looks like a Bitcoin wallet, not a DRK wallet!

1) Application's logo is a Bitcoin version
2) Quotes from different menus of GUI :

- "lightweight BITCOIN CLIENT"
- "with low resource usage and simplifying BITCOIN"
- "Startup times are instant because it operates in conjunction with high-performance servers that handle the most complicated parts of the BITCOIN SYSTEM"
- "You may enter a BITCOIN ADDRESS, a label from your list of contacts"
- "BITCOIN transactions are in general not free"
- "BITCOIN Address is None"
- "Invalid BITCOIN Address"
- "Invalid BITCOIN URI"

Also, all the source code is pointing to Bitcoin...

3) I couldn't find a single mention of Darkcoin or DRK (except a project's name)
Even currency in GUI is labeled as mBTC, not DRK

---

Electrum-DRK is not dealing with Darkcoins, so this fork deserves to be put in trash
 
Last edited by a moderator:

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,286
2,404
1,183
Germany
=== SERIOUS CONCERNS, ADDRESSED TO MAINTAINERS OF ELECTRUM-DRK REPO ===

github : electrum-drk/electrum-drk

I've installed the necessary libraries and launched Electrum-DRK client.
However, it looks like a Bitcoin wallet, not a DRK wallet!

1) Application's logo is a Bitcoin version
2) Quotes from different menus of GUI :

- "lightweight BITCOIN CLIENT"
- "with low resource usage and simplifying BITCOIN"
- "Startup times are instant because it operates in conjunction with high-performance servers that handle the most complicated parts of the BITCOIN SYSTEM"
- "You may enter a BITCOIN ADDRESS, a label from your list of contacts"
- "BITCOIN transactions are in general not free"
- "BITCOIN Address is None"
- "Invalid BITCOIN Address"
- "Invalid BITCOIN URI"

Also, all the source code is pointing to Bitcoin...

3) I couldn't find a single mention of Darkcoin or DRK (except a project's name)
Even currency in GUI is labeled as mBTC, not DRK

---

Electrum-DRK is not dealing with Darkcoins, so this fork deserves to be put in trash
Thanks for you contribution.

If you would have read the thread you would have noticed that the migration is done in

https://github.com/akhavr/electrum-drk

Feel free to join the development and fix the outstanding issues.

Thanks,
Holger
 

Gorila1977

New Member
Dec 21, 2014
2
1
3
Thanks for you contribution.

If you would have read the thread you would have noticed that the migration is done in

[3*w] github com/akhavr/electrum-drk

Feel free to join the development and fix the outstanding issues.

Thanks,
Holger
I am very sorry, I got confused by [3*w] electrum-drk org website which is pointing to wrong electrum-drk/electrum-drk repository.
If you have a control over this website, please replace a link with [3*w] github com/akhavr/electrum-drk ,
because it is very confusing for newcomers... :p
 
  • Like
Reactions: fernando