Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

Unable to bind :9999

Discussion in 'Daemon and QT Wallet Support' started by leeheinke, May 16, 2014.

  1. leeheinke

    leeheinke New Member

    Joined:
    May 16, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi Guys,

    Just downloaded the Darkcoin wallet and upon opening it in Windows 8 i get the following error,

    "Unable to bind to 0.0.0.0:9999 on this computer. Dark Coin is probably already running."

    Then after clicking ok, the 2nd error message says,

    "failed to listen on any port. Use -listen=0 if you want this."

    To answer your first question, no Darkcoin is not already running.

    Any ideas what the problem could be?

    I have closed all other wallets and done all the other usual malarkey like turn off security software etc

    Thanks in advance!
     

    Attached Files:

    • dc1.png
      dc1.png
      File size:
      295.2 KB
      Views:
      6
    • dc2.jpg
      dc2.jpg
      File size:
      141 KB
      Views:
      6
  2. leeheinke

    leeheinke New Member

    Joined:
    May 16, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi Guys,
    Just downloaded the Darkcoin wallet and upon opening it in Windows 8 i get the following error,
    "Unable to bind to 0.0.0.0:9999 on this computer. Dark Coin is probably already running."
    Then after clicking Ok, the 2nd error message says,
    "failed to listen on any port. Use -listen=0 if you want this."
    To answer your first question, no Darkcoin is not already running and pretty much all ports in that range are open.
    Any ideas what the problem could be?
    I have closed all other wallets and done all the other usual malarkey like turn off security software etc
    Thanks in advance!
     
  3. Propulsion

    Propulsion The buck stops here.

    Joined:
    Feb 26, 2014
    Messages:
    1,008
    Likes Received:
    467
    Trophy Points:
    183
    Dash Address:
    XerHCGryyfZttUc6mnuRY3FNJzU1Jm9u5L
    Did you ever figure this out?
     
  4. leeheinke

    leeheinke New Member

    Joined:
    May 16, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Nope, still working on it but thanks for asking.
     
  5. yidakee

    yidakee Well-known Member
    Foundation Member

    Joined:
    Apr 16, 2014
    Messages:
    1,812
    Likes Received:
    1,168
    Trophy Points:
    283
    open explorer and type

    Look for Darkcoin folder. Open folder and look inside. Then, right click and create a new text document and drop in
    Save the file as
    ... be double sure there is no .txt attached in the end

    Fire up the wallet. Should fix it. If it does, you probably have your router blocking that port.
     
  6. karisu

    karisu Member

    Joined:
    Jun 30, 2014
    Messages:
    70
    Likes Received:
    26
    Trophy Points:
    58
    I had the same problem once when I started bitcoind without a darkcoin.conf and then without adding
    rpcpassword=CqbmPwd49ArBeqT1x9VnJUT4dfsJ6B3pPPu8AbbaSvoo
    rpcallowip=127.0.0.1
    I started the daemon again which resulted in the exact same message. I think it can happen too if you don't have the writing rights to the darkcoin folder.
     
  7. jasisboy

    jasisboy New Member

    Joined:
    Feb 5, 2015
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    3

    Thank you yidakee! Your explanation worked out perfect for me.
     
    • Like Like x 1