Ubuntu terminal: Mining not starting

badseed

New Member
Jun 1, 2014
4
0
1
Hi, I am trying to start cpu mining via ubuntu 14.04 terminal. I have done it with Litecoin before and that was easy, but for some reason it won't start mining darkcoin. I have an account at drk.cpu-pool.net and enter my info like this:


cpuminer-2.4$ ./minerd -a X11 -o stratum+tcp://drk.cpu-pool.net:3500 -u Weblogin.Worker -p Worker password

cpuminer-2.4$ ./minerd -a X11 -o stratum+tcp://drk.cpu-pool.net:3500 -u username.workername -p workerpassword
./minerd: unknown algorithm -- 'X11'
Try `minerd --help' for more information.

I am not a Ubuntu ninja, and don't understand what this means. I have tried many combinations including caps/ non-caps, removing "stratum+" etc.

Then I try the format given here:
$ ./minerd --url=stratum+tcp://myminingpool.com:3333 --userpass=my.worker:password
[email protected]:~/cpuminer-2.4$ ./minerd --url=stratum+tcp://drk.cpu-pool.net:3500 --userpass=workername:workerpassword
[2014-06-01 12:39:58] 1 miner threads started, using 'scrypt' algorithm.
[2014-06-01 12:39:58] Starting Stratum on stratum+tcp://drk.cpu-pool.net:3500
[2014-06-01 12:40:28] Stratum connection failed: Connection timed out after 30000 milliseconds
[2014-06-01 12:40:28] ...retry after 30 seconds
[2014-06-01 12:41:28] Stratum connection failed: Connection timed out after 30001 milliseconds
[2014-06-01 12:41:28] ...retry after 30 seconds

The next time I do it, it says
[email protected]:~/cpuminer-2.4$ ./minerd --url=stratum+tcp://drk.cpu-pool.net:3500 --userpass=workername:workerpassword
[2014-06-01 12:47:58] 1 miner threads started, using 'scrypt' algorithm.
[2014-06-01 12:47:58] Starting Stratum on stratum+tcp://drk.cpu-pool.net:3500
[2014-06-01 12:47:59] Stratum authentication failed
[2014-06-01 12:47:59] ...retry after 30 seconds

why does authentication fail? I am logged into cpu-pool.net if that helps...


I also tried:

[email protected]:~/cpuminer-2.4$ ./minerd --url=stratum+tcp://drk.cpu-pool.net:3500 --userpass=username:userpassword
[2014-06-01 12:53:37] 1 miner threads started, using 'scrypt' algorithm.
[2014-06-01 12:53:37] Starting Stratum on stratum+tcp://drk.cpu-pool.net:3500
[2014-06-01 12:54:07] stratum_subscribe timed out
[2014-06-01 12:54:07] ...retry after 30 seconds
[2014-06-01 12:55:07] stratum_subscribe timed out
[2014-06-01 12:55:07] ...retry after 30 seconds

"stratum_subscribe".....??

Can anyone help in getting this started? Thank you!
 
Last edited by a moderator:

badseed

New Member
Jun 1, 2014
4
0
1
Never mind. I got it working by:
./minerd --url=stratum+tcp://drk.cpu-pool.net:3500 --userpass=username.workername:workerpassword
 

badseed

New Member
Jun 1, 2014
4
0
1
Hmmm I get only Booooos... I think it is running scrypt, not X11. How to fix?
(changed pool)

./minerd -a X11 -o --url=stratum+tcp://drk.yobapool.net:3333 --userpass=username.workername:workerpassword
./minerd: unknown algorithm -- 'X11'
Try `minerd --help' for more information.

Thanks.