Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

Transaction too large error

Discussion in 'Daemon and QT Wallet Support' started by romario, Apr 23, 2015.

  1. romario

    romario New Member

    Joined:
    Apr 2, 2015
    Messages:
    31
    Likes Received:
    5
    Trophy Points:
    8
    Hey guys

    Hope you can help me with the issue I recently faced.

    My wallet balance is ~ 500 DASH, which consists of thousands of tiny incoming payments and a couple of larger transactions of 100-150 DASH each.

    Every time I try to send out an amount larger than 5 DASH, I have the "transaction too large" error.
    Sending 1-3 DASH or less is no problem. I was trying to play with the settxfee option, but it didn't help.

    Is there any way to sort it out?

    P.S. Running dashd on Debian7
    P.P.S. After I sent several payments of 1-3 DASH, now I cant send even 0.5-1 DASH and keep having this "Transaction too large" error. Pls help
     
    #1 romario, Apr 23, 2015
    Last edited by a moderator: Apr 23, 2015
  2. UdjinM6

    UdjinM6 Official Dash Dev
    Dash Core Team Moderator

    Joined:
    May 20, 2014
    Messages:
    3,637
    Likes Received:
    3,536
    Trophy Points:
    1,183
    Hi there,

    There is a limit of ~100Kb per one transaction and each input takes some to be included in transaction. You can try to use scripts like this https://people.xiph.org/~greg/groomer.py to generate combining txes for small outputs (that one is for bitcoin so don't forget to use correct rpc port - 9998) or use qt wallet to select inputs manually. To see in qt how much your tx will take turn on Coin Control feature (settings -> wallet -> click corresponding checkbox) and then click "Inputs..." button on Send tab to actually select inputs. Once you start selecting them you will see size of your tx and corresponding warning labels there.
     
    • Like Like x 2
  3. romario

    romario New Member

    Joined:
    Apr 2, 2015
    Messages:
    31
    Likes Received:
    5
    Trophy Points:
    8
    Thanks! I will try it
     
  4. Rabinovitch

    Rabinovitch Member

    Joined:
    Mar 29, 2016
    Messages:
    103
    Likes Received:
    13
    Trophy Points:
    68
    Is there any new, convenient, automated and fast way to avoid this error now in Dec. 2017? Just imagine a person staying in some store and seeing this error in his SW wallet when he need to pay for some goods right now...
     
  5. Rabinovitch

    Rabinovitch Member

    Joined:
    Mar 29, 2016
    Messages:
    103
    Likes Received:
    13
    Trophy Points:
    68
    I can't believe that nobody cares, including DASH developers... Meanwhile I found some script that can help in such situations. But I have no enough skills to start it...

    https://github.com/elbereth/EasyDash-PHP
     
  6. crowning

    crowning Well-known Member

    Joined:
    May 29, 2014
    Messages:
    1,428
    Likes Received:
    2,005
    Trophy Points:
    183
    Actually it needs quite some inputs (around 580 last time I've tested, but that's a long time ago) to exceed the maximum transaction size, so either you got LOTs of small payments (like with a P2P pool mining wallet) or a LOT of big payments (like someone with lots of Masternodes) and want to spend big money.

    In other words, no wallets I would take to the store.

    If you want to avoid this scenario, just consolidate your inputs. Select e.g. 500 inputs in Coin Control (hint: it's easiest to do this in Tree-View there) , and send them to a newly created (own) address.
    Or to your wallet which you plan to take to the store.