Masternode shutting down after a day

darkness

Member
Mar 9, 2014
39
8
48
My masternode keeps shutting down after about a day. It seems to be looking to update the wallet.dat, but since there is no wallet.dat on the server it shuts down.

Here is the log:

Code:
2014-11-27 01:55:36 Committing 1233 changed transactions to coin database...
2014-11-27 01:55:36 *** System error: CDB() : can't open database file wallet.da                                                                                                                                                             t, error 2
2014-11-27 01:55:36 Error: System error: CDB() : can't open database file wallet                                                                                                                                                             .dat, error 2
2014-11-27 01:55:36 ERROR: AcceptBlock() : AddToBlockIndex failed
2014-11-27 01:55:36 ERROR: ProcessBlock() : AcceptBlock FAILED
2014-11-27 01:55:36 send last getblocks for 0000000000085e722056f89eb9b5e005f24d                                                                                                                                                             64dd652ae54f92153e1defee7419 peer=86
2014-11-27 01:55:36 opencon thread interrupt
2014-11-27 01:55:36 dumpaddr thread stop
2014-11-27 01:55:36 Shutdown : In progress...
2014-11-27 01:55:36 addcon thread interrupt
2014-11-27 01:55:36 Flush(false)
2014-11-27 01:55:36 wallet.dat refcount=0
2014-11-27 01:55:36 wallet.dat checkpoint
2014-11-27 01:55:36 net thread interrupt
2014-11-27 01:55:36 msghand thread interrupt
2014-11-27 01:55:36 wallet.dat detach
2014-11-27 01:55:36 wallet.dat closed
2014-11-27 01:55:36 DBFlush(false) ended               1ms
2014-11-27 01:55:36 StopNode()
2014-11-27 01:55:36 Flushed 10575 addresses to peers.dat  53ms

I am starting the MN with the wallet on the node and then deleting the wallet.dat after MN has started. I have been doing this since the start and it always worked fine.

I've tried deleting peers.dat, reinstalling newest version of darkcoind, and running darkcoind as root.

Is there a command to enable cold wallet?
 

oblox

Well-known Member
Aug 6, 2014
1,032
537
183
Alter your settings in your darkcoin.conf and setup a local darkcoin client with the matching remote settings to allow you to properly run a cold-remote masternode. Use Tao's guide as a reference point. Just because you starting and deleting the wallet.dat worked before doesn't mean anything... it's a poor way of running it. I've told you this already.