• Forum has been upgraded, all links, images, etc are as they were. Please see Official Announcements for more information

v14.0 Testing

How to use the test network? I installed the latest wallet 0.13.3 on the official network. The test network can not be synchronized to the latest block, but only to the block height 78808. How to upgrade to 0.14?
v0.14.0.0-rc5 has just been released: https://github.com/dashpay/dash/releases/tag/v0.14.0.0-rc5

Please upgrade when you find time. This RC is very close to what's going to be the final version.
This RC mostly contains bug fixes and performance improvements for LLMQ based ChainLocks and InstantSend.

An additional change is the introduction of simulated DKG errors and simulated misbehavior. I've configured all my masternodes to simulate a few errors in upcoming DKGs, so we should see regular complaints and justification messages on testnet now.
Should latest pull request for 14.0 (#2923) not be labeled as a bug fix, in what should be
a code freeze by now this close to 14.0 release ? If its not a bug fix, should it not be reserved for 14.1 ?

It worries me that this new code (bug fix or not) will effectively get less testing time then it would receive with a 14.1 update release. Also i feel like the code freeze process now comes across as a process that is being handled somewhat loosely and not strictly enforced.

Edit : the already approved 0.14 release notes draft pull request #2896 needs to be updated, reviewed and acknowledged again to include #2923
Last edited:
I used v0.14 to run the test network, but when I started synchronizing to the latest block, I ran out of memory, executed commands like dash-cli with no response, and started synchronizing from the first block after restarting.
@wangzf you should use these binaries for testnet: https://github.com/dashpay/dash/releases/tag/v0.14.0.0-rc5

It is easiest to use a clean datadir and sync from scratch. If you are stuck at block 78808 using, you can use the `getchaintips 5` command to find the block marked invalid and then `invalidateblock <blockhash>` to try and get to the right chain height again.

Faucet here: http://faucet.test.dash.crowdnode.io/

2019-05-17 09:06:33 ERROR: AcceptBlockHeader: block 00000000154499187efd42d9d63d874d0699f230748a7575ac0be154eafc1022 is marked invalid
2019-05-17 09:06:33 ERROR: invalid header received
Submit the signed message :This step of operation has been misreported. The error is as follows.

./dash-cli protx register_submit "03000100012b49b2e31f6097188676c0074d060cdeb2acf1fa929c779cf24f5cbcb83e1b670000000000feffffff0121c89a3b000000001976a914290cad49d053a230caae20873bfe2882aa08684088ac00000000d1010000000000a38321ed944a58cbfd45502e30d1f02ed729f18082f3cf703d8b61c4f7dbe9aa0100000000000000000000000000ffff7f00000127140a46247cb37a14429f93bb3382101069c96f9fea808c4a25d8051876f94805c555acaea9c9eb3c0bc252e99e0c44d64ffdb72244ae1e67236c1c882a25ecaa1947ffa758063e603c53107e8ba78fa858628113f2a35a499800001976a914298655b3f03b1b940146016dbbb97a82982ff56a88acd3d8a865c5d5c184259f1f82ed201b1ac3dd10f3549348c273d66bd93377d7af00" "IJKBhxsWogxWfN4K6L5k\/1h7XgQaFJqiN4Lk49pjrAz4BWppEI5q1AIy9+eXxQ2J9lOJfANB8sl1IGj04dul2nU="
error code: -1
error message:
bad-protx-collateral (code 16)

Hi @wangzf I'm not sure why you're getting this message, your collateral looks like it is defined properly in the protx:

"proRegTx": {
"version": 1,
"collateralHash": "aae9dbf7c4618b3d70cff38280f129d72ef0d1302e5045fdcb584a94ed2183a3",
"collateralIndex": 1,
"service": "",
"ownerAddress": "yMFmdi7TBqvoXN2MEcpbTb43g1eKCceNMT",
"votingAddress": "yLtTdJse23PForWwaJ8FwRTWK7gDtMVM1k",
"payoutAddress": "yQ71Up3wADdNv2oyEhBVFCj7cagxyAxd56",
"pubKeyOperator": "808c4a25d8051876f94805c555acaea9c9eb3c0bc252e99e0c44d64ffdb72244ae1e67236c1c882a25ecaa1947ffa758",
"operatorReward": 0,
"inputsHash": "afd77733d96bd673c2489354f310ddc31a1b20ed821f9f2584c1d5c565a8d8d3"

I tried to build your probable transaction that you should have signed with the collateral key for yQ4Vjsi2jY5HkxVxRQpjL2wXpQhYiKyKKn as follows:

"signMessage": "yQ71Up3wADdNv2oyEhBVFCj7cagxyAxd56|0|yLtTdJse23PForWwaJ8FwRTWK7gDtMVM1k|yMFmdi7TBqvoXN2MEcpbTb43g1eKCceNMT|afd77733d96bd673c2489354f310ddc31a1b20ed821f9f2584c1d5c565a8d8d3"

And it did not verify. Can you post your input and output of protx register_prepare please?

It might be easier to discuss this on Discord in realtime. You can find me there as user @strophy#2696
100 tDASH