Updating to 12.1 - Not capable masternode: Could not connect to X.X.X.X:9999

JOL

Member
Feb 8, 2017
117
44
78
Solved - it not an Dash error, just a network wrong configuration
Hi,

I have 2 MN.
I use Updating+to+12.1+-+Masternodes

For my 1st MN all gone well.

For the 2nd one have this mesage :
Not capable masternode: Could not connect to X.X.X.X:9999

Already try :

- Delete all .dat (not wallet) on MN and on cold wallet
- Restart with -reindex
- send masternode start-alias MYALIAS
- wait
- send masternode start-alias MYALIAS
- wait 1h
- ....

And do it it again ...

dash.conf

rpcuser=YYYYYYYYY
rpcpassword=ZZZZZZZ
rpcallowip=127.0.0.1
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
masternode=1
masternodeprivkey=MYPRIVKEY
addnode=23.23.186.131


On wallet the MN "active" : -07mn:07s

./dash-cli getinfo
{
"version": 120100,
"protocolversion": 70206,
"walletversion": 61000,
"balance": 0.00000000,
"privatesend_balance": 0.00000000,
"blocks": 617315,
"timeoffset": 0,
"connections": 8,
"proxy": "",
"difficulty": 81926.25057225698,
"testnet": false,
"keypoololdest": 1483464700,
"keypoolsize": 1001,
"paytxfee": 0.00000000,
"relayfee": 0.00010000,
"errors": ""
}

./dash-cli mnsync status
{
"AssetID": 999,
"AssetName": "MASTERNODE_SYNC_FINISHED",
"Attempt": 0,
"IsBlockchainSynced": true,
"IsMasternodeListSynced": true,
"IsWinnersListSynced": true,
"IsSynced": true,
"IsFailed": false
}

./dash-cli masternode debug
Not capable masternode: Could not connect to X.X.X.X:9999

What can i try to find my missing step.

thx
 
Last edited:
  • Like
Reactions: stan.distortion

AjM

Well-known Member
Foundation Member
Jun 23, 2014
1,335
571
283
Finland
dash.conf
Remove addnode row
Add row externalip=yournodeip:9999
Restart masternode
 
  • Like
Reactions: JOL

JOL

Member
Feb 8, 2017
117
44
78
A

And masternode firewall is ok, port 9999 allowed?
Yes, MN work fin before update

Just delete all.

I find this error in debug.log
torcontrol thread start
2017-02-08 07:15:41 ERROR: Read: Deserialize or I/O error - CAutoFile::read: end of file
2017-02-08 07:15:41 Invalid or missing banlist.dat; recreating

AND

CDBEnv::Open: LogDir=/home/ME/.dashcore/database ErrorFile=/home/ME/.dashcore/db.log

Dont know if its important.
 

AjM

Well-known Member
Foundation Member
Jun 23, 2014
1,335
571
283
Finland
Yes, MN work fin before update

Just delete all.

I find this error in debug.log
torcontrol thread start
2017-02-08 07:15:41 ERROR: Read: Deserialize or I/O error - CAutoFile::read: end of file
2017-02-08 07:15:41 Invalid or missing banlist.dat; recreating

AND

CDBEnv::Open: LogDir=/home/ME/.dashcore/database ErrorFile=/home/ME/.dashcore/db.log

Dont know if its important.
Calling help, @flare @UdjinM6
 

SirHikmat

Member
Nov 15, 2014
93
57
68
./dash-cli masternode debug
Not capable masternode: Could not connect to X.X.X.X:9999

What can i try to find my missing step.

thx
there were some changes in the networking. I had a similar problem with a special setup. I redirect all server outbound traffic to my ip (Port 9999) to localhost:9999.

Try the following:
Code:
sudo iptables -t nat -I OUTPUT -d YOURIP -p tcp --dport 9999 -j REDIRECT --to-ports 9999
Change YOURIP to your public IPV4-IP. After that, your dashd should be able to connect to your IP.
 
  • Like
Reactions: KryptoTypek and JOL

stan.distortion

Active Member
Oct 30, 2014
847
495
133
Sentinel passed tests ok?

EDIT: Special characters in rpcuser anr/or rpcpassword have also caused issues, alphanumeric only.
 
  • Like
Reactions: JOL

SirHikmat

Member
Nov 15, 2014
93
57
68
@SirHikmat probably have the solution but anyway - is your masternode really reachable from the outside? Try "masternode connect yourip:9999", should say "successfully connected".
yes, mine is reachable from the outside. The masternode is on dashninja and in the masternode list, listed as "Enabled".

I'll post more details, as soon as I understand my problem (maybe some problems with my /etc/hosts or my ipconfig)
 

JOL

Member
Feb 8, 2017
117
44
78
there were some changes in the networking. I had a similar problem with a special setup. I redirect all server outbound traffic to my ip (Port 9999) to localhost:9999.

Try the following:
Code:
sudo iptables -t nat -I OUTPUT -d YOURIP -p tcp --dport 9999 -j REDIRECT --to-ports 9999
Change YOURIP to your public IPV4-IP. After that, your dashd should be able to connect to your IP.
Reindex not finish yet, test it just after
yes, mine is reachable from the outside. The masternode is on dashninja and in the masternode list, listed as "Enabled".

I'll post more details, as soon as I understand my problem (maybe some problems with my /etc/hosts or my ipconfig)

./dash-cli masternode connect X.X.X.X:9999
error code: -32603
error message:
Couldn't connect to masternode X.X.X.X:9999

looks like network conf problem.

sudo ufw status
État : actif

Vers Action De
---- ------ --
22/tcp LIMIT Anywhere
9999/tcp ALLOW Anywhere
22/tcp (v6) LIMIT Anywhere (v6)
9999/tcp (v6) ALLOW Anywhere (v6)



I try
sudo iptables -t nat -I OUTPUT -d YOURIP -p tcp --dport 9999 -j REDIRECT --to-ports 9999

nothing change for me :)

Its looks like network issu. but i realy dont know where it is at this time.

Thx for your help, its not a dash issu, just my virtual machine network issu.
 
Last edited:

JOL

Member
Feb 8, 2017
117
44
78
I have to restart my masternode (mouving physical server)

After restart MN i cant have masternode working, i have to do

Stop

sudo iptables -t nat -I OUTPUT -d YOURIP -p tcp --dport 9999 -j REDIRECT --to-ports 9999

start

Or juste it need a 2nd start i dont know, it very strange.
 

UdjinM6

Official Dash Dev
Dash Core Team
Moderator
May 20, 2014
3,638
3,538
1,183
Hi guys,

I have the same problem as above. I'm running Dash Core 0.12.1.5 and my masternode's status is ""Not capable masternode: Masternode in NEW_START_REQUIRED state"

When I test it with the "./dash-cli masternode connect X.X.X.X:9999" command, it can't connect to the daemon if I try it locally, but it works fine when I run the command from another machine.

I use ufw and it worked fine before. Could you help me fix the problem?
You need to start masternode from local wallet again i.e. "masternode start-alias your_MN_alias_here".