Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

sgminer help - MSI 7950 Twin Frozer

Discussion in 'Mining' started by DRKDays4, Sep 3, 2014.

  1. DRKDays4

    DRKDays4 New Member

    Joined:
    Sep 3, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hi All,

    Have been CPU mining ok for a while now and just picked up a MSI 7950 Twin Frozer III GPU. Having no luck getting sgminer to work. Have tried many different versions of sgminer with settings from many other users all with no luck.

    I continually get HW errors with all settings I try.

    Win 7 x64
    AMD Catalyst 13.1
    Driver: 9.14.10.0945

    Interestingly Windows uninstalled my onboard graphics card after installing the 7950, so currently this is my only GPU. Not sure if this is an issue?

    Settings (sgminer 4.1.0)

    Batch File:

    set GPU_MAX_ALLOC_PERCENT=100
    set GPU_USE_SYNC_OBJECTS=1
    sgminer -k darkcoin -o stratum+tcp://stratum1.suchpool.pw:3335 -u abc -p def -I 16 -w 64 --thread-concurrency 8192

    Error:

    [22:02:15] (5s):1.513M (avg):1.513Mh/s | A:0 R:0 HW:4 WU:0.000/m
    [22:02:19] GPU0: invalid nonce - HW error


    Can anyone help with 7950 settings?

    Cheers in advance!
     
  2. Ignition75

    Ignition75 Active Member

    Joined:
    May 25, 2014
    Messages:
    332
    Likes Received:
    216
    Trophy Points:
    113
    You settings seem fine.

    Windows would be uninstalling your on board gpu most likely because your mobo BIOS is auto detecting the graphics.

    As a general rule of thumb, hardware errors are because intensity is too high. Try first with 11 or 12 and then work you way up, see how you go with that first.
     
  3. OnetyOne

    OnetyOne New Member

    Joined:
    Aug 4, 2014
    Messages:
    34
    Likes Received:
    19
    Trophy Points:
    8
    GPU0: invalid nonce - HW error is mostly caused by the catalyst driver. Update to the latest or roll back 1 or 2 versions to see if it runs the same Sgminer config.

    Edit; Could also be intensity, see https://bitcointalk.org/index.php?topic=179718.0
     
  4. DRKDays4

    DRKDays4 New Member

    Joined:
    Sep 3, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for your prompt responses!

    Have tried changing intensity to 10. Same issue just took longer to occur.

    I forgot to mention I'm running AMD SDK 2.7

    Will try an older driver version 8.982
     
  5. OnetyOne

    OnetyOne New Member

    Joined:
    Aug 4, 2014
    Messages:
    34
    Likes Received:
    19
    Trophy Points:
    8
    Cool. Could also try a CCC (catalyst) update since we're on 14.X version now.
     
  6. DRKDays4

    DRKDays4 New Member

    Joined:
    Sep 3, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Uninstalled everything AMD/ATI and also ran cccleaner.

    Installed Catalyst 12.8 along with drivers. Still no luck and still receiving the HW errors.

    Will try a 14.x version tomorrow...
     
  7. Ignition75

    Ignition75 Active Member

    Joined:
    May 25, 2014
    Messages:
    332
    Likes Received:
    216
    Trophy Points:
    113
    I know this wont make sense, and I've had people argue with me black and blue on this, but sometimes, when I'm getting bullshit errors to do with my rigs, I reflash a fresh mobo bios and reset all settings to default and my problems go away.

    It's a "when all else fails" type of play, it's worked a couple of times for me.
     
  8. DRKDays4

    DRKDays4 New Member

    Joined:
    Sep 3, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Catalyst 14.4 made things worse. Running my batch file sgminer just crashed each time.

    Rolling back to an earlier version currently.
     
  9. darkwing

    darkwing Active Member

    Joined:
    Apr 8, 2014
    Messages:
    149
    Likes Received:
    110
    Trophy Points:
    103
    Also try sgminer 5 with darkcoin-mod kernel
    works fine with catalyst 14.6

    https://bitcointalk.org/index.php?topic=632503.0
     
  10. DRKDays4

    DRKDays4 New Member

    Joined:
    Sep 3, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Still no luck with this. Spent all day trying to get a working version of the driver installed after installing 14.4 last night. Each time I uninstalled, rebooted, installed version x, rebooted I got all sorts of errors with apps crashing in windows (explorer, catalyst, etc) and sgminer would not run at all.

    Eventually got the PC back running ok on 13.1 and 2.9 SDK, but now back to the HW errors.

    Haven't tried bios flash as yet.

    Downloaded sgminer 5 but when running with my same batch file it gives error stating no usable GPU found and quits. Might have to try updating catalyst to 14.4/6 and try again, though I hope I don't have the same issues as today.....

    Frustrating!
     
  11. freedomdude

    freedomdude New Member

    Joined:
    Aug 30, 2014
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    3
    Try using ExO BAMT. Goggle ExO BAMT and down loan from Mega. This program works great. Just follow the instructions.
     
  12. DRKDays4

    DRKDays4 New Member

    Joined:
    Sep 3, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Have downloaded ExO BAMT and made the bootable USB drive, however my system isn't booting from it. Will look into this over the weekend.
     
  13. freedomdude

    freedomdude New Member

    Joined:
    Aug 30, 2014
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    3
    I have 3 machines and I forgot that 1 was a windows machine. You have to adjust the BIOS to prefer the usb drive over the hard drive when the machine boots up. The mother board had issues with this so I disconnected the hard drive from the mother board. This should do the trick. There is a you tube video that shows how the settings work. You should be up and running in less than an hour.
     
  14. Ignition75

    Ignition75 Active Member

    Joined:
    May 25, 2014
    Messages:
    332
    Likes Received:
    216
    Trophy Points:
    113
    Sounds to me like you also need to wipe all GPU drivers from your machine and start again...
     
  15. DRKDays4

    DRKDays4 New Member

    Joined:
    Sep 3, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    So I got EX0-BAMT running by disconnecting my HDD, and it started hashing - for about 5mins before the whole PC froze. Might have to try adjusting the config settings.

    Any idea how to easily remove all GPU drivers Ignition? When testing the different Catalyst versions I was uninstalling it, rebooting, using CCleaner to remove registry hangovers then a batch script to remove the dll files from system32 and syswow64 (got this from Review Outlaw website).

    Thanks all for your help so far.
     
  16. DRKDays4

    DRKDays4 New Member

    Joined:
    Sep 3, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    So..... success so far!!

    Using EX0-BAMT getting 1.2MH/s at the moment. Ended up removing some RAM from the PC (it has 32GB as I was running VM's on it previously), took it back to a single 8GB module and it is running ok. Could be a dodgy module perhaps?

    Will continue to monitor.

    Thanks all for your help and suggestions.
     
  17. Ignition75

    Ignition75 Active Member

    Joined:
    May 25, 2014
    Messages:
    332
    Likes Received:
    216
    Trophy Points:
    113
    There is a windows program I used to use, just google 'remove all video drivers' and it's the first to come up, but sounds like you're sorted now, nice one.
     
  18. fra55

    fra55 Member

    Joined:
    Mar 26, 2014
    Messages:
    143
    Likes Received:
    14
    Trophy Points:
    68
    Well try also Display driver uninstaller to remove all ATI drivers (start windows in safe mode) and install latest 14.8 Catalyst.
    With 14.6 I got a few problems both with Sgminer than with other programs.
     
  19. Sub-Ether

    Sub-Ether Well-known Member

    Joined:
    Mar 31, 2014
    Messages:
    1,516
    Likes Received:
    1,254
    Trophy Points:
    183
    Download Display Driver Uninstaller DDU for removing drivers, think it does in safe mode for cleaner deletion.
    use 'afterburner' for GPU memory overclocking, under voltaging and monitoring.Those 7950's are quite quick.
     
  20. DRKDays4

    DRKDays4 New Member

    Joined:
    Sep 3, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Thanks all!