sending DASH with v0.12.2.1 failed & upgrade to v0.14.0.1 as well

Tim E<0

New Member
Jun 23, 2019
4
2
1
Hello,

I sent some DASH to an Exodus wallet of a friend from my Dash Core v0.12.2.1 wallet on 21st June.
Unfortunately the DASH didn't reach him until today (23rd June). I searched the forum and found the hint to upgrade to DASH v0.14.0.1. I installed it but it fails to start with hint in debug.log that evodb is corrupt and needs to reindex. I installed v0.12.2.1 again and reindexed (and tried all other wallet repair features) but my wallet is still empty showing the DASH went out but I can't upgrade to v0.14.0.1.
The transaction ID is 9b030fade8069265a125a1779d2dd3a184998044edb2e1e19c20b5b12d15647d-000 and is 950x approved so far. I guess my 2 issues are related (corrupt wallet and failed transaction but unfortunately I don't know how to solve them).

Thanks for any hint,
Tim
 

AlbNie

New Member
May 27, 2019
4
0
1
44
I am in the same situation... does anybody knows how to solve this problem? Thank you.
 

AgnewPickens

Moderator
Moderator
Mar 11, 2017
371
128
113
57
We are two forks past the 0.12 wallet series, go to dash.org and download v. 0.14.0.1 wallet, you will have to rebuild your index from wallet repair tools. If you need to access funds quickly, download Electrum wallet and import your keys. Do not reinstall 0.12.2.1 again, it is a dead fork. 0.14.0.1 from 0.12, I would sync from scratch. Or use Eletcrum if I needed quicker access. Make sure you backup your wallet.dat.
 

Tim E<0

New Member
Jun 23, 2019
4
2
1
Hi AgnewPickens,
thanks a lot for trying to help us. Unfortunately after installing 0.14.0.1 the wallet immediately after starting gives the message that "theres is a non-solvable internal error, details are in debug.log".
And this log says as 2 of the last 7 lines before it says "shutdown: done":
"2019-06-23 14:02:04 Verifying last 6 blocks at level 3
2019-06-23 14:02:04 [0%]...*** Found EvoDB inconsistency, you must reindex to continue"
So unfortunately I don't have the chance to reindex with 0.14.0.1 and that's why I tried several times to reindex with 0.12.2.1.
I tried with both versions 0.12 and 0.14 to open my current wallet.dat and my backup from ~1a ago but getting the same error. I tried reindexing with 0.12 for both wallet.dat as well, still the same issue: 0.14 can't load it.
Regards,
Tim
 

AgnewPickens

Moderator
Moderator
Mar 11, 2017
371
128
113
57
Hi AgnewPickens,
thanks a lot for trying to help us. Unfortunately after installing 0.14.0.1 the wallet immediately after starting gives the message that "theres is a non-solvable internal error, details are in debug.log".
And this log says as 2 of the last 7 lines before it says "shutdown: done":
"2019-06-23 14:02:04 Verifying last 6 blocks at level 3
2019-06-23 14:02:04 [0%]...*** Found EvoDB inconsistency, you must reindex to continue"
So unfortunately I don't have the chance to reindex with 0.14.0.1 and that's why I tried several times to reindex with 0.12.2.1.
I tried with both versions 0.12 and 0.14 to open my current wallet.dat and my backup from ~1a ago but getting the same error. I tried reindexing with 0.12 for both wallet.dat as well, still the same issue: 0.14 can't load it.
Regards,
Tim
OK, that is an uncommon error but happens, you need to go to your Dashcore folder on whatever OS you are using and delete that EvoDB file and let Dashcore generate a fresh one. Your best bet is to do a fresh sync from there, so go ahead and remove everything but the wallet.dat in the Dashcore folder and let v0.14.0.1 generate all new files, a fresh sync should be done in a few hours depending on your OS and computer. Make sure you backup your wallet.dat, that holds the info to access your Dash.
 

Tim E<0

New Member
Jun 23, 2019
4
2
1
I found a similar hint in this forum a week ago already and renamed the folders "database" and "evodb" and got the same error from Dash 0.14. But right now with your new hint I renamed the whole folder "DashCore" to something else, created a new one called "DashCore" and just copied the wallet.dat in.
... and indeed 0.14 starts for the very first time on my mashine w/o any error message and is synching now! This looks pretty promising! :)
I will let you know the result.
 

Tim E<0

New Member
Jun 23, 2019
4
2
1
SOLVED!!!
thank you for your great help, AgnewPickens! I can now access my wallet normally again with 0.14.0.1 like before. The above mentioned transaction is marked as failed but I could successfully start a new one.