Pool for Darkcoin with NOMP doesn't work

Saulo Fonseca

New Member
May 27, 2014
3
0
1
Hi you all,
I am building a pool with NOMP and everything is almost fine. There are already 6 coins installed in my server and everyone but Darkcoin works without problems. I thing there is something in my json file that isn't right for this coin:
Code:
{
    "enabled": true,
    "coin": "darkcoin.json",

    "address": "Xry3M2WxcbwA3L2azAyLSkrZWh7yEHQVme",

    "rewardRecipients": {
        "Xn1pADmwNJormJ6titimUuV6H3rCAo9tXM": 0.5,
        "Xqd95QSF188QoqWgNTTYiKXM3aWSHyC7LK": 0.5
    },

    "paymentProcessing": {
        "enabled": true,
        "paymentInterval": 20,
        "minimumPayment": 0.1,
        "daemon": {
            "host": "127.0.0.1",
            "port": 1234,
            "user": "darkcoin",
            "password": ...
        }
    },

    "ports": {
        "5032": {
            "diff": 0.00390625,
            "varDiff": {
                "minDiff": 0.00390625,
                "maxDiff": 0.0078125,
                "targetTime": 15,
                "retargetTime": 120,
                "variancePercent": 30
            }
        },
        "5056": {
            "diff": 256
        }
    },

    "daemons": [
        {
            "host": "127.0.0.1",
            "port": 1234,
            "user": "darkcoin",
            "password": ...
        }
    ],

    "p2p": {
        "enabled": false,
        "host": "127.0.0.1",
        "port": 1234,
        "disableTransactions": true
    },

    "mposMode": {
        "enabled": false,
        "host": "127.0.0.1",
        "port": 3306,
        "user": "me",
        "password": "mypass",
        "database": "ltc",
        "checkPassword": true,
        "autoCreateWorker": false
    }

}
And hier ist my config.json:
Code:
{
    "logLevel": "debug",
    "logColors": true,

    "cliPort": 17117,

    "clustering": {
        "enabled": true,
        "forks": "auto"
    },

    "defaultPoolConfigs": {
        "blockRefreshInterval": 1000,
        "jobRebroadcastTimeout": 55,
        "connectionTimeout": 600,
        "emitInvalidBlockHashes": false,
        "validateWorkerUsername": true,
        "tcpProxyProtocol": false,
        "banning": {
            "enabled": true,
            "time": 600,
            "invalidPercent": 50,
            "checkThreshold": 500,
            "purgeInterval": 300
        },
        "redis": {
            "host": "127.0.0.1",
            "port": 6379
        }
    },

    "website": {
        "enabled": true,
        "host": "0.0.0.0",
        "port": 80,
        "stratumHost": "cryppit.com",
        "stats": {
            "updateInterval": 60,
            "historicalRetention": 43200,
            "hashrateWindow": 300
        },
        "adminCenter": {
            "enabled": true,
            "password": ...
        }
    },

    "redis": {
        "host": "127.0.0.1",
        "port": 6379
    },

    "switching": {
        "switch1": {
            "enabled": true,
            "algorithm": "sha256",
            "ports": {
                "3333": {
                    "diff": 10,
                    "varDiff": {
                        "minDiff": 16,
                        "maxDiff": 512,
                        "targetTime": 15,
                        "retargetTime": 90,
                        "variancePercent": 30
                    }
                }
            }
        },
        "switch2": {
            "enabled": true,
            "algorithm": "scrypt",
            "ports": {
                "4444": {
                    "diff": 10,
                    "varDiff": {
                        "minDiff": 16,
                        "maxDiff": 512,
                        "targetTime": 15,
                        "retargetTime": 90,
                        "variancePercent": 30
                    }
                }
            }
        },
        "switch3": {
            "enabled": true,
            "algorithm": "x11",
            "ports": {
                "5555": {
                    "diff": 0.001
                }
            }
        }
    },

    "profitSwitch": {
        "enabled": false,
        "updateInterval": 600,
        "depth": 0.90,
        "usePoloniex": true,
        "useCryptsy": true,
        "useMintpal": true
    }
}
This is what I get if I try to mine Darkcoin on it:

But NOMP doesn't show that a miner is active for Darkcoin:

Can anyone please say why Darkcoin is not working?