Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

New to DarkCoin, "stratum connection interrupted"

Discussion in 'Questions and Help' started by Lacedaemon, Dec 12, 2014.

  1. Lacedaemon

    Lacedaemon New Member

    Joined:
    Dec 12, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I posted this to /r/DRKCoin, but was recommended to ask here as well:


    Recently stumbled on DarkCoin after reading on the profitability of GPU mining on DogeCoin, and thought I'd give it a try. I'm not looking to make a fortune, just a little something here and there to buy cheap things online. My specs are:
    • i5-3470
    • R9 270X 2GB
    So I signed up for SuchPool's DRK mining pool, and built sgminer 5.0.1 for OS X. After entering the required details such as pool URL, username, and password, the desktop becomes slow, which I assume indicates it is mining, but it repeatedly says "stratum connection interrupted" and no activity records on my dashboard on SuchPool. Here's my sgminer.conf:
    Code:
    {
      "pools": [
        {
          "url": "stratum+tcp://mining.darkcointalk.org:3333",
          "user": "Username.Pool",
          "pass": "pass",
          "intensity": "16"
        }
      ],
      "profiles": [],
      "failover-only": true,
      "algorithm": "darkcoin",
      "device": "all",
      "shares": "0",
      "kernel-path": "/usr/local/bin",
      "api-mcast-port": "4028",
      "api-port": "4028",
      "expiry": "28",
      "failover-switch-delay": "60",
      "gpu-dyninterval": "7",
      "gpu-platform": "-1",
      "gpu-threads": "2",
      "hamsi-expand-big": "4",
      "keccak-unroll": "0",
      "log": "5",
      "no-pool-disable": true,
      "no-client-reconnect": true,
      "queue": "1",
      "scan-time": "7",
      "tcp-keepalive": "30",
      "watchpool-refresh": "30"
    }
    
    I've also tried your DarkcoinTalk pool, which I've reflected in sgminer.conf, and it does the same thing.

    Any help would be appreciated. Thanks!