new masternode error -1 this is not a masternode

DarkWater

Well-known Member
Foundation Member
May 14, 2014
111
98
193
5280, Colorado
www.meetup.com
So I just launched my new masternode.

I do a remote start, successful

run "dash-cli masternode list full | grep" lists it as enabled

perform ./dash-cli masternode status = error: {"code":-1,"message":"This is not a masternode\n"}

I perform a grep HotCold as well. I got my masternode to show up on the network then it dropped out. masternode is set to 1 in the dash.conf file. anything else that I am missing?
 

DarkWater

Well-known Member
Foundation Member
May 14, 2014
111
98
193
5280, Colorado
www.meetup.com
So I just launched my new masternode.

I do a remote start, successful

run "dash-cli masternode list full | grep" lists it as enabled

perform ./dash-cli masternode status = error: {"code":-1,"message":"This is not a masternode\n"}

I perform a grep HotCold as well. I got my masternode to show up on the network then it dropped out. masternode is set to 1 in the dash.conf file. anything else that I am missing?
FIXED IT. Imported the old style Dash.conf format, worked right off the bat.
 

Drakenel

New Member
Nov 27, 2019
4
1
3
49
Hello, I need some help,
I am running a Master Node just now,
the wallet is showing me the node is running yay
but in the VPS when I try to get the confirmation with dash-cli masternode status
this error is comming out:

error code: -32603
error message:
This is not a masternode

Why?
could you please help me?
thank in advance
 

splawik21

Grizzled Member
Dash Core Team
Moderator
Foundation Member
Dash Support Group
Apr 8, 2014
1,923
1,284
1,283
Your dash.conf on vps has no line of:
masternode=1

edit: eventually send me via PM how your dash.conf looks like.
 
Last edited:

splawik21

Grizzled Member
Dash Core Team
Moderator
Foundation Member
Dash Support Group
Apr 8, 2014
1,923
1,284
1,283
Hello splawik21,

the file.conf have the line masternode=1
Can you please send dash.conf lines here on into PM?
Sent you a message already.
 

Drakenel

New Member
Nov 27, 2019
4
1
3
49
#----
rpcuser=XXXXXXXXXXXXX
rpcpassword=XXXXXXXXXXXXXXXXXXXXXXXXXXXX
rpcallowip=127.0.0.1
#----
listen=1
server=1
daemon=1
maxconnections=64
#----
#masternode=1
#masternodeblsprivkey=XXXXXXXXXXX
externalip=XXX.XXX.XXX.XXX
#----
 

splawik21

Grizzled Member
Dash Core Team
Moderator
Foundation Member
Dash Support Group
Apr 8, 2014
1,923
1,284
1,283
As I said you have no line ;)
You see this small sign in front of the line? #
It simply make the line not valid.
Stop your dashd, edit your config.
Remove it from masternode=1 and masternodeblsprivkey=yourprivateblskeyhere
and start dashd again.
Let us know if works.
 

splawik21

Grizzled Member
Dash Core Team
Moderator
Foundation Member
Dash Support Group
Apr 8, 2014
1,923
1,284
1,283
Happy to hear that.
Stay Dashy ✌