My question regarding QT has not been answered for more than a month!

zelenskyi83

New Member
Mar 6, 2020
6
2
1
66
Hello!

We have linux debian 32bit.

On it stands the old dash official qt v0.12.0.56-7154cdf

Which doesn't work at all. Block synchronization does not go stupidly. And constantly hanging "not synchronized."

Download and install the new dash official qt v0.14.0.5

Which I successfully use with one caveat.

Every time I run it, I have to spend ~ 12 hours on synchronizing blocks on a new one from scratch!

I describe the problem in order.

I launch, i.e. doing from the terminal ./dash-qt

The error "Error loading masternode cache from /home/user/.dashcore/mncache.dat" appears

I press OK and the application turns off. And stubbornly does not want to turn on.

As decided:

I launch the old dash-qt (though from the icon in KDE Launcher (such as Windows Start), which I once set up, having spent nerves a week).
The error "Error loading the block database. Rebuild the block database right now?"
Click OK, "download complete." Old Dash starts. Which, as he said, is non-working - nothing is synchronized in it.
Turn off the old dash. I launch a new one from the terminal.
The error "Error loading the block database. Crashes the block database right now?"
I press OK - Hooray, the new Dash has started ...

BUT: header synchronization, which lasts half a day, goes from zero, wildly loads the computer. This is the blue window in the middle with the Hide button. And looms everywhere in red "unsynchronized."

Which, in fact, must be eliminated!

What do I need to do to correct the "conflict of interest" and every time I launch a new version of QT, it immediately worked for me, and did not synchronize all the blocks for 10 hours from scratch?

For I, by God, stuttered.

I am an extremely noob Linux user. I suspect that you just need to remove the old Dash correctly and everything will be ok. Or do another simple procedure. But I can’t even do this yet (although I somehow set the dashi).

Therefore, a request on points - which teams to type. What and where to write, delete, copy, paste.

I will be very grateful to you! I can not wait to use without tambourines :(

ps If necessary - I, of course, will send screenshots of errors that I reprinted in text - but, I think, to developers and outside observers in the context of errors - so everything will become clear. Just to recreate these step-by-step processes, I need to synchronize all the blocks again, turn off and turn on the new QT again - and the errors will go that I described the action plan, which I now do every time when the synchronization ends and I accidentally end the application or the computer needs to be restarted :)
 

splawik21

Grizzled Member
Dash Core Team
Moderator
Foundation Member
Dash Support Group
Apr 8, 2014
1,927
1,287
1,283
Why don't you visit the official dash website and check what is the newest wallet version?
14.0.5 is not.
Download v15. Remove all data files except the wallet.dat and backups folder.
Start the wallet and sync. Problem solved.
 

zelenskyi83

New Member
Mar 6, 2020
6
2
1
66
Thanks.

Deleting all files, except for those voiced by you, did not help. The problem remained.

It helped to delete the entire .dashcore folder entirely (I had backups of the wallet, so I did it safely).

The original message featured an older version of Dash Core QT, as I wrote a question on a problem in the Russian-language forum thread on March 6, 2020, where no one answered me.

https://www.dash.org/forum/threads/dash-qt-linux-debian-x86-Ошибка-загрузки-кэша-мастернод-из.49758/

Having copied the question through google translate, I did not look at the fact that a new version appeared. After your posts, I downloaded the new version and installed - the problem remained. As indicated above, removing .dashcore completely helped. Initially, I did not think to do this. The problem is closed.

Thanks to all.

I apologize for my google translate english.
 
  • Like
Reactions: splawik21