Mining Newbie, Am I Doing This Correctly?

Anonymat

New Member
Jun 27, 2014
2
0
1
Hello all, I understand this has probably been asked before, for that I apologise. I'm usually very IT-literate but I have zero experience with mining. I had a look at pooling briefly but that went way over my head.

I found a guide at reviewoutlaw's website on how to mine. So, I've installed the miner it recommends (Simple CPU Miner). I've had it running on and off over the last few days (nothing sent to my wallet so far, but it does point out it can take time).
I understand that my laptop is nowhere near as powerful as would be ideal for this sort of thing, I'm doing it for fun really until I purchase something new for uni later this year.

I'm just curious about a few things:

a) Does this '(yay!!!) line mean it has accepted the preceeding hashes, does it mean that I wil lrecieve some fragments from that block, or the whole block, or nothing because the hashes are low? (They are usually anything up to 4000 hashes, at anything up to 8.5 khash/s, is this pitifully low?)

b) Does the 'stratum_upstream_work stratum_send_line failed...retry after 30 seconds' line mean it has given up on a block, if so for what reason, and does that mean I won't recieve any fragments for the work done prior to that failing?

c) Does the 'stratum connection interrupted' line and 'stratum_recv_line failed' line also mean that it has given up on the block it found?

I've tried finding a 'for dummies' guide to explain all this but found nothing that was all that helpful.
I figured a forum dedicated to this neat little coin would help me get some answers so I can actually understand what I'm reading on the miner log.

I've had about 5 yay!!!'s in the last few hours. But There has been large gaps where retry after 30 seconds is repeated over the course of half an hour or more. I'm concerned that all these failure-related lines are indicating that I'm missing something important that could be rendering this a total waste of time (beyond the fact that my cpu is only chipping away lightly in comparison to what would be a worthwhile process).

Thank you in advance to anyone who can help me out. If I can't get this working then I'll look into pools again, but for the life of me I couldn't get that working either. It's frustrating to admit because it doesn't happen much but I really do need a hand with this one :p
(Note - I did try to include a couple of screenshots but as I just discovered, I can't include them in my first post here).
 
Last edited by a moderator:

Anonymat

New Member
Jun 27, 2014
2
0
1
Just an update, I don't know what difference it makes; the accepted/yays I was getting the last two days were preceeded by '100%'. Today I got a LOT of boooo's, and the few yays I got were only between 6-10%.

Has my miner begun attempting to mine something which a pool is already targeting?

Does 100% mean you will get the proceeds from that whole block, or does it just mean 100% of the work my miner did will go towards the proceeds?
If so, are these smaller percentages indicating that my hashes are too small for them all to generate much from that block?

Apologies for all the questions, I'm trying to make sense of it through googling but at the moment I'm extremely busy and I've not found much that can answer these questions fully.
 

sirazimuthdark

New Member
Jun 29, 2014
2
0
1
in a nutshell i would say yes 8.4khash is pitifully low. probably not worth it unless you have free electricity.
for comparison i pull 5200khash/s using two GTX 750ti GPU cards. in 2 weeks ive generated 1.8 coins mining 24/7. my yays!! scroll at about 1 every 10 seconds for each miner running .
the percentage the miner reports is the percent of accepted shares (yay!!) of total shares submitted in the mining session. so the more "boos"(rejected share,stale) you get the lower the percentage.so if you start a new session it will be 100% on 1st yay! (0 percent if you start with a boo!). and stay 100% until a boo occurs. then the percent reported is as explained above and so on.
as far as connection problem , sorry cant help you there. you could start by trying a different pool to rule out possibility of problem on poolside
I tried that Simple cpu Miner myself and couldnt get it to work at all.
For cpu mining I use X11-cpuminer-1.2c-windows. 64bit .
hope that helps. good luck.