Masternode setup on testnet

Miner237

Well-known Member
Foundation Member
May 28, 2014
516
226
213
I am having trouble with initial setup, and doing this on test net to start. I followed wierdgod's guide on rc3 Masternode. When I launch darkcoind it says the darkcoin.conf file needs to have rpcpasssword. I am runnin Ubuntu 14. The file is there and using vi I can see rpcpasssword and rpcuser are both in the file. Has anyone come across this? This is the conf I used with the obvious changes made in production for rpc and mnprivkey. I tried the file in ./darkcoin and ./home/user/darkcoin/ did anything change with rc4 as far as this goes?

rpcuser=enter-new-LONG-RANDOM-STRING-fisjfijyou_should_change_this
rpcpassword=enter-new-LONGER-RANDOM-STRING-fissjfijyou_should_change_this
rpcallowip=127.0.0.1
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
masternode=1
masternodeprivkey=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
addnode=23.23.186.131



Thanks for any help or ideas
 

UdjinM6

Official Dash Dev
Core Developer
Dash Core Team
May 20, 2014
3,639
3,537
1,183
I am having trouble with initial setup, and doing this on test net to start. I followed wierdgod's guide on rc3 Masternode. When I launch darkcoind it says the darkcoin.conf file needs to have rpcpasssword. I am runnin Ubuntu 14. The file is there and using vi I can see rpcpasssword and rpcuser are both in the file. Has anyone come across this? This is the conf I used with the obvious changes made in production for rpc and mnprivkey. I tried the file in ./darkcoin and ./home/user/darkcoin/ did anything change with rc4 as far as this goes?

rpcuser=enter-new-LONG-RANDOM-STRING-fisjfijyou_should_change_this
rpcpassword=enter-new-LONGER-RANDOM-STRING-fissjfijyou_should_change_this
rpcallowip=127.0.0.1
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
masternode=1
masternodeprivkey=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
addnode=23.23.186.131



Thanks for any help or ideas
correct directory for config is ~/.darkcoin/ (or /home/user/.darkcoin/ ) - note the dot
 
  • Like
Reactions: vertoe

karisu

Member
Jun 30, 2014
70
26
58
or you could just use the datadir parameter so your call could look like
./darkcoind -datadir="<the full path to the folder where darkcoin.conf is located>
if you want to use the qt version ./darkcoin-qt -datadir works too.
 
  • Like
Reactions: vertoe

Miner237

Well-known Member
Foundation Member
May 28, 2014
516
226
213
correct directory for config is ~/.darkcoin/ (or /home/user/.darkcoin/ ) - note the dot
Yep totally missed the .darkcoin ok I'm pretty rusty in Linux was using ls, forgot about la

Now the .conf file is in there but when I run darkcoind start I get "couldn't connect to server" when I run just darkcoind I get "invalid masternodeprivkey. Please see doc"

I checked the privkey does match my local wallet. And local wallet is running and in sync...

I am starting over new privkey now need to wait for 6 confirms before trying again.
 
Last edited by a moderator:

UdjinM6

Official Dash Dev
Core Developer
Dash Core Team
May 20, 2014
3,639
3,537
1,183
Yep totally missed the .darkcoin ok I'm pretty rusty in Linux was using ls, forgot about la

Now the .conf file is in there but when I run darkcoind start I get "couldn't connect to server" when I run just darkcoind I get "invalid masternodeprivkey. Please see doc"

I checked the privkey does match my local wallet. And local wallet is running and in sync...

I am starting over new privkey now need to wait for 6 confirms before trying again.
you should run darkcoind with the key -testnet=1 when you start it and every time you run any command against it
 

Miner237

Well-known Member
Foundation Member
May 28, 2014
516
226
213
Ok tracking back I tried to do this again, on the local wallet after genkey and paying zero address do you need to run "Masternode start" on the local, this may be where my problem is now, when I do that I get port not open 19999
 

Miner237

Well-known Member
Foundation Member
May 28, 2014
516
226
213
Ok tracking back I tried to do this again, on the local wallet after genkey and paying zero address do you need to run "Masternode start" on the local, this may be where my problem is now, when I do that I get port not open 19999
Firewall was my problem on this after I purchased a new security gateway it works like a champ.