inbound port is not open. Please open it and try again.

jsp3cs15

New Member
Masternode Owner/Operator
Jun 21, 2014
37
14
8
Hi Guys,

I setup a Masternode using Tao's guide on version 10.15.16. No issues.

Since all the updates my MN has been offline since 14/11. Anyway I have been trying to bring it back online on version 10.16.15 following Tao's update guide but it I'm getting the error message when I try to start the node from my local wallet.

What I did also notice is that when i started the new dameon and do a masternode list my IP is not showing up either. The node is synced though so I'm not too sure why my IP wasn't showing.

So I scrapped the whole thing and rebuilt the server and I'm now using version 10.16.16. I also copied over the same .conf files with the same MN private key. When I start the dameon my IP is still not showing up on the masternode list.

Any ideas guys?
 

flare

Administrator
Dash Core Team
Moderator
May 18, 2014
2,286
2,404
1,183
Germany
Delete peers.dat on local and remote wallet, restart both and wait for wallets to have at least 4 connections to network before doing a "masternode start"
 

jsp3cs15

New Member
Masternode Owner/Operator
Jun 21, 2014
37
14
8
Hey Flare, I tried this last night and it's still not showing up the masternode list.

masternode start still returns the same error message
 

jsp3cs15

New Member
Masternode Owner/Operator
Jun 21, 2014
37
14
8
Sorry if this has already been answered.

If you destory/deleted the remote server and redeploy a new server with a different IP address do you need to re-genereate the masternode genkey?
 

thelonecrouton

Well-known Member
Foundation Member
Apr 15, 2014
1,135
813
283
Sorry if this has already been answered.

If you destory/deleted the remote server and redeploy a new server with a different IP address do you need to re-genereate the masternode genkey?
Yes. Use a new masternodeprivkey.

If you're seeing inbound port not open when you do a masternode start, either your server has that port shut or you've got errors in one or both of your conf files, double check them.

You can check your server ports with 'sudo nmap -sT your.ip.address.here' or something similar from your local machine.
 
  • Like
Reactions: jsp3cs15

jsp3cs15

New Member
Masternode Owner/Operator
Jun 21, 2014
37
14
8
well the port is server is definitely up =(

Host is up (0.000036s latency).
PORT STATE SERVICE
9999/tcp open abyss

This server was working previously and the only thing i have changed the the masternode genkey in the .conf files
 

jsp3cs15

New Member
Masternode Owner/Operator
Jun 21, 2014
37
14
8
Hi

Just an update on this.

As Yidakee pointed out. This was due to my firewall settings on my side.

I had to configure my portforwarding rules specifically to the pc where cold my wallet is located.

I thought this would be of help for people

Cheers.

For some odd reason I was able to get away with this on v10.15.16 but not with the later versions.