First Time Miner having trouble

Maverick

New Member
Jun 24, 2014
6
0
1
So I’m attempting to GPU mine Darkcoins and over the past week or so I’ve had no luck and would appreciate any and all help in finding what’s going wrong with my setup and configuration.

I able to CPU mining successfully so I believe my network is adequate for mining.

I am using a rig with two AMD R9 280X graphics cards and I’m getting ok hash times but I never get anything accepted. I only get messages as show below “requested work restart” for days on end.



What I've tried so far:
Used various P2P pools and login pools but both have the same outcome, nothing accepted.
I’ve used different versions of sgminer 4.1 using –k darkcoin and sph-sgminer –k x11mod still no love what so ever.


Thank in advance for your assistance in pointing me in the right direction!
 

DrkMiner

Member
Jun 7, 2014
204
63
88
Something might be wrong in your p2pool setup.
My sgminer 4.1.0 says to what pool I'm connected to.
Your says Pool 0, mine says the name of the Pool

sgminer.exe --kernel darkcoin -o stratum+tcp://d-r-k.org:7903 -u YOUR_WALLET_ADDRESS -p ANY_PASSWORD --expiry 1 --scan-time 1 --queue 0

OR for x11mod:

sgminer.exe --kernel x11mod -o stratum+tcp://d-r-k.org:7903 -u YOUR_WALLET_ADDRESS -p ANY_PASSWORD --expiry 1 --scan-time 1 --queue 0

Try to setup the share difficulty. Try to add +0.004234 to the end of your wallet address.
DRK Address+0.00000116 x Hash Rate in KHash

Try to set it very low just to see if your miner accepts any shares.
 
Last edited by a moderator:

Maverick

New Member
Jun 24, 2014
6
0
1
Thanks for your quick reply!

I tried out your suggestion and I found that if I use the sph sgminer with the x11mod the pool name does show up. I also added the +0.004234 at the end of my address.
Unfortunately, I'm still just getting the :requested work restart" from the Stratum.
I can try and lower the number more if you think that might be the issue?




Thanks again for any and all assistance toward making this work!
 

DrkMiner

Member
Jun 7, 2014
204
63
88
from the image i see that you mine with 107 kh/s and Intensity : 8

The first image showed 3.6 Mh/s .... with 107 kh/s you better mine with a regular pool.

Try this:
add "/0.00000116" after your DRK wallet. Note the "/" with that you should get the lowest shares possible.
 
Last edited by a moderator:

Maverick

New Member
Jun 24, 2014
6
0
1
I don't generally but I just copied and pasted your suggestions above without setting the intensity. I have tried it with intensity's set from 8 to 20 but still no shares.

Thanks
 

DrkMiner

Member
Jun 7, 2014
204
63
88
try: /0.00000116


Oops missed that... looking again at the 2 images. you have HW errors!
check your config file. might be wrong thread-concurrency.
Try to delete the thread-concurrency in config as a test.
 
Last edited by a moderator:

Maverick

New Member
Jun 24, 2014
6
0
1
Ok I've added the /0.00000116 and sadly I'm still getting the same results.
Just in case I've botched something, here is the bat file i'm running

And here is the output after a few minutes of running

Thanks again for your help!
I'm hoping I've just missed something obvious here
 

DrkMiner

Member
Jun 7, 2014
204
63
88
The bat file looks okay.
HW:160 you might have an error in the sgminer.conf.

Although it shows in the images you are connected to D-R-K.org p2pool, your DRK wallet doesn't show on stats.

Post your conf file.
 

Maverick

New Member
Jun 24, 2014
6
0
1
Thanks DrkMiner, I didn't realize that HW indicated an error. Duhhh on my part
I don't have a conf file, I'm just using the bat to start sgminer.exe
If you have one I can use please post it

Thanks again!
 

DrkMiner

Member
Jun 7, 2014
204
63
88
Funny :tongue:

Copy that to a text file and rename it sgminer.conf place it in the main dir on of the miner.

Code:
{
"pools" : [
     
         {
                "url" : "stratum+tcp://d-r-k.org:7903",
        "user" : " YOUR DRK ADDRESS",
        "pass" : "5"
        }
      

],
"api-listen" : true,
"intensity" : "14",
"vectors" : "1",
"worksize" : "256",
"kernel" : "x11mod",
"auto-fan" : true,
"temp-cutoff" : "95",
"temp-overheat" : "92",
"temp-target" : "85",
"expiry" : "1",
"gpu-dyninterval" : "7",
"log" : "5",
"queue" : "0",
"retry-pause" : "5",
"scan-time" : "1",
"temp-hysteresis" : "3",
"failover-only" : true,

"thread-concurrency" : "8000",
"gpu-thread" : "1",
"gpu-engine" : "0",

"lookup-gap" : "2",
"gpu-powertune" : "0",
"gpu-memclock" : "0"

}
Please edit:
intensity, thread-concurrency, kernel (x11mod or darkcoin)
 

Maverick

New Member
Jun 24, 2014
6
0
1
Thanks again for your help,

I've tried many different configurations and worked on two similar rigs but both kept giving me HW errors instead of accepted shares so......
After hitting a wall, I dumped windows and downloaded BAMT

In about 1 hour I'm up and running error free!
Happy Mining!