Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

Failed to install processor

Discussion in 'Development Tech Discussion' started by Izham Zubir, Nov 28, 2017.

  1. Izham Zubir

    Izham Zubir New Member

    Joined:
    Nov 28, 2017
    Messages:
    25
    Likes Received:
    3
    Trophy Points:
    3
    Hello, I am trying to install Dash Payment Processor into my server but having a problem which is failed to install bitcore-node-dash due to permission denied. I have tried to install using root, normal account with su, but still encounter permission denied.

    Image below shows the error.
    [​IMG]


    I've been posted this problem in Stack Overflow and yet no solution to be solved. Perhaps any developer in here can assist me in installing Dash Payment Processor.

    === SERVER DETAILS ===
    - Ubuntu 16.06
    - 8GB RAM
     
    #1 Izham Zubir, Nov 28, 2017
    Last edited: Nov 28, 2017
  2. UdjinM6

    UdjinM6 Official Dash Dev
    Dash Core Team Moderator

    Joined:
    May 20, 2014
    Messages:
    3,608
    Likes Received:
    3,516
    Trophy Points:
    1,183
  3. Izham Zubir

    Izham Zubir New Member

    Joined:
    Nov 28, 2017
    Messages:
    25
    Likes Received:
    3
    Trophy Points:
    3
    Thank you @UdjinM6.

    We've been struggling over 1 week for that permission issue. Furthermore, I am not familiar with Node.js since I am writing using PHP/Java only :(
     
  4. Adsncker

    Adsncker New Member

    Joined:
    Nov 13, 2017
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    1
    This is not an easy thing to do, :oops: , are you a professional?
     
  5. Izham Zubir

    Izham Zubir New Member

    Joined:
    Nov 28, 2017
    Messages:
    25
    Likes Received:
    3
    Trophy Points:
    3
    Bitter truth to be told, I am still newbie in Node.js environment.

    My effort on having my own Dash Processor, I already hired 2 developers in Fiverr (Freelance service marketplace), but both having the same issue (Permission denied).

    Perhaps they are not professional enough? Haha joke on me :p
     
  6. Izham Zubir

    Izham Zubir New Member

    Joined:
    Nov 28, 2017
    Messages:
    25
    Likes Received:
    3
    Trophy Points:
    3
    [​IMG]

    I've been following this guide to install bitcore-node-dash, everything seems good. But when I want to try install insight-ui-dash, bitcore-node-dash cannot install insight-ui-dash.

    I'm using Linux Ubuntu 17.10 x64.
     
  7. Izham Zubir

    Izham Zubir New Member

    Joined:
    Nov 28, 2017
    Messages:
    25
    Likes Received:
    3
    Trophy Points:
    3
  8. Dashmaximalist

    Dashmaximalist Active Member

    Joined:
    Mar 16, 2017
    Messages:
    1,008
    Likes Received:
    246
    Trophy Points:
    133
    Even this fix failed to work for me :(
     

Share This Page