DashPayments for WooCommerce Released

nmarley

Administrator
Core Developer
Dash Core Team
Moderator
Jun 28, 2014
369
427
133
I get an error when I try to activate the plugin.

Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or '(' in /home3/~~~~~~this part is private :) ~~~~~~~~~~~~~~~~/wp-content/plugins/dashpay-woocommerce/includes/class-dp-address-factory.php on line 9
Hmm... you shouldn't be getting syntax errors if the plugin uploaded correctly.

Does your server meet the minimum requirements for the plugin?
 

nmarley

Administrator
Core Developer
Dash Core Team
Moderator
Jun 28, 2014
369
427
133
I believe I have an outdate version of PHP, do I tell bluehost to update it for me?
Yes. I would ask them what version of PHP is running on your server. If it's a number lower than 5.5, you could ask them how you can upgrade to a newer version.
 

bluebit

Active Member
Jun 4, 2015
196
197
103
Yes. I would ask them what version of PHP is running on your server. If it's a number lower than 5.5, you could ask them how you can upgrade to a newer version.
Ok so they updated it to PHP 5.6 but I still get this error message: DashPayments for WooCommerce: Required extension(s) not loaded/enabled. Please enable 'gmp' PHP extension(s) on your WordPress server.

Bluehost told me that they enabled all the PHP extensions and that they don't see the gmp extension :( what do I do?
 

nmarley

Administrator
Core Developer
Dash Core Team
Moderator
Jun 28, 2014
369
427
133
Ok so they updated it to PHP 5.6 but I still get this error message: DashPayments for WooCommerce: Required extension(s) not loaded/enabled. Please enable 'gmp' PHP extension(s) on your WordPress server.

Bluehost told me that they enabled all the PHP extensions and that they don't see the gmp extension :( what do I do?
They didn't enable GMP right, I'm almost 100% sure. But let's check.

First, create a file called 'info.php' and put this in it:

<?php phpinfo(); ?>

That's the entire file. Now, upload it to your site.

Then go to your site's url + /info.php.

If GMP is enabled, it should look like this:

http://imgur.com/EH35Sb6


Let me know how it turns out!
 

TheDashGuy

Well-known Member
Dec 16, 2015
1,228
1,010
183
They didn't enable GMP right, I'm almost 100% sure. But let's check.

First, create a file called 'info.php' and put this in it:

<?php phpinfo(); ?>

That's the entire file. Now, upload it to your site.

Then go to your site's url + /info.php.

If GMP is enabled, it should look like this:

http://imgur.com/EH35Sb6


Let me know how it turns out!
You expect the support staff to actually know stuff?

LAWL
 
  • Like
Reactions: nmarley

CryptoIsKey

New Member
Jul 2, 2016
7
8
3
California
Dash Address
XuWHRFDnTTLKWnb1zUHdkpRkDtt4QaBtDh
PHP 5.5+?
its actully a managed wordpress on godaddy so the php version cant be changed manually if thats the case, but i would assume they have the latest or at least 5.5+ but ive hit the mod up to see if i can get an answer
 

nmarley

Administrator
Core Developer
Dash Core Team
Moderator
Jun 28, 2014
369
427
133
its actully a managed wordpress on godaddy so the php version cant be changed manually if thats the case, but i would assume they have the latest or at least 5.5+ but ive hit the mod up to see if i can get an answer
Yep, that's an incompatible PHP version. Your version is lower than 5.5. It actually doesn't surprise me with shared hosting/GoDaddy to have a lower version.
 

CryptoIsKey

New Member
Jul 2, 2016
7
8
3
California
Dash Address
XuWHRFDnTTLKWnb1zUHdkpRkDtt4QaBtDh
Yep, that's an incompatible PHP version. Your version is lower than 5.5. It actually doesn't surprise me with shared hosting/GoDaddy to have a lower version.
ikr thats exactly what i thought...theirs been more complaints about it, so hopefully they get there act together quick smart:).
 

CryptoIsKey

New Member
Jul 2, 2016
7
8
3
California
Dash Address
XuWHRFDnTTLKWnb1zUHdkpRkDtt4QaBtDh
actually scraped that i dont want to be bound by the share restrictions i will use the ec2 instead:)..thanks guys for the responces.
 
  • Like
Reactions: TaoOfSatoshi

nmarley

Administrator
Core Developer
Dash Core Team
Moderator
Jun 28, 2014
369
427
133
The most common issue with this plugin was the PHP v5.5+ version requirement... but the code only used the newer features in one place.

So I've removed that and uploaded a new version which works with lower versions of PHP (only tested with PHP 5.4). This should hopefully reduce the number of support requests regarding the "code error".

The latest version has been pushed to Github and resides at the usual spot, https://github.com/nmarley/dashpayments-for-woocommerce/releases/latest
 

CryptoIsKey

New Member
Jul 2, 2016
7
8
3
California
Dash Address
XuWHRFDnTTLKWnb1zUHdkpRkDtt4QaBtDh
any idea what this is or how i can fix it? error is : "Dash payment gateway NOT operational. Required extension(s) not loaded/enabled. Please enable 'gmp' PHP extension(s) on your WordPress server."
 

Balych

Active Member
Sep 12, 2015
365
211
113
Dash Address
Xba1ychX7CjgbRrCKE1LjHjT3jLUhcexs5

pooya

New Member
Sep 28, 2016
3
2
3
41
Sweden
lagaiphone.se
Hi,
After installing the plugin I get error below:

Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected '[' in /home/mydomain..../public/wp-content/plugins/dashpay-woocommerce/vendor/react/promise/src/functions.php on line 15​

any suggestion?
Regrads,
Pooya
Fil
 

nmarley

Administrator
Core Developer
Dash Core Team
Moderator
Jun 28, 2014
369
427
133
Hi,
After installing the plugin I get error below:

Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected '[' in /home/mydomain..../public/wp-content/plugins/dashpay-woocommerce/vendor/react/promise/src/functions.php on line 15​

any suggestion?
Regrads,
Pooya
Fil
That should not be happening. Do you know which PHP version you are running?
 
  • Like
Reactions: tungfa

Pondlife

New Member
Mar 21, 2017
6
2
3
45
I am having the same problem as everyone else when I installed the plugin via WP. I am running PHP 5.4 and I have several sites on this server.

"Warning: require_once(/home/mydomain..../public/wp-content/plugins/dashpayments-for-woocommerce-master/vendor/autoload.php): failed to open stream: No such file or directory in /home/mydomain..../public/wp-content/plugins/dashpayments-for-woocommerce-master/includes/class-dp-address-factory.php on line 7
 

chaeplin

Active Member
Core Developer
Mar 29, 2014
749
356
133
I am having the same problem as everyone else when I installed the plugin via WP. I am running PHP 5.4 and I have several sites on this server.

"Warning: require_once(/home/mydomain..../public/wp-content/plugins/dashpayments-for-woocommerce-master/vendor/autoload.php): failed to open stream: No such file or directory in /home/mydomain..../public/wp-content/plugins/dashpayments-for-woocommerce-master/includes/class-dp-address-factory.php on line 7
try https://github.com/nmarley/dashpayments-for-woocommerce/releases/latest to download.
 
  • Like
Reactions: maripao

Pondlife

New Member
Mar 21, 2017
6
2
3
45
But your log has "master" in path.

YES! Excellent, this version has worked, many many thanks. I do get the following error though which I will talk to the hosting company about
"DashPayments for WooCommerce: Required extension(s) not loaded/enabled. Please enable 'gmp' PHP extension(s) on your WordPress server."
 
  • Like
Reactions: chaeplin

Pondlife

New Member
Mar 21, 2017
6
2
3
45
Hmm, ok so host support said that GMP is already enabled on my server: http://www.mypandamedia.com/info.php

Any idea then why I might still get the error message: Dash payment gateway NOT operational. Required extension(s) not loaded/enabled. Please enable 'gmp' PHP extension(s) on your WordPress server.
 

Pondlife

New Member
Mar 21, 2017
6
2
3
45
Ok, so not so uselss Bluehost afterall, I spoke to another technician and they updated PHP for me and now gmp support is enabled and the plugin is working fine on my Wordpress site. thanks
 
  • Like
Reactions: UdjinM6