Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

"dash-qt: ./leveldb/db/skiplist.h:344"

Discussion in 'Daemon and QT Wallet Support' started by RichardAO, Feb 6, 2019.

  1. RichardAO

    RichardAO New Member

    Joined:
    Jan 17, 2017
    Messages:
    34
    Likes Received:
    8
    Trophy Points:
    8
    Dash Address:
    XmTSEYFTG5dF7N68mEZwtpVUQPAPQ
    Im getting this message when dash-qt fails to start on my linux 64 bit system running debian stretch:

    dash-qt: ./leveldb/db/skiplist.h:344: void leveldb::SkipList<Key, Comparator>::Insert(const Key&) [with Key = const char*; Comparator = leveldb::MemTable::KeyComparator]: Assertion `x == NULL || !Equal(key, x->key)' failed.
    Aborted

    Can anyone suggest a fix?
     
  2. Antti Kaikkonen

    Antti Kaikkonen Active Member

    Joined:
    Jun 20, 2017
    Messages:
    238
    Likes Received:
    157
    Trophy Points:
    103
    Dash Address:
    XnZdwT1w2kGeH6RujwoyJ7BBNrukdyTBRB
    Did it work previously? It looks like a database issue. Maybe your database got corrupted. Have you tried clearing the datadir? Make sure to make backups of your wallets first.
     

Share This Page