Dash Core worked for months, now crashes

Breadstick

New Member
Apr 9, 2018
6
6
3
I've been running Dash Core for 6 months or more on my Mac mini (OSX 10.13.4 High Sierra), no problems. A couple of weeks ago it started crashing within a minute of starting it up. There was no obvious change just before it started to fail. I have some Dash in the wallet, 5 maybe. I updated to 0.12.2.3 from 0.12.2.1 (I think) a few days ago, but it still crashes. It starts up, says loading block index, sometimes displays 8% or 12% or 16%, then after a minute just crashes.

Any suggestions?

The beginning of the error log (IDs deleted) is:
Process: Dash-Qt [91036]
Path: /Applications/Dash-Qt.app/Contents/MacOS/Dash-Qt
Identifier: org.dash.Dash-Qt
Version: 0.12.2 (0.12.2)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Dash-Qt [91036]
User ID: 501
Date/Time: 2018-04-09 15:51:43.937 +0100
OS Version: Mac OS X 10.13.4 (17E199)
Report Version: 12
Anonymous UUID: x
Sleep/Wake UUID: x
Time Awake Since Boot: 240000 seconds
Time Since Wake: 3200 seconds
System Integrity Protection: enabled
Crashed Thread: 12
Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_MEMORY_ERROR at 0x000000011ba6aa4a
Exception Note: EXC_CORPSE_NOTIFY
Termination Signal: Bus error: 10
Termination Reason: Namespace SIGNAL, Code 0xa
Terminating Process: exc handler [0]
...

Thanks for any help.
 

strophy

Administrator
Dash Core Team
Dash Support Group
Feb 13, 2016
768
451
133
Hi there, the first thing you should do is make sure you have a backup of your wallet.dat file, just in case. Then maybe try deleting all the .dat files EXCEPT wallet.dat in your application data folder? For macOS this should be ~/Library/Application Support/DashCore
 

Breadstick

New Member
Apr 9, 2018
6
6
3
Thanks for the suggestion. I made a copy of wallet.dat, then deleted all the .dat files except wallet.dat. I then opened DashCore and the same thing happened, namely it started to load the block index then crashed after a minute.

I rebooted, same result.
 

tungfa

Grizzled Member
Foundation Member
Masternode Owner/Operator
Apr 9, 2014
8,902
6,740
1,283
was there an update for High Sierra recently ?
 

strophy

Administrator
Dash Core Team
Dash Support Group
Feb 13, 2016
768
451
133
OK, thanks for trying that. Let's see if we can get a developer in here to look at the error log you posted... @thephez you got a minute?
 

UdjinM6

Official Dash Dev
Core Developer
Dash Core Team
May 20, 2014
3,639
3,537
1,183
Pls copy all the text it gives you inside the crash dialog box into a new file. Also find debug.log file in ~/Library/Application Support/DashCore. Put them in one folder, select both, right click, "Compress 2 items". This should create Archive.zip with these 2 files inside, pls send this zip file to me via email - [email protected]
 

Breadstick

New Member
Apr 9, 2018
6
6
3
was there an update for High Sierra recently ?
Yes, there was an update, which I installed a few days ago. But DashCore had already been crashing for a week or so before that. The update made no difference to the crashing.
 
  • Like
Reactions: tungfa

Breadstick

New Member
Apr 9, 2018
6
6
3
Pls copy all the text it gives you inside the crash dialog box into a new file. Also find debug.log file in ~/Library/Application Support/DashCore. Put them in one folder, select both, right click, "Compress 2 items". This should create Archive.zip with these 2 files inside, pls send this zip file to me via email - [email protected]
Files zipped and emailed just now. Thanks very much.
 
  • Like
Reactions: tungfa

UdjinM6

Official Dash Dev
Core Developer
Dash Core Team
May 20, 2014
3,639
3,537
1,183
Hmm... looks like your blockchain data files are corrupted. Pls remove blocks/ and chainstate/ folders in ~/Library/Application Support/DashCore and try syncing from scratch.
 
  • Like
Reactions: tungfa

Breadstick

New Member
Apr 9, 2018
6
6
3
Hmm... looks like your blockchain data files are corrupted. Pls remove blocks/ and chainstate/ folders in ~/Library/Application Support/DashCore and try syncing from scratch.
Aha! I deleted those folders, fired it up, and now it's syncing up. Looks like normal behaviour. Thank you. I'll post again, one way or the other.
 
  • Like
Reactions: UdjinM6 and tungfa

Breadstick

New Member
Apr 9, 2018
6
6
3
Looks good now. It crashed once after about 80,000 blocks, but afterwards sync'd up fine overnight. I removed almost all the Dash to another wallet, er, just in case. Thanks very much guys for the rapid help.
 
  • Like
Reactions: strophy and tungfa