Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

Dash core wallet GUI - no incoming connections

Discussion in 'Daemon and QT Wallet Guides' started by shadowseason, Jan 4, 2019.

  1. shadowseason

    shadowseason New Member

    Joined:
    Jan 4, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello Dash-community,

    i have been testing Dash core wallet GUI on Linux Mint 18.3 Cinnamon.

    The wallet connects to the P2P-network and the blockchain sync works without problems.
    I am using a VPN to access the network.

    The only problem is, that my wallet does not get any incoming connections.
    The number of outgoing connection rises quickly to 17-20 and then all connections seem to be closed and the process starts again and again. I suppose that there is a configuration problem with the network settings.

    I have already tried the following things:

    - VPN disabled
    - Creation of firewall rule for application dash-qt (TCPv4 and TCPv6 IN and OUT on port 9999)
    - Firewall disabled completely
    - Activated port forwarding on my router (TCPv4 and TCPv6 IN and OUT on port 9999)
    - Activated UPnP on wallet and router

    None of these things helped.
    Can you give me an advice what is going wrong?
    If you need further information or logs please ask.

    Thank you.

    Cheers, Michael
     
  2. shadowseason

    shadowseason New Member

    Joined:
    Jan 4, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Does nobody have any idea?
     
  3. AjM

    AjM Well-known Member
    Foundation Member Masternode Owner/Operator

    Joined:
    Jun 23, 2014
    Messages:
    1,310
    Likes Received:
    564
    Trophy Points:
    283
    Why do you worry about incoming connections, info window newer show incomings, but it still works ok.

    info2.png

    info.png
     
  4. shadowseason

    shadowseason New Member

    Joined:
    Jan 4, 2019
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hey AjM,

    thanks for the reply.
    I just worry about it, because i would like to support the network.
    Is it intended that the info windows nevers shows incoming connections or is it a software bug?
     
  5. AjM

    AjM Well-known Member
    Foundation Member Masternode Owner/Operator

    Joined:
    Jun 23, 2014
    Messages:
    1,310
    Likes Received:
    564
    Trophy Points:
    283
    No idea, maybe @UdjinM6 can tell us?
     
  6. UdjinM6

    UdjinM6 Official Dash Dev
    Dash Core Team Moderator

    Joined:
    May 20, 2014
    Messages:
    3,627
    Likes Received:
    3,537
    Trophy Points:
    1,183
    Make sure "Options -> Network -> Allow incoming connections" checkbox is on.

    Number of outgoing connections going above 8 and down again is ok - it's your wallet asking some masternodes to confirm the state of some another masternode, nothing to worry about.
     
    • Agree Agree x 1
  7. Antti Kaikkonen

    Antti Kaikkonen Active Member

    Joined:
    Jun 20, 2017
    Messages:
    226
    Likes Received:
    150
    Trophy Points:
    103
    A very high percentage of Dash nodes are accepting incoming connections because of the masternode network. As a result less nodes might be connecting to your node. You can try connecting to your node using this website: http://nodes.blakeanderson.ca/networks/dash
     
    • Informative Informative x 1

Share This Page