Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

Darksend shows the message "Masternode: Incompatible version"

Discussion in 'PrivateSend Questions and Help' started by krasi69, Apr 13, 2015.

  1. krasi69

    krasi69 New Member

    Joined:
    Mar 28, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    When I try to mix my dash coins with Darksend, I receive the message "Masternode: Incompatible version".
    Here you can see my log file:

    2015-04-13 23:33:12 Last Darksend message: Darksend request incomplete: Incompatible version.. Will retry...
    2015-04-13 23:33:12 dsee - Got bad masternode address signature
    2015-04-13 23:33:12 Misbehaving: 54.175.49.142:9999 (0 -> 100) BAN THRESHOLD EXCEEDED
    2015-04-13 23:33:22 Last Darksend message: Masternode: Incompatible version.

    I also attached a screenshot of my wallet. Can you please help me to fix this issue ?
     

    Attached Files:

  2. Sub-Ether

    Sub-Ether Well-known Member

    Joined:
    Mar 31, 2014
    Messages:
    1,527
    Likes Received:
    1,260
    Trophy Points:
    183
    What version of Dash are you on?
     
  3. UdjinM6

    UdjinM6 Official Dash Dev
    Core Developer Moderator

    Joined:
    May 20, 2014
    Messages:
    3,101
    Likes Received:
    3,141
    Trophy Points:
    1,183
    That's ok, wallet will skip that MN and will find the right one automatically.
     
  4. krasi69

    krasi69 New Member

    Joined:
    Mar 28, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello Sub-Ether,

    I use Dash Core Wallet v0.11.1.26-g7467e18-beta (32-bit) installed on Windows 7. I have this problem from one week and I cannot mix my Dash coins.
     
  5. Sub-Ether

    Sub-Ether Well-known Member

    Joined:
    Mar 31, 2014
    Messages:
    1,527
    Likes Received:
    1,260
    Trophy Points:
    183
    I bow down to UdjinM6's vastly superior knowledge as a key Dev, but it would be wise to upgrade to the latest Dash wallet (v.0.11.2.22) as you are still appear to be on the darkcoin wallet,once you have migrated you may find it works better, try that first to rule it out ..
     
    • Like Like x 1
  6. moli

    moli Grizzled Member

    Joined:
    Aug 5, 2014
    Messages:
    3,263
    Likes Received:
    1,838
    Trophy Points:
    1,183
    I think what that message meant is his DS transaction came across a MN that was on an older version, and it had nothing to do with his wallet version. I wish that the devs would make DS feedback messages clearer to users because I have seen many users get confused by those messages.
     
  7. UdjinM6

    UdjinM6 Official Dash Dev
    Core Developer Moderator

    Joined:
    May 20, 2014
    Messages:
    3,101
    Likes Received:
    3,141
    Trophy Points:
    1,183
    Ahh... I assumed that you are on the latest one, sorry. Most of MNs are on 0.11.2.22 (~96% according to https://dashninja.pl/masternodes.html#mnversions) and it's incompatible with 0.11.1.26 (in terms of mixing) so it's really hard for your wallet to find some old MN to mix now. Just update your wallet to 0.11.2.22 and you should be good.
     
  8. moli

    moli Grizzled Member

    Joined:
    Aug 5, 2014
    Messages:
    3,263
    Likes Received:
    1,838
    Trophy Points:
    1,183
    Oh... I guess I was wrong. That message has more to do with his wallet version? In the past I've seen similar messages that indicated the MNs were on outdated versions. Could you or Evan change it to something like... "Error: Your wallet is incompatible with Masternode. Please update." ?

    Thanks. :)
     
  9. Sub-Ether

    Sub-Ether Well-known Member

    Joined:
    Mar 31, 2014
    Messages:
    1,527
    Likes Received:
    1,260
    Trophy Points:
    183
    Thats what I was thinking, but didn't want to push the point, as I was at the limit of my understanding, lol.
     
  10. moli

    moli Grizzled Member

    Joined:
    Aug 5, 2014
    Messages:
    3,263
    Likes Received:
    1,838
    Trophy Points:
    1,183
    UdjinM6 eduffield - Here's another example of someone who thought the message "Masternode: incompatible version" was rather about online Masternodes not updated than his wallet version: https://dashtalk.org/threads/darksend-issue.3688/

    I know eduffield always tells us to update our wallet on his threads when there's a change in Darksend, but not everyone reads the official development threads religiously. For those of us who do, we always update our wallets accordingly, hence, we don't come across this problem. But for other users I think we need to change the DS messages to let them know they need to update, without having to go into 'getinfo' or post a thread here to find out.
     
  11. krasi69

    krasi69 New Member

    Joined:
    Mar 28, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello Moli,

    Thank you for your information. I used before Dark Coins Wallet. Then I installed Dash Coins Wallet as I tried to upgrade my old wallet to the new version.
    But after the installation I had two wallets - Dark Coins Wallet and Dash Coins Wallet. Then I tried to transfer the money from the old wallet to the new wallet.
    I sent the money from my old wallet to the new wallet and I uninstalled the old wallet. Also I waited half day for the new wallet to download the Dash block chain.

    Is there an easy way to update an old wallet to new wallet version ? It will be great if the new wallet is installed in the same directory as the old wallet
    and the coins and the block chain are transferred automatically.
     
  12. moli

    moli Grizzled Member

    Joined:
    Aug 5, 2014
    Messages:
    3,263
    Likes Received:
    1,838
    Trophy Points:
    1,183
    Hello krasi69,

    This rebranding is just a name change, so the wallet.dat in your Darkcoin folder is still the same. I guess everything went fine when you transfered the money from the old wallet to the new wallet? If you've done it successfully then don't worry about it. And I'm not sure why it took you half a day for the new wallet to download the block chain, because this new version 11.2.22 is pretty fast to sync. For future reference if you want it faster, you can use the bootstrap from this link:
    https://github.com/UdjinM6/dash-bootstrap
    Not sure which OS you use but in Windows the Dash data folder is in C:\Uses\username\AppData\Roaming\Dash, where your wallet.dat is stored. When you download a new version of dash-qt.exe and run this .exe, you'll open this wallet.dat. If you run your wallet.dat often, you don't have to wait long to sync. The wallet.dat only needs to be upgraded when it has a change on "walletversion" and "keypoolsize", that's when you have to run your client and let it install a new, empty, updated wallet.dat, then you transfer your money from the old wallet to the new wallet. Or you can do "-upgradewallet" command. To find your wallet.dat's info, go to console and type "getinfo", with this new version you should see something like this:

     

Share This Page