CPU mining with Ubuntu (linux) and darkcoin cpuminer 1.3-avx-aes

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,871
1,863
1,283
Open a terminal then cut and paste each line one at a time. I use this for my free Amazon EC2 account. I also have both my GPU and CPU mining together and it seems to work well for me :)

sudo apt-get update
sudo apt-get install -y build-essential m4 libssl-dev libdb++-dev libboost-all-dev libminiupnpc-dev git automake libcurl4-openssl-dev
git clone
cd darkcoin-cpuminer-1.3-avx-aes
chmod +x autogen.sh
./autogen.sh
./configure CFLAGS="-O3 -march=native"
sudo make


Now start it with:
sudo ./minerd -a X11 -o poolserver -u TanteStefana.Miner2 -p Pass -B
Just replace the blue with your pool and login info If you're using an Amazon ec2, and it got disconnected, when you reconnect, you just have to change directories to the mining directory with this:
cd darkcoin-cpuminer-1.3-avx-aes
then proceed to enter the start line above.
 
Last edited by a moderator:
  • Like
Reactions: S0AndS0

Lzeppelin

Member
Feb 27, 2014
283
57
88
Open a terminal then cut and paste each line one at a time. I use this for my free Amazon EC2 account. I also have both my GPU and CPU mining together and it seems to work well for me :)

sudo apt-get update
sudo apt-get install -y build-essential m4 libssl-dev libdb++-dev libboost-all-dev libminiupnpc-dev git automake libcurl4-openssl-dev
sudo git clone
https://github.com/elmad/darkcoin-cpuminer-1.3-avx-aes
cd darkcoin-cpuminer-1.3-avx-aes
sudo chmod +x autogen.sh
sudo ./autogen.sh
sudo ./configure CFLAGS="-O3 -march=native"
sudo make


Now start it with:
sudo ./minerd -a X11 -o stratum+tcp://drk.lotterymining.com:4444 -u TanteStefana.Miner2 -p Pass
Just replace the blue with your pool and login info If you're using an Amazon ec2, and it got disconnected, when you reconnect, you just have to change directories to the mining directory with this:

cd darkcoin-cpuminer-1.3-avx-aes
then proceed to enter the start line above.
BUT WHAT ABOUT -funroll-loops?!!!!!!!!
 

n00b_miner

New Member
Mar 14, 2014
17
2
3
You can actually do a live disconnect using a couple of programs: nohup and screen.

nohup:
Code:
$ nohup command --and --flags 1> logfilename.log 2> logfilename.err &
This will disconnect the command from the current tty and it'll output everything on stdout to logfilename.log, and all stderr to logfilename.err. The important bit to send it into the background is the & at the end.
screen:
Code:
$ screen -d -m -S GIVE_THIS_SESSION_A_NAME command --and --flags
This is now my preferred way of doing this. It basically allows you to emulate as many virtual terminals as you like through one SSH session. When you run this command it should drop straight back to the terminal. Use
Code:
screen -r
to retrieve a started screen session. I run all my miners like this, and put the screen command in a bash script, so I can easily link them in an OS startup script.

Hope that's of use to someone :)
 
Last edited by a moderator:

badseed

New Member
Jun 1, 2014
4
0
1
Tantestefana:
Installed fine, but when trying to run it says:
sudo: ./minerd: command not found
 

SuperTrooper

New Member
Jun 6, 2014
1
0
1
I have the same issue (Linux Mint Petra).
Below the verbose when I ran the sudo configure and the sudo make.
At the very end there are 2 errors while leaving the folder /home/SuperTrooper/darkcoin-cpuminer-1.3-avx-aes.
Code:
make[2]: *** [minerd-hash.o] Erreur 1
make[2]: quittant le répertoire « /home/SuperTrooper/darkcoin-cpuminer-1.3-avx-aes »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/SuperTrooper/darkcoin-cpuminer-1.3-avx-aes »
make: *** [all] Erreur 2
[email protected] ~/darkcoin-cpuminer-1.3-avx-aes $
 

Darkuopm

Member
Jun 18, 2014
50
17
48
I successfully got the miner working however when I close my ssh connection it stops mining. Do I have to keep my ssh connection active on my local pc? Thanks

*EDIT Weirdgod answered my question. I had to put -B in the start command to run in background in case any other linux noobs are reading this or having the same issue.
 
Last edited by a moderator:
  • Like
Reactions: MrMime

elmad

New Member
May 27, 2014
13
5
3
Open a terminal then cut and paste each line one at a time. I use this for my free Amazon EC2 account. I also have both my GPU and CPU mining together and it seems to work well for me :)

sudo apt-get update
sudo apt-get install -y build-essential m4 libssl-dev libdb++-dev libboost-all-dev libminiupnpc-dev git automake libcurl4-openssl-dev
git clone
cd darkcoin-cpuminer-1.3-avx-aes
chmod +x autogen.sh
./autogen.sh
./configure CFLAGS="-O3 -march=native"
sudo make


Now start it with:
sudo ./minerd -a X11 -o poolserver -u TanteStefana.Miner2 -p Pass
Just replace the blue with your pool and login info If you're using an Amazon ec2, and it got disconnected, when you reconnect, you just have to change directories to the mining directory with this:

cd darkcoin-cpuminer-1.3-avx-aes
then proceed to enter the start line above.
You dont need to use sudo. Just work on a folder in your home folder and dont need superuser permissions. I edited your guide in the quote :) .

P.S. I had to remove the link because I have no permissions to post.
 

TanteStefana

Grizzled Member
Foundation Member
Mar 9, 2014
2,871
1,863
1,283
Oh gosh, I'm sorry I haven't been around to check on this! Yah, I used screen to keep it live after I learned how, LOL. Didn't know about -B option for having it run in the background, that seems simplest. I added that, hopefully correctly. This is pretty old, not too many people will CPU mine anymore, but what the heck? eh?

Thank you elmad, I updated the instructions.

SuperTrooper, I'm sorry I can't read the errors, but I hope you figured it out and got it working!
 
  • Like
Reactions: elmad