Can't install bitcore-node-dash

S

Skrutch

Guest
Help please...
Debian
: 9.3.0

Code:
[email protected]:~# nvm run node --version
Running node v4.0.0 (npm v2.14.2)
v4.0.0
Code:
[email protected]:~# npm install -g bitcore-node-dash

> [email protected] preinstall /root/.nvm/versions/node/v9.3.0/lib/node_modules/bitcore-node-dash
> ./scripts/download

Downloading dash: https://bamboo.dash.org/browse/DASHL-REL-13/artifact/JOB1/gitian-linux-dash-dist/
./scripts/download: line 46: $tarball_name: ambiguous redirect
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] preinstall: `./scripts/download`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] preinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2018-01-08T00_56_14_307Z-debug.log

Also I see https://github.com/dashpay/bitcore-node-dash
Prerequisites
  • Dash Core (v0.12.1.x) with support for additional indexing (see above)
  • Node.js v0.10, v0.12, v4 or v5
  • ZeroMQ (libzmq3-dev for Ubuntu/Debian or zeromq on OSX)
  • ~20GB of disk storage
  • ~1GB of RAM
And
Please note that Dash Core v0.12.1.x will be downloaded automatically. Once completed the dashd binary should be placed into the <dash-data-dir> folder specified during node creation.

So I must install Dash Core, or not required? If yes, try to install him too, but...
Code:
[email protected]:~# npm install -g bitcore-dash
npm WARN engine [email protected]: wanted: {"node":">=4.5.0"} (current: {"node":"4.0.0","npm":"2.14.2"})
-
> [email protected] preinstall /root/.nvm/versions/node/v4.0.0/lib/node_modules/bitcore-dash/node_modules/bitcore-node-dash
> ./scripts/download

Downloading dash: https://bamboo.dash.org/browse/DASHL-REL-13/artifact/JOB1/gitian-linux-dash-dist/
npm ERR! Linux 4.9.0-4-686-pae
npm ERR! argv "/root/.nvm/versions/node/v4.0.0/bin/node" "/root/.nvm/versions/node/v4.0.0/bin/npm" "install" "-g" "bitcore-dash"
npm ERR! node v4.0.0
npm ERR! npm  v2.14.2
npm ERR! code ELIFECYCLE

npm ERR! [email protected] preinstall: `./scripts/download`
npm ERR! Exit status 7
npm ERR!
npm ERR! Failed at the [email protected] preinstall script './scripts/download'.
npm ERR! This is most likely a problem with the bitcore-node-dash package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     ./scripts/download
npm ERR! You can get their info via:
npm ERR!     npm owner ls bitcore-node-dash
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /root/npm-debug.log
[email protected]:~#
npm-debug.log - is havn't

Thanks.
 
Last edited by a moderator:

jack catesby

New Member
Jan 5, 2018
13
2
3
43
you can skip the download of dash core by adding the --ignore-scripts flag

did you manage to get this installed?