Welcome to the Dash Forum!

Please sign up to discuss the most innovative cryptocurrency!

Can't compile darkcoin-cpuminer-1.3-avx-aes from git on stock Ubuntu 14.04 64-bit

Discussion in 'Mining' started by Dark Leaf, May 16, 2014.

  1. Dark Leaf

    Dark Leaf New Member

    Joined:
    May 14, 2014
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I wanted to try out darkcoin-cpuminer-1.3-avx-aes and I fail to compile it on stock Ubuntu 14.04 64-bit server.

    Here's what I do:
    Code:
    sudo apt-get install automake build-essential git libcurl4-gnutls-dev -y
    git clone https://github.com/elmad/darkcoin-cpuminer-1.3-avx-aes.git
    cd darkcoin-cpuminer-1.3-avx-aes
    ./autogen.sh
    ./configure CFLAGS="-O3"
    make -j 8
    And I get the following errors.

    What can I do?
     
  2. Lzeppelin

    Lzeppelin Member

    Joined:
    Feb 27, 2014
    Messages:
    283
    Likes Received:
    57
    Trophy Points:
    88
    Can you try building it with no optimizations to see if that works?
     
  3. Dark Leaf

    Dark Leaf New Member

    Joined:
    May 14, 2014
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Nice idea! Tried, but the errors are all the same.
     
  4. Lzeppelin

    Lzeppelin Member

    Joined:
    Feb 27, 2014
    Messages:
    283
    Likes Received:
    57
    Trophy Points:
    88
    Hmmm, I don't really know then. Maybe the head is messed up, do they have any release tarballs you can download rather than cloning from git? Sorry I'm not more help, usually build errors are a lot more straight forward like missing dependencies or something.

    Edit: Don't know if you want it but here is a tarball https://github.com/elmad/darkcoin-cpuminer-1.3-avx-aes/archive/v1.0.tar.gz sorry again I can't be of more help.
     
    #4 Lzeppelin, May 16, 2014
    Last edited by a moderator: May 16, 2014