Can't change "Create Darksend Transaction"

italx

Well-known Member
Foundation Member
Jul 31, 2014
65
52
158
California
Hi,

I want to move some of the coins off my masternodes (leaving the original 1000) into my main wallet. I'm trying to do it today as I update them to 10.15.13 and restart from the cold wallets. No issues updating or getting the servers updated and restarted.

I'm using the new version 10.15.13 on a mac for my cold wallets. In each separate wallet in the send tab I cannot change the "Create Darksend Transaction" selection box at the bottom of the window. Clicking on it does nothing.

So of course, when I try to send any coins off I get the error "Unable to locate enough Darksend denominated funds for this transaction" and "Error: Transaction creation failed!"

Since these are masternode cold wallets darksend denomination is off.

So
How do I make this work?
Is this a bug in the mac wallet?
Am I supposed to have something set differently?

Last time I cleared the reward balances off was probably early September, so using RC4 I imagine. I was able to chose to not use Darksend and everything worked fine. Thanks in advance.
 

UdjinM6

Official Dash Dev
Core Developer
Dash Core Group
May 20, 2014
3,639
3,537
1,183
os x 10.9.5, v0.10.15.13-beta - no issues with selection box for me
 

italx

Well-known Member
Foundation Member
Jul 31, 2014
65
52
158
California
Interesting. Well at least that gives me the insight that maybe there is an issue with my machine specificaly. I'm running the same as you.
I'm seeing the same issue with multiple Data Dirs, so I doubt it's any of the files in the /Darkcoin folders. Are there any other files to potentially remove besides what's in ~/Library/Preferences?
 

UdjinM6

Official Dash Dev
Core Developer
Dash Core Group
May 20, 2014
3,639
3,537
1,183
could be the opposite btw - I was playing with different versions of Qt SDK so my machine is not that clean nor ideal for QA purposes ;)
 

italx

Well-known Member
Foundation Member
Jul 31, 2014
65
52
158
California
So in case it's of interest to anyone else, I figured it out.
I open the wallet. If I leave the window in it's original location and I click on the "Create Darksend Transaction" menu at the bottom, nothing happens.

(Image 1)


However, if I drag the window down to the bottom of the screen and try... The cursor jumps up and shows me the list and I can select from it.
(Image 2)


So a pretty odd quirk. I tried deleting everything and reinstalling, with no change.
I'm running OS X 10.9.5 with no other issues. I'm just glad I finally figured out a way to make it work (Being able to select "Create Normal Transaction")
 
  • Like
Reactions: moli

Ch0nG

Member
Oct 3, 2014
50
34
58
This same issue occurred for me with v0.10.17.24 on Windows. Unchecking "Darksend" let the transaction go through, but I'd like to see what it takes to get the resolved. Having to send non-anonymized funds defeats the purpose of DRK.