ALERTA SECURITATE! Bug major in openssl

chaeplin

Active Member
Core Developer
Mar 29, 2014
749
356
133
[PSA] ALERTA SECURITATE! Bug major in openssl
https://bitcointalk.org/index.php?topic=561162.0

http://heartbleed.com/
http://filippo.io/Heartbleed/



https://github.com/bitcoin/bitcoin/issues/4021

luke-jr commented 5 hours ago
This shouldn't affect Bitcoin Core at all. The only risk is on the server end of the payment protocol (which BCCore does not implement).

laanwj commented 42 minutes ago
The vulnerability does not affect the bitcoin protocol or wallet. It may affect auxilary usage of TLS in RPC-over-SSL and when fetching payment requests over HTTPS.

Not a big deal, but we are going to release a 0.9.1 that updates OpenSSL (see pull #4023 if you want to test) and fixes some other minor issues from 0.9.0.