2.6.4 windows not connected

jimbursch

Active Member
Mar 5, 2017
837
499
133
56
My Electrum-Dash 2.6.4 for windows is not connecting to the network.

Looking at the network tab, default settings:

Server: drk1.electrum-servers.us 50002

proxy: none localhost 9050
 

akhavr

Active Member
Oct 11, 2014
758
376
133
I'm now traveling (hotel wifi, yikes), but
Code:
drk1.electrum-servers.us
doesn't resolve for me.
 

jimbursch

Active Member
Mar 5, 2017
837
499
133
56
Possibly a windows firewall issue -- I was not prompted to make an exception for the electrum-dash wallet.
 

akhavr

Active Member
Oct 11, 2014
758
376
133
Try connecting to a different server. "Select server automatically" works usually fine.
 

Miner237

Well-known Member
Foundation Member
May 28, 2014
510
223
213
Yeah I just connected my Electrum to electrum.dash.siampm.com and it connected
 
  • Like
Reactions: akhavr

jimbursch

Active Member
Mar 5, 2017
837
499
133
56
This morning when I fired up electrum-dash, it connected.

Here are my network settings that is working:

Server: electrum.dash.siampm.com 5001
Uncheck Select server automatically
Uncheck Use SSL
Proxy: NONE localhost 9050

When I made any change to network setting, I had to restart the computer to connect.
 

akhavr

Active Member
Oct 11, 2014
758
376
133
Usually you don't have to restart your computer to connect electrum-dash to a different server
 

balouthebaer

New Member
Mar 30, 2017
1
0
1
51
I have also installed new dash version but it still doesn't connect even after restart, it is already resolved don't know why but all as a sudden it was working.:)
 
Last edited:

akhavr

Active Member
Oct 11, 2014
758
376
133
Electrum is an spv wallet, it relies on servers to do its work.

Use "select server automatically" option and it should solve your issue.
 

cherapple

New Member
Jul 24, 2015
16
21
3
Albany, NY
www.cheryllorraine.com
This morning when I fired up electrum-dash, it connected.

Here are my network settings that is working:

Server: electrum.dash.siampm.com 5001
Uncheck Select server automatically
Uncheck Use SSL
Proxy: NONE localhost 9050

When I made any change to network setting, I had to restart the computer to connect.
Thank you! This worked for me, too.