• Forum has been upgraded, all links, images, etc are as they were. Please see Official Announcements for more information

masternode help or trouble shooting guide

tjc_crypt

New member
I have a masternode up and running for a while now (16 months) but it is not paying out recently despite being listed at dashninja.pl ip 45.32.1.44. Last payout 5/24/2016. Dash version 12.8.56. This happened to this one masternode (no others) after I upgraded my masternodes ot 12.8.56. Others are paying as usual.

Is there a trouble shooting guide I can follow?
 
https://dashninja.pl/mndetails.html?mnpubkey=XcUyPk7643sdpUqoAWfeARHk3yUr5zbb3e
Active Duration 10 hours 15 minutes 52 seconds
It restarted ~10 hours ago and now back to the end of the queue.
How did you configure it? If you are using local dash.conf and not masternode.conf you must make sure you have masternode=0 there (or no masternode=1 line).
In such case I would (as always) suggest to move to masternode.conf setup - that's the better/easier way to manage MNs even if you have only one in that wallet.
 
First of all change masternode=1 to masternode=0 in local dash.conf (on your pc) before starting a wallet or MN will drop out of the queue again.
Next wait till it get payment (since you already waiting 3 days) and then follow a guide.

Using @TaoOfSatoshi guide https://www.dash.org/forum/threads/taos-masternode-setup-guide-for-dummies-updated.2680/ you can skip to the phrase:
"Back on your Windows PC, you need to tie it all together, and get on with your life of Masternode payments...."
To setup masternode.conf and restart your masternode.

Or pick any other guide you like from here https://www.dash.org/forum/threads/masternode-guides-all-formats-all-options-updated-june-2016.4164/ (setup section I guess)
 
hanging tight for now
Active Duration 4 days 20 hours 32 minutes 50 seconds

my other masternode doing fine active for over 3 months same settings...
 
First of all change masternode=1 to masternode=0 in local dash.conf (on your pc) before starting a wallet or MN will drop out of the queue again.
Next wait till it get payment (since you already waiting 3 days) and then follow a guide.

Using @TaoOfSatoshi guide https://www.dash.org/forum/threads/taos-masternode-setup-guide-for-dummies-updated.2680/ you can skip to the phrase:
"Back on your Windows PC, you need to tie it all together, and get on with your life of Masternode payments...."
To setup masternode.conf and restart your masternode.

Or pick any other guide you like from here https://www.dash.org/forum/threads/masternode-guides-all-formats-all-options-updated-june-2016.4164/ (setup section I guess)

Thank you for your help. I set up a masternode.conf file (I don't recall that being part of Tao's guide when I set these up in September 2015) and now this masternode stays online when the wallet is closed. I still do not know what my problem was but this fixed it.

9b333b9100187e7dbc2bda78b60936567163fcd6228bac1f193dcf13d643e3c3-000
 
Thank you for your help. I set up a masternode.conf file (I don't recall that being part of Tao's guide when I set these up in September 2015) and now this masternode stays online when the wallet is closed. I still do not know what my problem was but this fixed it.

9b333b9100187e7dbc2bda78b60936567163fcd6228bac1f193dcf13d643e3c3-000
Yes, I only recently updated it to include the masternode.conf. I was on the fence because the dash.conf was still working for a single setup, but it made sense to go with the masternode.conf as it made it easier for the owner to add masternodes over time.
 
Rats, back to square 1.
upload_2016-6-29_20-44-8.png

Wallet shut down, vps reports Enabled! but not seen on DASH Ninja.
 

Attachments

  • upload_2016-6-29_20-39-15.png
    upload_2016-6-29_20-39-15.png
    29.2 KB · Views: 107
Rats, back to square 1.
View attachment 2550
Wallet shut down, vps reports Enabled! but not seen on DASH Ninja.
That date in grep on your VPS - 2016-05-30.... that's not right, it's too old. It should be somewhere around 2016-06-29 01:22:45 instead.
Check your settings again: masternodeprivkey part (string from "masternode genkey") of the corresponding line in local masternode.conf should match masternodeprivkey value in remote dash.conf.
 
Hi, I am an absolute beginner with linux but I managed with Babygiraffe´s guide to setup a master node on my Mac. At least I hope I have my masternode active now.
And here my two questions:
1. In step 9
Step 9: Start your masternode(s)
Now launch the Dash Qt and reopen a console session. Enter the following to activate your remote masternode.
Code:
walletpassphrase <enter passphrase> 60
masternode start-alias <alias of the masternode you are starting>
You should get a message saying "started masternode successfully". To double check, go back to your remote server and enter the following.
Code:
./dash-cli masternode list full | grep <your MN IP address>​

I received the message
"started masternode successfully".
But I cannot manage the double check. If I do so, my remote server answers for the request: ./dash-cli masternode list full | grep <your MN IP address>:
"error: couldn´t connect to server". I waited untill the blockchain was fully downloaded. Do you have an idea, what is wrong?
2. How can monitor my masternode and see the current status and receive alerts in downtimes etc.? Do you recommend dashcentral?

Thx in advance,
 
hey
can you please link to the guide u used ?
(babyg never wrote a guide)
will make it easier for the tech guys helping
tx
 
Hey get on ninja.pl and place you IP of the remote server in the search. If your node is running than you will see a line with ip pub address and many other info.
 
Hey get on ninja.pl and place you IP of the remote server in the search. If your node is running than you will see a line with ip pub address and many other info.
Hi splawik21, thanks for your reply. I tried the dashninja.pl (ninja.pl was interesting as well;-)), but the IP of my remote server was not found. Any idea what went wrong, even if I received the message"started masternode successfully"?
 
Might you retry to start it? See if dashninja.pl see it after the second start? Strange....
 
Might you retry to start it? See if dashninja.pl see it after the second start? Strange....
did it.
Again: Start in console of Dash qt: "Masternode successful"
but double check in terminal:
./dash-cli masternode list full | grep <my MN IP address.> is the answer:
error: couldn't connect to server

any idea?
 
Have you checked if you have a dashd working on your remote server?
Sounds exactly like you start it from local it is confirmed and in reality your remote dash deamon does not work.
do the
Code:
ps aux
do you see ./dashd working as a process?
 
Back
Top