• Forum has been upgraded, all links, images, etc are as they were. Please see Official Announcements for more information

DashMasternodeTool Trezor libusd_error_io

Hi @Bertrand256 ,

First of all, I'd like to say thank you very much for creating this DMT, appreciate it.

Everything was working fine these few months.
Until today when I updated the DMT to the latest version and the firmware+bridge for Trezor.

After that, I'm unable to connect to my Trezor wallet via DMT.
It shows LIBUSB_ERROR_IO (error attached in the pic).

Here's what I experimented on:
- Signed in on wallet.trezor, I'm able to send out my dash.

- Signed in on wallet.trezor, then click the DMT wallet tab and clicked "Connect" the hardware wallet, it returns the error after 30 seconds or so. After that, if i try to send my DASH via wallet.trezor, it fails and shows the same LIBUSB_ERROR_IO message. It's like the DMT disconnects my trezor. DMT also doesnt show the balance.
I would need to reconnect my trezor n sign in again to be able to send out my coins via wallet.trezor. DMT still no avail.

- I used a different PC and I updated the DMT and firmware+bridge using the same steps. But I was able to see my balance this time and I assume I'd be able to send out my coins too. I tried reinstalling the trezor bridge on the problematic PC but still the same results. Is there a way to have a "clean reinstall" of DMT and wipe all potential files? Or any solution to my problem?

Would appreciate your help. Thank you very much.


  • trezord.PNG
    7.3 KB · Views: 157
Hi @Bertrand256 ,
After that, I'm unable to connect to my Trezor wallet via DMT.
It shows LIBUSB_ERROR_IO (error attached in the pic).

This issue is caused by Microsoft Windows update #1903, which significantly changed the behaviour of the library responsible for providing communication layer between Windows apps and specific type of USB devices. It has impact on other apps using Trezor and Keepkey devices:

According to some reports, you can work around the problem by starting the app in an administrator mode, but I haven't checked that yet.
The latest DMT version has the ability to change the behaviour of the Trezor library, so that you can possibly avoid the issue. For this you need to start DMT with `--trezor-webusb=0` command line option.

I'm also preparing another workaround, that won't require using additional startup parameters - it should be ready in a few days.