• Forum has been upgraded, all links, images, etc are as they were. Please see Official Announcements for more information

CCminer X11 mining on NVidia cards

Im having some trouble with ccminer. The program loads and is supposedly hashing but no shares are accepted/found and the pool doesn't detect the work even if it was working. Here is what is in my BAT file: "ccminer35.exe --algo=x11 -o stratum+tcp://mining.darkcointalk.org:3333 -u dchoquette.1 -p stuff"
I would really appreciate some help!
I gotta say this is really confusing. and I was excited to use my gpu again (evga gtx760)
 
Do you see hw errors dchoquette?
I have overclocked my 780 a little and it has zero error with ccminer 1.0beta (not yet tryed the new version, saw some comments that it doesnt work that good)
 
Has anyone tried this? I started out with darkcoin the other night running two systems whit the cpuminer just to see how everything worked. Had zero issues so I'm moving over to one of my GPU setups. It seems gpu support for darkcoin is sketchy at best. I've tried sgminer (4.10) both regular and x11 versions with no luck as they just keep crashing.

I found in a different forum a suggestion to use ccminer (1.0) which is supposed to specifically support nvidia gpus. I'm using drkpool.com and in the cpuminer I get a message indicating when I've completed a hash (yay!!!) but with CC I don't see any indication when I've completed a hash nor does the drkpool website seem to register any progress either on a kh/sec or valid hash count. the start-up for seems easy "ccminer35.exe --algo=x11 -o stratum+tcp://drkpool.com:3333" plus -u/-p tags.

drkpool doesn't even seem to realize that ccminer is logged in although it doesn't seem to have any issues with logging on.

Any thoughts? I'd really like to get beyond 200ish kh/sec numbers.

Thank you for reading.
 
Maybe try KBomba's build? It uses the most recent copy of the official ccMiner source (faster the the current official) and also includes an optional downgraded ccminer21 for older nvidia cards.
https://github.com/KBomba/ccminer-KBomba/releases/
Thanks for the suggestion, but I get the same failure during the build. The make output shows it is using options compute_30 and compute_35, but no sign of anything like compute_21. Do I need to add some option to the "configure" command?
 
I appreciate the suggestion. Why is that pool better than the one I'm using?

I double checked and that is the same version of ccminer I've been trying to use.
 
Last edited by a moderator:
Double check your ccminer version inside of 1.0, there are ccminer30, ccminer35, and ccminer50 depending on your card computing.. I use 2 GTX 760's and have to use ccminer30, I was getting the same thing you were getting before I switched.. I think the default is ccminer35, check your string.. Here's mine for my 2 cards:
ccminer30.exe -t 2 -a x11 -o stratum+tcp://mining.darkcointalk.org:3333 -u -p
 
You want to change yours to ccminer30, I am running 2 GTX 760's and with a little tweaking I am getting @ 2.05mhash/s out of each.. Here is my string:
ccminer30.exe -t 2 -a x11 -o stratum+tcp://mining.darkcointalk.org:3333 -u -p
MSI Afterburner settings: Power Limit : 84% ( I keep getting VRel cap limit @ 75%, think I need a bigger power supply), Core Clock: +192, Memory Clock: +192, Fan Speed: +84, My temps are at 73c and 67c ( I am running one EVGA and one Galaxy), the Galaxy has half the cooling vents as the EVGA hence the higher temp..
 
Not 100% sure of the explanation, but it has to do with the computing power of the card itself.. sort of like when dealing with cudaminer.. some cards use K6x24 etc.. and some use T6x24 etc.. It has to do with how the card is rated or something like that.. just change the beginning of your string and try it, if you get the same error, change it to the other one.. I promise once you get the right one.. you will know!!
 
I'm not erroring out, I'm just not finding any blocks or hashes because it doesn't seem to actually connect my userid to the pool server. So with CPUminer I can see my two workers are connected to drkpool. I can see from drkpool and cpuminer when they find valid shares. It was the same when I mined bitcoins. When I run ccminer## (any of the number'd ones) they work and process hashes as you can see from the included screenshots but drkpool (and darkcointalk) do not acknowledge the worker's ID and the program gives no indication of finding hashes.
 

Attachments

  • Screenshot 2014-05-30 16.19.38.png
    Screenshot 2014-05-30 16.19.38.png
    43.7 KB · Views: 175
  • Screenshot 2014-05-30 16.20.08.png
    Screenshot 2014-05-30 16.20.08.png
    45 KB · Views: 162
First, what Nvidia card do you have? The ccminer(30,35,50) refers to the version of CUDA. Such as, my GTS 450 only supports up to 2.1 while Syntor's GTX 760's support CUDA 3.0 (And oddly enough, the GTX 750's support CUDA 5.0....how does that work?)

Second: https://developer.nvidia.com/cuda-gpus
The link above is a reference list of what version of CUDA each of their cards is compatible with.

If for some reason, your card is only compatible with CUDA 2.1, go here: https://github.com/KBomba/ccminer-KBomba/releases/

It has the older CCminer21 that I don't believe is really supported anymore. Good luck, I hope this helps!
 
Thanks for the suggestion, but I get the same failure during the build. The make output shows it is using options compute_30 and compute_35, but no sign of anything like compute_21. Do I need to add some option to the "configure" command?

I only grabbed the windows binaryto get an old NV5400 working on a windows laptop so I'm afraid I didn't do a compile.

Seems like the error you are seeing has also been logged as an issue for the main ccminer trunk - https://github.com/cbuchner1/ccminer/issues/10

Also noticed that the install file mentions using the CUDA 5.5 toolkit whereas it looks like you are using v5.0.35 - so it might be worth trying a newer version of the toolkit.
 
Ouch, I'm sorry. If you have a little extra money, you can check ebay or amazon for something slightly higher on the list. My GTS 450 runs at about 500 kh/s on http://mining.darkcointalk.org/

I'm looking at ebay right now(just search nvidia), and there are some usable ones on there for not too horrible a price. 60-150 each. I reccomend trying to find something that runs CUDA 5.0. From what I'm seeing, a GTX 750 is running about 100, while the 750Ti is about 150. I know how hard disposable income is these days, but if you can scrape it together, the CUDA 5.0 card should be able to perform pretty nice compared to a CUDA 3.0 or 3.5 card.

I hope this helps.
 
I'm sorry for not asking earlier what card you were actually using.. That would have solved everything right away!! LOL, I have no idea why I assumed you were working with a newer card in the 3.0-5.0 range.. See what I get for assuming!!
 
I'm torn... I have a couple options if I want to play with this. With Bitcoin my video cards worked perfectly but their support system is a bit more expansive than DC right now.

I have pci express 1.0 slots in the two computers I'm using. I've been tossing around the idea of buying a used 3x video card motherboard and playing some newer 3.0 pci express cards.

Or I could try to find a decent bang for my buck pci 1.0 card.

Has anyone been keeping track of the avg hash rates for different cards with darkcoin?

PS. I just switched over to the Darkcointalk pool. You guys have been super nice/helpful here.
 
Uleepera,
If you've got the spare funds, might be worth it to upgrade to the newer cards. Especially with the difficulty jumping like it has. I'm not making much of anything anymore mining, and I'm so close to my first .1 DRK. Makes me wish I had the spare funds for new cards.
 
Hello,
So I'm new at this (of course), and I did some CPU mining and thought I should move onto GPU. So I've downloaded ccminer...but what I don't know what to do is how to set up the strings.

For CPU mining, I used a GUI from reviewoutlaw...so there was a GUI where I can input the string. Since ccminer is terminal only, I am baffled as to where I can edit the pool. Does compiling have to do with this? I've tried opening the CUDA3.5 but a terminal window opens and immediately disappears...

Any help and tips would be really appreciated. =)
 
I was wondering...when I try to run the BAT file for either kbomba's or christian's ccminer, the terminal window appears and then immediately disappears. Does anyone know why this might be? For the CPU miner, it works fine...
 
Back
Top