• Forum has been upgraded, all links, images, etc are as they were. Please see Official Announcements for more information

"Cannot read file"


New member
I may be in trouble.

I have an old wallet from DarkCoin days dated 27 May, 2014. I tried to access it using DashCore but it showed $0. So I installed Electrum, and where it asks which wallet I point it at the DarkCoin one. But instantly it says, "Cannot read file".

Is there some conversion process or some way I can recover this wallet?
Hi there. I don't think Electrum existed for Dash back then, so you are more likely to have success using Dash Core to recover the wallet. Can you describe the steps you took for recovery in Dash Core?

Documentation here, if you need it: https://dashpay.atlassian.net/wiki/x/WTm6Bg
Ok DashCore it is.

I have two wallet.dat, one in ~/.altcoin of 64kB, and one in ~/darkcoin of 72kB. It could be either one of them.

I started dashcore and let it load up the blockchain. Then I stopped it and substituted its wallet.dat with each of the above. In both cases 0 coins were found.

I set aside ~/.dashcore and copied ~/.darkcoin to ~/.dashcore, and started DashCore and let it catch up with the blockchain. 0 coins.

The only hint at what might be going on is when I pointed Electrum at the ~/.darkcoin/wallet.dat -- it said "Cannot read file". This must be what DashCore is finding too. I may have encrypted the wallet, although neither application ever asks for a password. I then tried Electrum on a Windows 10 virtual machine -- "Cannot read file."

I tried running my -old- DarkCoin wallet software, which I still have from 2014, but I can not satisfy the library dependencies since they're so old. (CentOS7) So I installed Fedora 21 in a virtual machine -- same thing. I installed Fedora 19, same thing. Now I'm trying to get Fedora 17 installed but it's putting up a fight. I don't know what else to do.
From what I have seen, Electrum wallets do not use a .dat extension by default. The likely reason for the "Cannot read file" error is that the wallet was not created by Electrum and therefore not compatible with it.

Does Dash Core show any transaction history when you put your darkcoin wallet.dat file into the dashcore folder? Also, do you know if you did any transactions with the old wallet?

The current version of Dash Core is compatible with old Darkcoin wallets, so there should be no need to try running the old software. Also, I think Dash Core would report an error if it was unable to read the wallet.dat file.

I started dashcore and let it load up the blockchain. Then I stopped it and substituted its wallet.dat with each of the above. In both cases 0 coins were found.

I set aside ~/.dashcore and copied ~/.darkcoin to ~/.dashcore, and started DashCore and let it catch up with the blockchain. 0 coins.

@strophy Would it be necessary to do a rescan (Tools->Wallet Repair->Rescan blockchain files) if wallet.dat was swapped out after the blockchain was synced?
There is no transaction history at all. But I don't think I made any transactions.

Well this is bad news:
2018-03-13 21:09:36 Creating backup of /home/bill/.dashcore/wallet.dat -> /home/bill/.dashcore/backups/wallet.dat.2018-03-13-21-09
2018-03-13 21:09:36 Using wallet wallet.dat
2018-03-13 21:09:36 init message: Verifying wallet...
2018-03-13 21:09:36 CDBEnv::Open: LogDir=/home/bill/.dashcore/database ErrorFile=/home/bill/.dashcore/db.log
2018-03-13 21:09:36 scheduler thread start
2018-03-13 21:09:36 Bound to [::]:9999
2018-03-13 21:09:36 Bound to
2018-03-13 21:09:36 Cache configuration:
2018-03-13 21:09:36 * Using 37.5MiB for block index database
2018-03-13 21:09:36 * Using 8.0MiB for chain state database
2018-03-13 21:09:36 * Using 254.5MiB for in-memory UTXO set (plus up to 286.1MiB of unused mempool space)
2018-03-13 21:09:36 init message: Loading block index...
2018-03-13 21:09:36 Opening LevelDB in /home/bill/.dashcore/blocks/index
2018-03-13 21:09:36 Opened LevelDB successfully</code>
It appears to be reading the wallet successfully.  So what happened to all my coins?
If the wallet ever contained a balance, there would be receive transactions. If you haven't already, try the Wallet Repair Rescan command I mentioned in the last message. The worst case is that it won't make any difference.
I've Repair Rescanned with both wallets and still 0, and nothing in Transactions unfortunately.

My god, maybe I've lost my $40k.

I don't understand why it never asks for my password for the wallet?
Last edited:
The wallet only requires a password to create transactions that result in a change to your balance. Even if the wallet is secured by a password, it can be opened and the balance and transaction history viewed without entering that password. You can see if the wallet is locked by the lock icon in the lower right corner, and try to unlock it using Settings > Unlock wallet. This way you can at least see if this is the wallet you think it is by checking if the password matches.

If you still think it is the right wallet, you could check if it contains the keys to the addresses you think have a balance. Use a block explorer to check the address and verify it has a balance, then use the validateaddress function in Tools > Debug console to check that the address belongs to your wallet.

In the end, if you still don't see any balance, it looks like you might still have the wrong file. Are you sure this is the only possible wallet file? And it is definitely a Darkcoin wallet, not Bitcoin or Litecoin, which used effectively identical wallet architecture back in 2014? Are you doing this with the GUI wallet on Linux? Have you tried another platform?
Hi, thanks for your help strophy. I don't have a lock in the lower-right of DashCore.

By "use a block explorer" I guess you mean to download an application and examine my wallet file?

I've installed Abe block explorer but it doesn't work in Linux. Opening the wallet in a text editor just gives nonsense of course. Any recommendation for a free block explorer?
Last edited:
Sure, try insight.dash.org or explorer.dash.org

If you thought you protected you protected your wallet with a password and this wallet is not protected then you almost certainly have the wrong wallet.dat file.
I don't understand. insight.dash.org and explorer.dash.org are just blockchain examiners. How would I find my blocks without being able to examine my wallet? Seems like I'd need to open up my wallet somehow to see its contents? If I'd exported my wallet to a paper number I could see how a blockchain examiner would help, but in this case I'm lost.

Dashcore seems to be opening my wallet without error but it finds no coins. I do have another wallet, but same thing. I was pretty sure that I'd stored the coins in DarkCoin in 2014, and that I wouldn't trust to leave them in any exchange.
This command will list all addresses in the wallet even if they have never been used -
listreceivedbyaddress 0 false true
I *think* this is the same list you would see if you went to File->Receiving Addresses.

If an address has been used, it will also list the transaction IDs for associated transactions. However, at this point, I think @strophy is correct regarding whether this is the right wallet.dat file. It sounds like the ones you are looking at have never been used.
Ok I understand what you're saying thephez (but not what strophy says).

Here's what I get using your command in Debug mode:
09:01:35  listreceivedbyaddress 0 false true
09:01:35  [
    "address": "XwFjKVNkNBW4iZ?????PcwUvHviqhoXPff",
    "account": "",
    "amount": 0.00000000,
    "confirmations": 0,
    "label": "",
    "txids": [
.altcoin/wallet.dat - 64kB
09:12:11  listreceivedbyaddress 0 false true
09:12:11  [
.bitcoin/wallet.dat - 76kB
09:21:48  listreceivedbyaddress 0 false true
09:21:48  [
.litecoin/wallet.dat (5 transactions, including 3 received) - 14.2MB
09:33:13  listreceivedbyaddress 0 false true
09:33:13  [
.litecoin/wallet.dat-2 48kB
09:45:58  listreceivedbyaddress 0 false true
09:45:58  [
.altcoin/backup.dat (renamed to wallet.dat)(4 transactions, including 3 received) - 9.1MB
09:57:26  listreceivedbyaddress 0 false true
09:57:26  [

No other wallet candidates.
Last edited:
Sorry if I wasn't clear - I thought you knew which addresses were supposed to be holding funds. If you only have the wallet file, then the command from thephez will list the addresses holding funds, which you can then verify on the block explorers I posted.

Your problem here doesn't seem to be the software, the problem is that your wallet files are either not Dash wallets, or they are Dash wallets but hold no balance or transaction history. Even if the wallet previously held a balance but it was since spent, you would still be able to see the transactions on the Transactions tab. If this is empty, then you have an empty and unused wallet.
On the first instance I seem to have Received, but it says 0 coins. This doesn't make sense. Do any other wallets look like they may have my coins?
What shows "Received"? Can you send a screenshot?
I am having a similar issue with my DarkCoin wallet. I got it back in 2015, and I have never had a similar problem, actually. Had the same issue, tried to access it using DashCore, but it showed $0, just like you. Trying to use Electrum, the situation didn't really change. It told me the file could not be read! What the actual fck happens? How do I fix it, guys? I need it as soon as possible. When I tried to export the account statement to a portal for secure file sharing, there were 0$. How is that possible?
Last edited:
I am having a similar issue with my DarkCoin wallet. I got it back in 2015, and I have never had a similar issue, actually.

I have some tips with regards to the Dashcore wallet, i will let others comment on the Dash Electrum issue ''cannot read file''.

First make sure that there is actually a balance on the Dash blockchain receiving address, please check your Dash receiving address(es) here : https://chainz.cryptoid.info/dash/

If there is indeed a balance on your Dash address and the Dashcore wallet is not showing that, i would advice the following :

- make a backup of your wallet
- delete peers.dat file
- download latest Dashcore wallet version from here : https://www.dash.org/downloads/
- initiate a reindex on your blockchain, this can be done from within your Dashcore wallet (Tools - Wallet Repair - Rebuild Index) or through the commandline as a -reindex option behind dash-qt.exe in the target of your desktop shortcut.

If that does not help, you have two other options :

Option 1

- make a backup of your wallet
- download latest Dashcore wallet version from here : https://www.dash.org/downloads/
- delete everything except your wallet.dat file and let the Dashcore wallet download and sync the whole Dash blockchain from scratch

Option 2

- make a backup of your wallet
- delete peers.dat file
- download latest Dashcore wallet version from here : https://www.dash.org/downloads/
- download and install the Dash bootstrap from our Dash lead developer here : https://github.com/UdjinM6/dash-bootstrap
and let the Dashcore wallet sync that Dash blockchain from start.
Last edited: