• Forum has been upgraded, all links, images, etc are as they were. Please see Official Announcements for more information

Amount exceeds balance msg when sufficient DASH is present

Rick Seeger

New member
Hello,

I've imported a private key via the debug console to access 1000 DASH (previously used for staking a Masternode, but the MN is now shutdown and subsequently banned by the network).

I'm unable to spend the DASH because QT is reporting an insufficient balance. See attached screenshot. Any ideas?

Cheers,
Rick
 

Attachments

  • dash-qt-fail.png
    dash-qt-fail.png
    71 KB · Views: 171
You need to have fully synced the blockchain to see and access your wallet balance. What OS are you using?
 
Blockchain is fully synced (you can see the balance is being reported as 1000 in the screenshot). OS is Ubuntu 16.04.
 
Weird, try rescanning the blockchain, or rebuilding the index? Maybe there is something wrong with the blockchain data you synced.
 
Use coin control when sending and see if your input is not locked.
 
I'm using 0.14.0.2. But, It's moot now as I used another wallet to do the tx. I agree with the comments though. The only possibilities I can think of are 1) the full re-scan failed somehow when the key was imported as @AgnewPickens alluded to, or the UTXO for the masternode collateral was somehow locked @splawik21 said. But, this doesn't seem likely as my local dash.conf file was empty (had no knowledge of my masternodes).

I did notice that even though I has shut down my masternode server hours before, I had not yet been PoSe banned. So the network still assumed it was active. I still don't see how this would have prevented the spend, as I've done this type of thing many times before so I'm going with option 1. Is there any way to explicitly check the integrity of the chain sync when things seem ok on the surface?
 
Masternode UTXOs are automatically locked in some cases I believe. You need to enable coin control to check which UTXOs you are actually trying to spend here, and make sure they did not end up locked somehow
 
I seem to recall that a masternode's collateral (1000 Dash) gets automatically locked when its run
with masternode=1 in the Dash.conf (to avoid people accidentally spending that 1000 Dash).

You could try starting the wallet with masternode=0 to see if it gets unlocked or try using coincontrol
to manually release that lock.
 
Back
Top