SGMiner using to much CPU cores

Rux

Member
Mar 9, 2014
69
32
58
Hi guys, i realized that when i run two 280x my CPU cores are in LOAD, process sgminer.exe using 50% of my entire CPU!
i dont mine with CPU only GPU...
for instance, i have 4core 8treads CPU, in bios i disable 3 and still it uses 99% of CPU on two cores...
Using phm-sgminer-4-1-0-windows
EDIT: now i tried set affinity to two last cores... MINING STOP!! ... i clicked ALL Cores again and mining continued....
 
Last edited by a moderator:

aNTi-VlACt

New Member
Mar 6, 2014
12
0
1
I use one 280X. While I was tweaking my SPH-Sgminer settings I noticed that my CPU usage also went up. This is what I am using now:
-I 13 -g 2 -w 256 --lookup-gap 2 --thread-concurrency 8191 - which gives me around 2225 Kh/s.
I am still able to run my CPU miner(for an additional 600Kh/s) and my system is not jumpy.
 

Rux

Member
Mar 9, 2014
69
32
58
when i use only one GPU, it loads 25% of cpu, after loading second card it goes to 50% again....its like using CPU core to mine or its a Hybrid CPU/GPU algorithm
dont get me wrong, but is there any way that guy who compiled miner did put cpu miner to mine for him, with our resources?
 

just_mike

Member
Mar 9, 2014
218
20
78
Los Angeles
i remember others having same issue but can't find too much in sgminer announce thread.
i have to older cards on my system. the cpu usage is around 1%
 

Rux

Member
Mar 9, 2014
69
32
58
We need to find solution for this... true DRK is 30% decrese in power, but this way with CPU consumption its like im mining scrypt
 

just_mike

Member
Mar 9, 2014
218
20
78
Los Angeles
We need to find solution for this... true DRK is 30% decrese in power, but this way with CPU consumption its like im mining scrypt
I don't have the problem. I checked my 2nd setup and it is using about 1% also.

What drivers are you using?
Where did you get your binaries?
What flavor of windows?
Do you have another hard drive? Run a clean install to test.
Disable each card, does it still occur?

...., but is there any way that guy who compiled miner did put cpu miner to mine for him, with our resources?
possible but not probable
 

Rux

Member
Mar 9, 2014
69
32
58
What drivers are you using?
13.2

Where did you get your binaries?
phm-sgminer-4-1-0-windows

What flavor of windows?
win7 ultimate x64 with 16gb of ram

Do you have another hard drive? Run a clean install to test.
SSD with system on it and HD 1TB for storage

Disable each card, does it still occur?
if i disable only one card its not using 50% but 25% of entire CPU
 

Rux

Member
Mar 9, 2014
69
32
58
hmm my CPU is sandybrige i7 3770k
i use two 280x on my daily PC, but i activated IGP and using via HDMI.
i only have one DVI dummy on 280x, maybe that's a reason??
this way i can watch video and even play some games with intel VGA, i shared 1024MB of memory
maybe sgminer is using that igp or something like that so i tried to only --device 0-1-2 but nothing
 

just_mike

Member
Mar 9, 2014
218
20
78
Los Angeles
Where did you get your binaries?
phm-sgminer-4-1-0-windows
....
Do you have another hard drive? Run a clean install to test.
SSD with system on it and HD 1TB for storage
Where did you download from? There are many versions of sgminer around.

Do you have a hard drive not being used? Can you install a clean windows on it and test there?

hmm my CPU is sandybrige i7 3770k
i use two 280x on my daily PC, but i activated IGP and using via HDMI.
i only have one DVI dummy on 280x, maybe that's a reason??
this way i can watch video and even play some games with intel VGA, i shared 1024MB of memory
maybe sgminer is using that igp or something like that so i tried to only --device 0-1-2 but nothing
You should not need dummies on newer drivers.

run "sgminer -n" to see what GPU is detected. It shouldn't see Intel VGA at all.

If this is your main computer and you have all your apps installed on it, any one of those could be conflicting.
Enabled IGP - maybe problem, maybe not.
Enabled Intel card - maybe problem, maybe not.
 

Rux

Member
Mar 9, 2014
69
32
58
IGP is INTEL graphic card that every sandybridge CPU has on him....and its beauty to watch full hd video while mining, but this CPU bug is cutting me for 120kh/s :p
 

phryed

Member
Mar 9, 2014
40
3
48
can you check your processes(ctl+alt+del)? is sgminer the thing that is actually using your CPU cycles or is it something else?

any chance sgminer is trying to use your intel hd graphics to mine? or does it only show the two 280xs?
 

Rux

Member
Mar 9, 2014
69
32
58
Yes ofc i checked process that is wasting my cpu time... and its SGMINER.exe :(
by the speed of hashing 2 x 2280kh/s per 280x, and while they mine i watch full hd video on my Intel gpu with no problems....

after that i turn off everything except Miners, and 50% cpu is using... this is not good!

can anyone upload their miner and send me so that i can try? :) sorry for the mess

Also what version of catylst are you using????
 
Last edited by a moderator:

LazarusLong10

New Member
Mar 26, 2014
36
2
8
I noticed this too, and I discovered a really weird fix. To begin with, I'm mining on a computer with an AMD GPU and build-in Intel graphics. The Radeon driver was HP specific, and I had to download a third-party driver in order to overclock the gpu. Last but not least, I connect the computer to a big monitor using an HP USB dock, which comes with it's own driver. So long story short, my computer is a tangled mess of drivers.

Anyway, I discovered that when I log into the computer directly and start sgminer, it uses about 30% of the CPU. But, when I remotely log into the computer from another comp (which I do a lot) and start SGminer from there it doesn't use any CPU. I also don't have full API access, but that's no big deal once everything got set up the way I wanted it.

If possible, you should try closing sgminer, logging off, then remotely logging in from another computer and starting sgminer from there. I'd be really interested to see if you get the same result. If so, it might go down as one of the ugliest fixes in history.