Sentinel does not work, could it be the cause of ban?

johnyj

New Member
Sep 23, 2017
16
1
3
42
Since two weeks ago my mn is not active until I noticed it recently,
And after upgrade to 18.0.1 my mn still not work

venv/bin/python bin/sentinel.py
Python 2.7 is not supported

And when I tried to update sentinel, another error appeared:

venv/bin/pip install -r requirements.txt
Downloading/unpacking deprecation==2.1.0 (from -r requirements.txt (line 1))
Cannot fetch index base URL https://pypi.python.org/simple/
Could not find any downloads that satisfy the requirement deprecation==2.1.0 (from -r requirements.txt (line 1))
Cleaning up...
No distributions at all found for deprecation==2.1.0 (from -r requirements.txt (line 1))
Storing debug log for failure in /home/johny/.pip/pip.log

Is it so that if sentinel is not working, then mn is banned?

If I run dash-cli masternode status, it shows everything ok, but if I run dash-cli mnsync status

"IsBlockchainSynced": false,
"IsSynced": false
 

splawik21

Yeah, it's me....
Dash Core Group
Foundation Member
Dash Support Group
Apr 8, 2014
1,965
1,327
1,283
What getblockchaininfo command gives you as a. response?
 

darkness

Member
Mar 9, 2014
46
10
48
For the python error, this is what I did:

1) Delete sentinel directory
2) apt install python virtualenv
3) Reinstall sentinel

Then it just worked... (before this I had stupidly installed python3 so I uninstalled that and then did these steps).

Also, if you want to redo the blockchain you can delete the "mncache.dat" file.
 
Last edited:

johnyj

New Member
Sep 23, 2017
16
1
3
42
For the python error, this is what I did:

1) Delete sentinel directory
2) apt install python virtualenv
3) Reinstall sentinel

Then it just worked... (before this I had stupidly installed python3 so I uninstalled that and then did these steps).

Also, if you want to redo the blockchain you can delete the "mncache.dat" file.
I get error: Unable to locate package virtualenv
 

johnyj

New Member
Sep 23, 2017
16
1
3
42
What getblockchaininfo command gives you as a. response?
{
"chain": "main",
"blocks": 1738697,
"headers": 1738697,
"bestblockhash": "00000000000000362d528545b40976af8a9b5380def57d63943a30a9379a5385",
"difficulty": 73244017.95390324,
"mediantime": 1663244460,
"verificationprogress": 0.9992588674192312,
"initialblockdownload": true,
"chainwork": "000000000000000000000000000000000000000000007871309887ec28a6e90a",
"size_on_disk": 31201501757,
"pruned": false,
"softforks": [
{
"id": "bip34",
"version": 2,
"reject": {
"status": true
}
},
 

qwizzie

Grizzled Member
Aug 6, 2014
2,016
1,185
1,183
These are normally the commands to install Sentinel (either as new or after having deleted the Sentinel folder) :

cd ~/.dashcore
git clone https://github.com/dashpay/sentinel.git
cd sentinel
virtualenv venv
venv/bin/pip install -r requirements.txt
venv/bin/python bin/sentinel.py

And this is the command to just update the Sentinel version from there on out :

cd .dashcore/sentinel
git pull

And yes, Sentinel not working will cause a PoSe ban.

Also having

"IsBlockchainSynced": false,
"IsSynced": false

indicates a sync problem. Check this article for problem solving, if you keep having a sync problem as well : https://dev.to/dcgcrew/dash-core-v18-whats-new-4a3d
 
Last edited:

johnyj

New Member
Sep 23, 2017
16
1
3
42
These are normally the commands to install Sentinel (either as new or after having deleted the Sentinel folder) :

cd ~/.dashcore
git clone https://github.com/dashpay/sentinel.git
cd sentinel
virtualenv venv
venv/bin/pip install -r requirements.txt
venv/bin/python bin/sentinel.py

And this is the command to just update the Sentinel version from there on out :
It is this command brings the error:
venv/bin/pip install -r requirements.txt
Downloading/unpacking deprecation==2.1.0 (from -r requirements.txt (line 1))
Cannot fetch index base URL https://pypi.python.org/simple/
Could not find any downloads that satisfy the requirement deprecation==2.1.0 (from -r requirements.txt (line 1))
Cleaning up...
No distributions at all found for deprecation==2.1.0 (from -r requirements.txt (line 1))

And in the log:
venv/bin/pip run on Sat Sep 17 21:08:24 2022
Downloading/unpacking deprecation==2.1.0 (from -r requirements.txt (line 1))
Getting page https://pypi.python.org/simple/deprecation/
Could not fetch URL https://pypi.python.org/simple/deprecation/: 403 Client Error: SNI is required
Will skip URL https://pypi.python.org/simple/deprecation/ when looking for download links for deprecation==2.1.0 (from -r requirements.txt (line 1))
Getting page https://pypi.python.org/simple/
Could not fetch URL https://pypi.python.org/simple/: 403 Client Error: SNI is required
Will skip URL https://pypi.python.org/simple/ when looking for download links for deprecation==2.1.0 (from -r requirements.txt (line 1))
Cannot fetch index base URL https://pypi.python.org/simple/
URLs to search for versions for deprecation==2.1.0 (from -r requirements.txt (line 1)):
* https://pypi.python.org/simple/deprecation/2.1.0
* https://pypi.python.org/simple/deprecation/
Getting page https://pypi.python.org/simple/deprecation/2.1.0
Could not fetch URL https://pypi.python.org/simple/deprecation/2.1.0: 403 Client Error: SNI is required
Will skip URL https://pypi.python.org/simple/deprecation/2.1.0 when looking for download links for deprecation==2.1.0 (from -r requirements.txt (line 1))
Getting page https://pypi.python.org/simple/deprecation/
Could not fetch URL https://pypi.python.org/simple/deprecation/: 403 Client Error: SNI is required
Will skip URL https://pypi.python.org/simple/deprecation/ when looking for download links for deprecation==2.1.0 (from -r requirements.txt (line 1))
Could not find any downloads that satisfy the requirement deprecation==2.1.0 (from -r requirements.txt (line 1))

I think this is a python problem but so far did not find a solution to it, and why it worked last month? Something must have changed in the latest sentinel update that broke this
 
Last edited:

johnyj

New Member
Sep 23, 2017
16
1
3
42
sudo apt-get update
sudo apt-get install virtualenv
I get this
# apt-get install virtualenv
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package virtualenv

Some posts on stackoverflow says the package is called python-virtualenv, that is already installed

The node is running an old ubuntu 14.04, but it rans well until two weeks ago
 

johnyj

New Member
Sep 23, 2017
16
1
3
42
"IsBlockchainSynced": false,
"IsSynced": false

indicates a sync problem. Check this article for problem solving, if you keep having a sync problem as well : https://dev.to/dcgcrew/dash-core-v18-whats-new-4a3d
Thanks, after invalidate and reconsidered the block 1737792, now it syncs with the latest block, but sentinel could not run due a problem with python, it says does not support python 2.7, and after I compiled the latest python 3.10, it can not generate venv, saying the package virtualenv could not be located
 

AgnewPickens

Administrator
Chief Sock Advisor
Mar 11, 2017
608
315
133
58
I get this
# apt-get install virtualenv
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package virtualenv

Some posts on stackoverflow says the package is called python-virtualenv, that is already installed

The node is running an old ubuntu 14.04, but it rans well until two weeks ago

I think v18 needs a newer Linux Distro than 14.04, a lot of users are using Linux 20 distros, think there may be some things missing from 14.04 that v18 needs.
 

johnyj

New Member
Sep 23, 2017
16
1
3
42
I think v18 needs a newer Linux Distro than 14.04, a lot of users are using Linux 20 distros, think there may be some things missing from 14.04 that v18 needs.
Maybe, but now it seems only a sentinel problem with configurations in python, the node itself syncs fine now after refreshed the forked block 1737792

Do you really need sentinel or it is just for self-monitoring purpose? I can see my mn now on both dashninja and DC
 

AgnewPickens

Administrator
Chief Sock Advisor
Mar 11, 2017
608
315
133
58
Maybe, but now it seems only a sentinel problem with configurations in python, the node itself syncs fine now after refreshed the forked block 1737792

Do you really need sentinel or it is just for self-monitoring purpose? I can see my mn now on both dashninja and DC

Not sure how important Sentinel is, but there have been other issues with Linux Distros, 22.04 dropped some libraries V18 needed and that caused some problems. Glad you have it syncing, I am am not a masternode owner, so maybe somebody else can answer that last question. @xkcd ?
 
  • Like
Reactions: xkcd

johnyj

New Member
Sep 23, 2017
16
1
3
42
I managed to update the pip to version 20.3.4 and then pip command become this:

~/.dashcore/sentinel# venv/bin/pip install -r requirements.txt
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Collecting deprecation==2.1.0
Downloading deprecation-2.1.0-py2.py3-none-any.whl (11 kB)
ERROR: Could not find a version that satisfies the requirement packaging==21.3 (from -r requirements.txt (line 2)) (from versions: 14.0, 14.1, 14.2, 14.3, 14.4, 14.5, 15.0, 15.1, 15.2, 15.3, 16.0, 16.1, 16.2, 16.3, 16.4, 16.5, 16.6, 16.7, 16.8, 17.0, 17.1, 18.0, 19.0, 19.1, 19.2, 20.0, 20.1, 20.2, 20.3, 20.4, 20.5, 20.6, 20.7, 20.8, 20.9)
ERROR: No matching distribution found for packaging==21.3 (from -r requirements.txt (line 2))

And after checking the requirements.txt, these are the files that pip can not install, marked with *. I tried manually install each of them

deprecation==2.1.0
packaging==21.3*
peewee==3.14.10
py==1.10.0
pycodestyle==2.4.0
pytest==7.0.1 *
pyparsing==3.0.9 *
python-bitcoinrpc==1.0
simplejson==3.8.2
 
Last edited:

darkness

Member
Mar 9, 2014
46
10
48
Radical plan, but just to make sure you have the right python...

1) sudo apt remove python2
2) sudo apt autoremove --purge
3) python --version (you should get nothing because it's uninstalled - if it says version 3 then get rid of that too)
4) sudo apt update
5) sudo apt install python2 python
 

xkcd

Active Member
Masternode Owner/Operator
Feb 19, 2017
453
430
133
australia
mnowatch.org
Dash Address
XpoZXRfr2iFxWhfRSAK3j1jww9xd4tJVez
Not sure how important Sentinel is, but there have been other issues with Linux Distros, 22.04 dropped some libraries V18 needed and that caused some problems. Glad you have it syncing, I am am not a masternode owner, so maybe somebody else can answer that last question. @xkcd ?
Ubuntu 22 LTS is now supported, the issue impacting was recently resolved. The OP is recommended to re-install the OS, eg Ubuntu 22 LTS and then run the Dash Masternode Zeus for clean operations.
 
  • Like
Reactions: AgnewPickens

johnyj

New Member
Sep 23, 2017
16
1
3
42
Ubuntu 22 LTS is now supported, the issue impacting was recently resolved. The OP is recommended to re-install the OS, eg Ubuntu 22 LTS and then run the Dash Masternode Zeus for clean operations.
What is the purpose of sentinel? Can you just remove it?
I remember that sentinel was there for old masternode architecture, but after the dip3 change, the way how masternode works has greatly changed, is there still a need for sentinel?

I have been running it for 12 hours without sentinel working, the node still syncs without problem and registered on mn list
 

qwizzie

Grizzled Member
Aug 6, 2014
2,016
1,185
1,183
Lets hope a dev jumps in with regards to possible missing supportive libraries in 14.04, causing a failed Sentinel installation with Dash Core v18.0.1
You can raise a github issue about it here : https://github.com/dashpay/dash (that should get the attention of the devs)
Also you could upgrade your system to 18.04.6 LTS and see if that fixes things with Sentinel.

I am running that OS version without a problem with regards to Sentinel so far. I do remember seeing that deprecation notice of Python 2.7 but it does not throw an error and installs fine.

I worry that over time you will end up with PoSe scores, when Sentinel is not active.
 
Last edited:

xkcd

Active Member
Masternode Owner/Operator
Feb 19, 2017
453
430
133
australia
mnowatch.org
Dash Address
XpoZXRfr2iFxWhfRSAK3j1jww9xd4tJVez
What is the purpose of sentinel? Can you just remove it?
I remember that sentinel was there for old masternode architecture, but after the dip3 change, the way how masternode works has greatly changed, is there still a need for sentinel?

I have been running it for 12 hours without sentinel working, the node still syncs without problem and registered on mn list
Sentinel is not required.
 

johnyj

New Member
Sep 23, 2017
16
1
3
42
Lets hope a dev jumps in with regards to possible missing supportive libraries in 14.04, causing a failed Sentinel installation with Dash Core v18.0.1
You can raise a github issue about it here : https://github.com/dashpay/dash (that should get the attention of the devs)
Also you could upgrade your system to 18.04.6 LTS and see if that fixes things with Sentinel.

I am running that OS version without a problem with regards to Sentinel so far. I do remember seeing that deprecation notice of Python 2.7 but it does not throw an error and installs fine.

I worry that over time you will end up with PoSe scores, when Sentinel is not active.
I really think that is just a configuration problem, since I have other services running on that 14.04 machine, it will impact lots of other legacy environments if I upgrade the OS, so I hope that just by installing the required package, the sentinel.py could run.

Now the sentinel.py just throws "Python 2.7 is not supported", but it seems it works on your machine, that's odd