Not capable masternode: Could not connect to <ip>:<port>

Dworf

Member
Jun 25, 2016
103
37
78
55
I use DashCore to setup a masternode (Dash Core Version v0.12.0.58 (64-Bit)) under Windows 10.
I followed this guide: https://www.dash.org/forum/threads/guide-simple-masternode-on-a-windows-machine.7956/
Everything works fine except that I cannot start the masternode and continuesly get this error:
"Not capable masternode: Could not connect to 191.168.0.111:9999"

my dash.conf looks like:

rpcuser=RANDOMLETTERSANDNUMBERS
rpcpassword=MORERANDOMLETTERSANDNUMBERS
rpcallowip=127.0.0.1
listen=1
server=1
daemon=1
logtimestamps=1
maxconnections=256
masternode=1
masternodeprivkey=7qvh86fiWWqRZmLCxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx​


any ideas on that?
 

UdjinM6

Official Dash Dev
Dash Core Team
Moderator
May 20, 2014
3,639
3,537
1,183
You masternode has to be accessible from the outside this means that you need to have port 9999 open and forwarded on your router.

On a side node, this guide assumes that you have your PC always on i.e. you need your local wallet with 1000 DASH to be online 24/7 and unlocked which I DON'T recommend for obvious security reasons. This also assumes that your IP is static i.e. IP is always the same which is NOT true for regular home internet connections. Having said all this you might want to consider setting up masternode via @TaoOfSatoshi 's Guide instead (will require using any ~$5/mo VPS for your MN but it completely worth it imo).
 

Dworf

Member
Jun 25, 2016
103
37
78
55
@UdjinM6
thank you - it was just a quick try after VULTR rejected all my credit cards and does not allow Bitcoin for the first payment ;)
 
Last edited: