My Electrum Wallet needs updating - I think!

Marster

New Member
Jul 3, 2017
5
0
1
50
Greetings all - this is my first post! My Electrum Wallet has been struggling to synchronise recently after 6 months of use. Perhaps it needs updating? Any advice greatly appreciated as I'm worried about losing my Dash!
 

akhavr

Active Member
Oct 11, 2014
758
376
133
Greetings all - this is my first post! My Electrum Wallet has been struggling to synchronise recently after 6 months of use. Perhaps it needs updating? Any advice greatly appreciated as I'm worried about losing my Dash!
What version of dash-electrum are you using?
 

Marster

New Member
Jul 3, 2017
5
0
1
50
2.4.1 - thanks - what next! If I upgrade (how?) will me dash be transferred automatically? Much appreciate the help!
 

akhavr

Active Member
Oct 11, 2014
758
376
133
2.4.1 - thanks - what next! If I upgrade (how?) will me dash be transferred automatically? Much appreciate the help!
You definitely need to upgrade. Current version is 2.6.4.

What OS are you on?

Be sure to back up your wallet files before upgrade.
 

Marster

New Member
Jul 3, 2017
5
0
1
50
Once again thanks so much for helping an old luddite! Any advice on how to back-up?.....
 

tungfa

Administrator
Dash Core Team
Moderator
Foundation Member
Masternode Owner/Operator
Apr 9, 2014
8,972
6,740
1,283
u have a recovery seed for electrum
thatbis all u need !
keep that save