Help. I can't get sgminer to work on some systems

bspus

New Member
Mar 30, 2014
12
0
1
Hello
I have 4 gpus on 4 different systems. A 5770, a 7770, a 7970 and a 7950

I have gotten sgminer to work on 2 systems (5770 on windows server 2012 and 7770 on windows 7) but I'm having trouble with the other two (on windows 8 32 and 64 bit)

At first, I could get sgminer to run (using phm-sgminer-4-1-0-windows on all systems) but I would only get hardware errors on the 7970 and 7950. The other two worked almost immediately and I've been getting around 600Kh each.
I read on another forum that it can happen with old drivers so I upgraded. The two working systems had 13.12 driver with 2.8 sdk so I put the same on my other two systems.
Now neither of them works at all! sgminer just crashes after the "darkcoin kernel is experimental" line
This happens regardless of whatever parameters I choose regarding intensity, thread concurrency, worksize etc

Any clues where I should be looking?
 

jakecrow

New Member
Mar 30, 2014
25
3
3
I've never tried win8 so if there's something specific there I can't help, but to start what's your .conf or command line look like?

As far as drivers I've never bothered with the sdk on any of my miners and they work fine so that's something to possibly eliminate. I also think the 13.11 beta 9.5 drivers work best for mining, I've personally had a few issues with the 13.12 version. You may try uninstalling ALL AMD software and installing the 13.11 beta 9.5 drivers (http://www.guru3d.com/files_details/amd_catalyst_13_11_beta_9_5_driver_download.html) and see if that helps.
 

bspus

New Member
Mar 30, 2014
12
0
1
I uninstalled all amd software and installed 13.11 beta 9.5 as instructed above. I still get the same error, which is a pop up window saying that sgminer has stopped working
 

Sub-Ether

Well-known Member
Mar 31, 2014
1,516
1,256
183
Post your config settings, it will stop us guessing. SDK 2.7 is more stable for older graphics cards in my experience, did you say 1 of the systems is a 32 bit win8? must be 64 bit for more compatibility ..
 

bspus

New Member
Mar 30, 2014
12
0
1
7950, windows 8 32 bit 13.11 beta 9.5 driver (tried 13.12 too)
sgminer -k darkcoin -o stratum+tcp://drkpool.com:3333 -u bspus.2 -p 1234 -I 15 -w 128 --thread-concurrency 18000
Stops soon after "darkcoin kernel is experimental" message, with a pop up saying sgminer has stopped working

7970, windows 8 64bit driver 13.12 (tried 13.1 too)
sgminer -k darkcoin -o stratum+tcp://drkpool.com:3333 -u bspus.1 -p 1234 -I 13 -w 256 --thread-concurrency 8192
Exactly the same error as above

7770, windows 7 32bit driver 13.12
sgminer -k darkcoin -o stratum+tcp://drkpool.com:3333 -u bspus.4 -p 1234 -I 15 -w 256 --thread-concurrency 11200
Works at about 600Kh. Though Intensity is at 13 regardless of what i specify and it seems to be working with 2 thread though I did not specify that either

5770, windows server 2012 (r1) 64 bit (only one there is anyway) driver 13.12
sgminer -k darkcoin -o stratum+tcp://drkpool.com:3333 -u bspus.3 -p 1234 -I 14 -w 256 --thread-concurrency 11200
Works, again exactly as the same way as the 7770 above

No conf settings, just batch files
SDK is 2.8 for all of them. On the first system with the 7950, I removed all amd software before installing the 13.11 b9.5 driver and did not install any sdk again. Yet scrypt mining is working and I thought it requires SDK. Maybe it somehow stayed in but the catalyst uninstall manager does not show it and neither does the windows programs list
 

Sub-Ether

Well-known Member
Mar 31, 2014
1,516
1,256
183
Firstly SDK already comes with some versions of catalyst driver that you mention.(can delete it from control panal and/or over install sdk 2.7)
and sgminer defaults at 2 threads unless you specify otherwise.
Although I suspect your problem lies elsewhere, your older cards are working, and scrypt is working which is important, what I suggest is, you use another version of sgminer(such as sph master or 'dirty'), my version is NOT the one on the first page(that does not work for my 5850 and 6950), there are other compilations, get them and try them on the 64 bit version first.
tip for you, check the .bin file in the sgminer folder after running and you can see how many threadconcurrency you can run (look after tc),
 

FreeOne

Member
Mar 28, 2014
44
1
48
I think anything after V12 has SDK included.

I find some cards are finicky with drivers especially R9 290x. I use old MSI ones for those, so keep track of which drivers you try.

Also, important, when you uninstall the drivers and install new ones, make sure you:

1) Go to device manager, click on view (show hidden), and remove the AMD stuff under Plug and Play (windows 7)
2) Clean your registry. (clean registry fixes alot of problems) I reccomend CCCleaner
3) You can use CGWatcher and watch the log to see what the error is...
4) Not sure if sgminer has a debug command, cgminer did and it can help solve problems.
 

FreeOne

Member
Mar 28, 2014
44
1
48
It's definatly either a driver issue or a config file issue.

Also try just launching your config with a .bat file, with only your connection settings, and let sgminer default all your settings.

If the above works, it's a config setting if it doesn't re-install the drivers, but clean them out first like I said above. And keep track of what drivers work and don't work (can be a tedious process).

Some R9 290x's I have work very well on some old MSI Drivers (2800 kh/s), and on other drivers they are not nearly as stable.

But the 290x's seem to be finicky.
 

bspus

New Member
Mar 30, 2014
12
0
1
I tried some sph version by badman74, which I found here (the most recent)
https://bitcointa.lk/threads/ann-dr...ulti-algo-gpu-miner-myr-groestl-added.264612/

And it works now. Thanks a lot :)
My 7950 averages about 1.382Mh with an intensity 16 (intensity value seems to work with this build), which is roughly 3x my scrypt hashrate with the same settings.
I didn't want to go higher with scrypt because I like to keep temp at below 70 and fan noise relatively low, but since this miner runs a lot cooler I just might try. Whats a decent hashrate for a 7950, about 1.6 Mh?

I'll try the 7970 tomorrow when I physically get to it.

I should probably try this version with my other cards to compare and contrast
 

Sub-Ether

Well-known Member
Mar 31, 2014
1,516
1,256
183
great you've got it working-now for the fine tuning,my mate gets 2 meg on each of his 7950, temps no problem on X11 set I to upto 20 and try --gpu-autotune 20 on the end of your .bat command(warning you will use slightly more power) , I get around 1.4-1.7meg on 6950's so you should definitely be higher. The sph version does not gpu-autotune on my machine setup, try the 'dirty' version, works well for me (lol)
 

22naru

New Member
Mar 22, 2014
8
0
1
i'm looking to get 2Mh/s on my MSI R7950 TF3 but i can get only 1850 stable ... if your mate can share some config. will be grate ... he use Xintensity or I ? cheers