electrum-dash doesn't work with hardware wallets in linux

camosoul

Grizzled Member
Sep 19, 2014
2,266
1,130
1,183
Trezor works flawlessly with Firefox/trezor-bridge/trezor-udev.

Also works flawlessly with dashmnb.

Unplug trezor, close Firefox.

Re-plug trezor.

Portable Electrum-DASH is broken. Complains about Python module DNS missing, no such module exists as far as pip3/pip is concerned, so giving up.

Installed the "development" version from git instead.

Code:
Development version
===================

Check out the code from Github::

    git clone https://github.com/akhavr/electrum-dash.git
    cd electrum-dash

Run install (this should install dependencies)::

    python3 setup.py install

Compile the icons file for Qt::

    sudo apt-get install pyqt5-dev-tools
    pyrcc5 icons.qrc -o gui/qt/icons_rc.py

Compile the protobuf description file::

    sudo apt-get install protobuf-compiler
    protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto

Create translations (optional)::

    sudo apt-get install python-pycurl gettext
    ./contrib/make_locale
Process proceeds flawlessly.

Code:
./electrum-dash
Works! No whining about silly nonsense.

BUT...

When one reaches the point of initial wallet setup where you select hardware wallet and hit next, it claims no libraries for any hardware wallets were found.

Which is obviously untrue because wallet.trezor.io is working perfectly...

So is dashmnb...

lsusb shows properly identified TREZOR...

18.04

Derp...
 
Last edited:

camosoul

Grizzled Member
Sep 19, 2014
2,266
1,130
1,183
So, after googling it generically, I accidentally found that there's a ppa hosted by @akhavr

dash.org takes you to a tarball, with no mention of the ppa anywhere...

Standalone electrum website uncertain since there was a fake for a while...

So, I tried to purge the mess from the tarball... (Maybe that's the problem?)

then did the ppa thing...

still doesn't work...

Code:
[email protected]:~$ electrum-dash
Traceback (most recent call last):
  File "/usr/bin/electrum-dash", line 97, in <module>
    from electrum_dash.util import set_verbosity, InvalidPassword, check_www_dir
ImportError: cannot import name 'check_www_dir'
[email protected]:~$
I did a purge, autoremove, and reinstall in combination with a reboot... No effect. Same error persists.
 
Last edited:

camosoul

Grizzled Member
Sep 19, 2014
2,266
1,130
1,183
PPA installation method is preferred and documented as such here: https://docs.dash.org/en/latest/wallets/electrum/installation.html
Yeah, I found it eventually.
The official dash.org site leads to the tarball and no mention of the PPA anywhere.
See for yourself.
https://www.dash.org/wallets/#wallets
Click Linux tab, tarball is all there is...

I don't know if goofing around with all the stuff that doesn't work in that tarball is what's causing the problem or not, but installing from the PPA results in fail.
Code:
[email protected]:~$ electrum-dash
Traceback (most recent call last):
  File "/usr/bin/electrum-dash", line 97, in <module>
    from electrum_dash.util import set_verbosity, InvalidPassword, check_www_dir
ImportError: cannot import name 'check_www_dir'
[email protected]:~$
I went to / and did sudo find | grep "electrum-dash" and sudo rm everything found (nuke it from orbit, just to be sure).

But, no impact. The PPA source does it's install with no errors reported, and it doesn't work as seen above.
 
Last edited:

strophy

Administrator
Dash Core Team
Moderator
Dash Support Group
Feb 13, 2016
705
402
133
Please ping @tungfa for anything relating to dash.org - I agree links to documentation could be more prominent. Something to consider as the website is refreshed this year...
 
  • Like
Reactions: tungfa

akhavr

Active Member
Oct 11, 2014
758
376
133
I don't know if goofing around with all the stuff that doesn't work in that tarball is what's causing the problem or not, but installing from the PPA results in fail.
Code:
[email protected]:~$ electrum-dash
Traceback (most recent call last):
  File "/usr/bin/electrum-dash", line 97, in <module>
    from electrum_dash.util import set_verbosity, InvalidPassword, check_www_dir
ImportError: cannot import name 'check_www_dir'
[email protected]:~$
Well, as you might guess, it works on my (and not just mine) system w/o issues.

I'll check the trace and will try to reproduce. What system are you on?
 
  • Like
Reactions: tungfa

camosoul

Grizzled Member
Sep 19, 2014
2,266
1,130
1,183
I'll check the trace and will try to reproduce. What system are you on?
Xubuntu 18.04

My marginally educated guess is that some module that is normally a default part of python isn't being installed... But no idea how to check that or do anything about it since virtually nothing is ever documented in Linux these days...
 

akhavr

Active Member
Oct 11, 2014
758
376
133
Xubuntu 18.04

My marginally educated guess is that some module that is normally a default part of python isn't being installed... But no idea how to check that or do anything about it since virtually nothing is ever documented in Linux these days...
No, this is pretty strange traceback and it is not related to any module missing.

Right now we're finalizing 3.1.3 release and then will try to reproduce your specific case.
 

akhavr

Active Member
Oct 11, 2014
758
376
133
@camosoul do you have something dash-electrum-specific in `/usr/local`? If yes - it is polluting your namespace and causing errors. Try removing it and reinstalling from ppa.